Previous 1 2 3 Next 421 Replies Latest reply: Aug 18, 2013 8:29 AM by rgotty
ilovecode Level 1 Level 1

Hey guys,

 

I have the following problem:

 

after I wake my 17" MacBook Pro 8,3 (early 2011) from sleep by opening the lid, it starts searching for a WiFi network to join. It will just keep searching and searching, without ever finding anything. When I try to click on the WiFi icon in the menubar I get the beachball, also the System Preferences are affected by this crash - I can't go to "Network", it also beachballs. The only way out is a restart.

 

To prevent this from happening I can disable WiFi before putting my mac to sleep, but that's quite inconvenient. I have disabled all Auto Proxies, tried to delete the known networks from both the Network pane and the Keychain.

 

 


MacBook Pro (17-inch Early 2011), OS X Mountain Lion
Solved by ilovecode on Jul 28, 2012 1:22 AM Solved

Ok, I finally fixed this myself.

 

Go to "System Preferences > Network" and select the WiFi-Service from the list on the left. Select "Options" from the bottom right of the right pane. In this window, delete all the known Networks and hit OK. Then go ahead and delete the WiFi device. Create a new WiFi device and you're done.

  • ilovecode Level 1 Level 1

    Ok, I finally fixed this myself.

     

    Go to "System Preferences > Network" and select the WiFi-Service from the list on the left. Select "Options" from the bottom right of the right pane. In this window, delete all the known Networks and hit OK. Then go ahead and delete the WiFi device. Create a new WiFi device and you're done.

  • durgani Level 1 Level 1

    Hi, has you wifi connectivity been stable (between sleeps) since you last posted your fix?

  • dzatona Level 1 Level 1

    Hi there,

     

    I've tried this fix — nothing happened. Still having this issue =(

    Connection is NOT stable =(

  • primalman Level 1 Level 1

    I have tried this top. Still network freezes after wake from sleep on mid-2009 MBP.  Not good. Going to go back to Lion I think.

  • David Parmet Level 1 Level 1

    worked for me!  thanks!!!!!

  • dzatona Level 1 Level 1

    It seems to be (imho) that this problem is caused by the new background update system that was first introduced in 10.8 version. I am inclined to think so because after a «short» sleep system works perfectly, but after a «long» sleep wi-fi freezes, becoming a beachball =(

  • primalman Level 1 Level 1

    I have an addition.

     

    Check to see if you have an older pre-version 7 version of parallels installed. I checked another suggestion which was to delete to network preferences in the library folder. When reviewing those files I noticed that the parallels network interfaces were listed. On a hunch I upgraded to parallels 7 which I already purchased which parallels says is now mountain lion compatible, the only version that is certified. After a few sleep-then-wake tests on my MBP it looks to have fixed the issue. I'll report back if this changes back to the previous behavior and which Wi-Fi and the networking preference pane would freeze.

     

    Fingers crossed!

  • primalman Level 1 Level 1

    Never mind. New test with a much longer sleep has the freeze.

     

    What could this be?

  • primalman Level 1 Level 1

    Another odd thing that is associated with the wifi freeze is that when this happens, I cannot launch any apps. Tis lasts wifi freeze became a system wide thing when activity monitor, the force quit window and the finder all beachballed and I could not launch apps at all. Only a hold the power button shutdown worked.

     

    This is super annoying.

  • dzatona Level 1 Level 1

    primalman, yep, this is quite similar to what I have, short sleep is OK, long one — we've got a freeze( no idea how to fix it(

  • Dr_David Level 1 Level 1

    I posted about something similar here:  https://discussions.apple.com/thread/4141159?tstart=0

     

    But, rebuilding the wifi in network settings didn't solve it for me.

  • primalman Level 1 Level 1

    I am reinstalling ML now, just to see. But, after a bit kore researching, has anyone tried to change the ipv6 setting to local only? Things imam seeing seen to suggest that there might be issues with this. As soon as I am back up I am going to run my usual wifi freeze tests, then change my ipv6 settings.

  • RevChris Level 1 Level 1

    Same problem here - glad I'm not alone - maybe Apple will send a fix.  I followed the proposed solution, so we'll see if that does anything.  But after seeing the replies on this thread, I'm not hopeful.

  • dzatona Level 1 Level 1

    Most likely that this fix will not affect deep sleep problem. Still monitoring my own laptop and refreshing the feed in hope to see the solution... Will see tomorrow, because I don't know what time exactly needed for mb pro to go to deep sleep instead of short one.

Previous 1 2 3 Next