Skip navigation

Mountain Lion no Wifi after wake from sleep

101374 Views 421 Replies Latest reply: Aug 18, 2013 8:29 AM by rgotty RSS
  • kreme Level 1 Level 1 (35 points)
    Currently Being Moderated
    Jul 29, 2012 3:56 PM (in response to primalman)

    primalman wrote:

     

    I am reinstalling ML now, just to see. But, after a bit kore researching, has anyone tried to change the ipv6 setting to local only? Things imam seeing seen to suggest that there might be issues with this. As soon as I am back up I am going to run my usual wifi freeze tests, then change my ipv6 settings.

     

    I'm game. Just set it now and will get back to you to see if it solves my issue. This has been annoying me since Lion and the only fix I've been able to come up with so far is to turn wi-fi off for 10 seconds and then turn it back on.

  • primalman Calculating status...
    Currently Being Moderated
    Jul 29, 2012 4:11 PM (in response to kreme)

    So it does not seem to help. I did the reinstall, then changed the ipv6 thing. Same progressive hard freeze when trying to reconnect wifi after sleep for about 3 mins.

     

    Going to restore to lion. Disappointing.

  • dzatona Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 29, 2012 4:13 PM (in response to primalman)

    Lets determine what is deep sleep? I've closed a lid for almost one hour and everything is working fine. Will close for all night long and then see what will happen.

  • kreme Level 1 Level 1 (35 points)
    Currently Being Moderated
    Jul 29, 2012 4:30 PM (in response to dzatona)

    For me, it's anything after an hour. My mac mini misbehaved at first when I installed Lion. Then it just worked after that. My MacBook Air was fine until I messed around with it and had to re-install Lion. Wi-Wi's been an issue since. I thought ML might correct it and it appeared to do so on the first day, but it's right back to misbehaving again.

     

    My encryption is WPA-2. Come to think of it. I changed it from WEP around the same time I re-formatted. I haven't turned my mini on since I did all this, and I don't have the same problems when I'm at work (I don't know what kind of encryption they're using, if any at all). I'm beginning to wonder. I won't be opening my Air on for a few minutes. I'll see how the IPv6 change goes and go from there.

  • Dr_David Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jul 29, 2012 4:31 PM (in response to kreme)

    1 Hour would suggest that possibly Time Machine is involved? Maybe it's turning itself on to back up, going back to sleep.. But, when you wake it up manually, things go wonky.

     

    Possible?

  • kreme Level 1 Level 1 (35 points)
    Currently Being Moderated
    Jul 29, 2012 4:37 PM (in response to Dr_David)

    Would I have to be using Time Macine?

     

    I've always used Apple Script and Automator along with rsync commands to do my backups. I'm a it old school. If Time Macine is somehow involved, how would I go about correcting this and why did it only happen after I did a clean re-install of Lion?

     

    About the only changes I've made are with my router's encryption and I chose not to install MS Office this time around

  • dzatona Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 29, 2012 4:40 PM (in response to Dr_David)

    No, Time Machine is not enabled. Now closing the lid, will see tomorrow what will happen, and then post here. Thanx!

  • primalman Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 29, 2012 4:55 PM (in response to Dr_David)

    I don't have Time Machine enabled either. I've been trying to look over the console logs just to see if there's anything I can't quite find anything that looks like anything. At least to my untrained eye. There seems to be a lot of little errors but nothing that just screams out Wi-Fi or something. Can somebody who knows more about reading console logs take a look? Still going to go back 10.7 at least for now.

  • kreme Level 1 Level 1 (35 points)
    Currently Being Moderated
    Jul 29, 2012 6:37 PM (in response to primalman)

    Well, it's been over two hours of my Air being in sleep now and I just opened my laptop to see if the IPv6 fix worked. So far, so good. The real test will come on Tuesday when I re-connect at work and then come back home to try to re-connect.

  • primalman Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 29, 2012 6:52 PM (in response to ilovecode)

    This is weird. I decided to make another admin user, logged out of my main user account and tried to recreated the issues in the new account. The first re squire of the wifi took a bit and I thought it would hang like before. Then it came back. I even did the delete keychain items to boot. Tried a few more times with lid closed, etc. worked fine. Logged out of new user. Logged back into old admin user, my normal account. Everything seems fine. I hope. Will do a longer sleep test now and see. What would doing keychain management in another admin user do to this situation? I dunno.

  • Jonas Kaplan Calculating status...
    Currently Being Moderated
    Jul 29, 2012 7:35 PM (in response to primalman)

    I have these exact symptoms.

     

    I'm not really convinced that it's network related, even though the Airport thing does seem to be searching for a network.  When its hung, I can't do anything in Safari, but from the terminal I can tell that I am actually connected to the network (ifconfig), and I can ping my router, perform DNS lookup, etc.even though the Airport icon is not completed.   

     

    I tried killing SystemUIServer, since that controls those menubar items, but this didn't really help.  SystemUIServer didn't restart itself. 

     

    Still investigating. 

  • primalman Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 29, 2012 7:57 PM (in response to primalman)

    Nope. Bonked on second wake up. Restoring to lion clone now. I did the terminal snoop like above poster too and see that I am pulling an ip address, but the menu bar and safari, Firefox and mail all go kablooee.

  • FishNYC22 Calculating status...
    Currently Being Moderated
    Jul 29, 2012 8:31 PM (in response to ilovecode)

    I'm having the exact same issue. Waking the machine from sleep and it hangs trying to connect to the network. Seems to kill everything. Last time it happened I had to hard restart the machine. (hate doing that).

     

    Are we certain that its the network connection process that is causing the issue or is it just happening within those first few seconds of wake when the machine is still looking for the wifi network.

     

    I had a weird thing happen right after I installed mountain lion where Panic's Transmit would hang when I started it up. Transmit has been open each time this happened but I doubt its related. However figured its worth mentioning.

     

    Hope we figure this out soon.

     

    BTW, I'm on a 15" MBP (mid 2010 model)

     

    Fish

  • primalman Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 29, 2012 8:36 PM (in response to ilovecode)

    How do we officially notify apple of this issue? Any one know?

  • Dr_David Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jul 29, 2012 8:56 PM (in response to primalman)

    I filed a radr on it (a bug report); also, I've been harassing applecare.

     

    BUT, I'm wondering if there's a common LaunchDaemon or LaunchAgent?

     

    Here's my LaunchAgents and LaunchDaemons...  (click the image to see it all!)/___sbsstatic___/migration-images/migration-img-not-avail.png

     

    To see yours, go to Macintosh HD -> Libraries -> LaunchDaemons / LaunchAgents

     

    Is there a common program that's causing the issue?

1 2 3 4 ... 29 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (23)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.