Previous 1 18 19 20 21 22 Next 421 Replies Latest reply: Aug 18, 2013 8:29 AM by rgotty Go to original post
  • WildBill Level 3 Level 3
    Mac OS X

    Well that's obviously not the case. I'm running 10.8.2 and I STILL have this issue!

  • Cabel Level 1 Level 1

    The problem is that this thread is somehow talking about two separate issues at once!


    I'm referring to an issue where, when you wake your Mac from sleep, your entire system is frozen with a rainbow cursor and you have to hard reboot. That is fixed in 10.8.2.


    You're talking about an issue (I think?) where your WiFi is dropping out? That, I don't know anything about.




  • Gary Chelak Level 1 Level 1

    Hi Cabel,


    Yes, when waking my Mac from sleep with Transmit menu bar icon, it no longer causes wifi to be lost or a hard reboot.


    Thanks for following up,


  • msaaaa Level 1 Level 1

    I have the problem that with a prolonged sleep after awakening the wifi wouldn't connect and then most programs would crash requiring a reboot. I upgraded to 10.8.2  NO HELP!!!!!

    The only thing I have found that works is I manually turn off the track pad before the compute goes to sleep, when it wake it connects and i reconnect the track pad. A pain in the you know where but it only take 15 seconds, much less than the reboot.


    Apple please pay attention and fix this!!!

  • Herbert Schulz Level 1 Level 1



    I assume you are talking about the Apple's ``Magic Trackpad''. I recently had one that developed a bad switch that would occassionaly randomly click and drag all over the place. Replacing it with a new one (I love Applecare!) fixed up all of those problems.


    Good Luck,

    Herb Schulz

  • andylepandy Level 1 Level 1

    Found somesort of a fix...


    1. Open back of MacBook Pro up

    2. Take out RAM

    3. Press down on Wifi cables to ensure they are connected

    4. Put RAM back in

    5. Close up the back again

    6. Power back on


    Worked for me which I'm surprised by seeing I tried EVERY possible other solution from software to hardware, so I beleive it's not a Mountain Lion issue but far more a hardware issue. Hope this helps!

  • msaaaa Level 1 Level 1

    Ah! if only that easy I have an iMac no such easy fix

  • peterwillem Level 1 Level 1

    It seems there are several issues. I have a similar problem with different symptoms . The 2 things they all have in common are: Happens after upgrade to M.L.   and after waking up from sleep mode.

    My issue is that sometimes (every 2 or 3 days) my iMac freezes when browsing with safari. With me WiFi has little to do with it because I switched it off and am using Ethernet connection. Switching it on does make things happen more often. Also clearing the menubar from 3rd party software icons has improved things.

    Also set the computer sleeping mode to never in energy pref. helps, I only put the computer to sleeping mode via the Apple menu.

    At this moment I am testing :not using the safari browser, but chrome instead (as standard browser). So far it looks promising.

    I have an iMac so some things are easyer to do, on my MBP I still have Lion and that will remain so for some time.




  • WildBill Level 3 Level 3
    Mac OS X

    Yes, Cabel, you're correct.

  • msaaaa Level 1 Level 1

    unfortunately the only solution I have found that works so far for the last 2 days is to never sleep the computer.

  • asux Level 1 Level 1

    Yesterday I upgraded MBP 17" (end 2011 model) from Lion 10.7.5 (or .6?) to Mountain Lion 10.8.2 and have this problem since that time: Every time I send the system to sleep (either via the  menu or by closing the lid) it has the rainbow cursor after waking up again and can only be hard rebooted via the power switch. I have tried several solutions as suggested here but none helped


    - I do not have the mentioned Transition App ...

    - I removed Dropbox from the menu bar

    - I removed Funambol sync from the menu bar


    One time it occured when WiFi was off. That time I could even open the screen saver with my password before seeing the rainbow cursor. I also had a Terminal open and some commands worked without problems (e.g., df), others said "permission denied" (e.g. "ps") and others could not even be found by the shell (e.g., "ls") anymore.


    But I have some other facts:


    - I do have a second disk (first disk is SSD, second disk is 750GB SATA), second disk is/was just "encrypted" (by context menu "encrypt"), first disk is encrypted via file vault (is there any difference?). I am currently decrypting the second disk to see if that helps.

    - A similar problem occoured yesterday when switching on file vault for the boot disk yesterday ... in the middle of the encryption process some processes stopped working, even the encryption itself ... showed me the rainbow cursor, shell commands didn't work any longer etc. - only a hard reboot/power off helped. Fortunately the encryption continued after the reboot.

  • Andrew Harris1 Level 1 Level 1

    I too have a second ssd disk installed but I no longer have the problem.


    1) I removed all 3rd party toolbar icons

    2) deleted all my wifi connections and reset them


    I havn't metioned this one before... I noticed I was getting a repeated repeated error in my logs about the backlight so I shut off the setting to automatically adjust the backlight. I did this around the same time as the other things so it may be related.


    A colleague at work was having a similar issue as this thread... it was rectified for him by turning off the setting "put hard drive to sleep when possible"


    One last thing.... if you have two disks in your laptop you must have the boot disk in the hard drive bay or you will have wake from sleep issues.

  • Explorerguy Level 1 Level 1

    I don't think there's one definitive solution. I had the problem of wifi reconnecting after sleep, which I resolved by changing channels on my router, a while back. Last week, I installed an SSD. I bought an adaptor tray, so that I could use the optical bay (6gb SSD/3gb for the orig. HD). Problem returned, but was again resolved by changing router channels. No wake-from-sleep issues.

  • asux Level 1 Level 1

    I agree, there seem to be different causes to the same problem. I had a warranty (90 days after buy) call with Apple yesterday evening. They recommended to reinstall ML. I have done so but with no improvement.


    But I made some additional tests (MBP with SSD as primary and SATA as secondary disk - yes, I have removed the optical drive):


    Tested the following combinations with Boot from SSD

      - with different users

      - file system encrypted (file vault) and decrypted

    In any case ML didn't wake up from sleep. I had Terminal and Activity monitor open and still could see that some processes seemed to be working and others were not, at least for a short moment (e.g., AM told me Finder and Skype were not responding, while I could still call "df" from the open Terminal).


    If I install ML to the second drive (small "Rescue" partition) it woke up from sleep without any problem.

    So it seems to be an SSD related problem in my case. I will give the MBP to my local Apple reseller for extended testing tomorrow to make sure it is not a hardware issue (I twice had serious problems with the SSD itself during this whole problem: 1. The MBP aborted through the initial File Vault migrate after the ML install, 2. The ML re-install on the SSD yesterday failed for the first time, since the installer reported an un-repairable file system problem; I first had to boot from the second partition, repair the SSD file system and could re-install ML then).


    BTW: I do have those problems with and without network cable attached (and WiFi switched off all the time). So I think it is not related to the (wireless) network.


    Good luck to the others,



    Message was edited by: asux - fixed a typo

  • Andrew Harris1 Level 1 Level 1



    You probably installed your SSD in your optical drive and put your system on that drive... correct?


    When I was reasearching this upgrade they made note that if you did it this way you WILL have issues with waking from sleep. Basically the optical drive is not set up to wake the computer for some reason.


    The solution is simple... install your SSD in the hard drive bay and install your HDD in the optical bay. This is the set up I have and it works flawlessly.

Previous 1 18 19 20 21 22 Next