Previous 1 8 9 10 11 12 Next 239 Replies Latest reply: Apr 22, 2013 2:50 AM by bluejay0018 Go to original post
  • miflo Level 1 (10 points)

    Hi all. Had the same issue. 10.8.3 will fix that (tested the developer preview).

  • pollixx Level 1 (10 points)

    I'm experiencing these exact same issues! 

  • G.C.Thompson Level 1 (0 points)

    ...count me in too. The problems appear to be more prevalent since the recent Java update, but that could be a perception problem. While I'm off work for Christmas, I have more time to use the MacBook, so I've seen more issues

  • inc3pt Level 1 (0 points)

    Since my last post on December 18th, I've been using Safari with gfxCardStatus set to Discrete Only. I have not seen a single issue. I really hope 10.8.3 has the issue corrected so that I can let my rMBP go back to deciding which card to use on it's own.

  • Jakelong Level 1 (0 points)

    I have the same problem

  • jancha Level 1 (0 points)

    Same problem here..


    OS X 10.8.2

    Safari 6.0.2 (8536.26.17)


    Going back to chrome until this is fixed


    Seems like there is whole bunch of css3/html5 rendering issues in this version.

  • Jakelong Level 1 (0 points)

    I had the same problem and the cause was a bad extension. Try disabling all your extensions.

  • Shawn McCuan Level 1 (0 points)

    If you don't mind sharing, what extensions did you have installed?

  • Jakelong Level 1 (0 points)

    Skærmbillede 2013-01-07 kl. 12.25.20.jpg


    These except for NinjaKit. I found out that it was 4chan X that caused the trouble. Since there is no official release of 4chan X for safari I have been using the raw javascript to make an extension myself. Now I'm using NinjaKit to handle such userscripts and everything works perfect again


    Edit: the 4chan X 2.37.7 is disabled now.

  • Shawn McCuan Level 1 (0 points)

    I also had AdBlock installed; but the issues appear with or without it installed/uninstalled or enabled/disabled. I have long since switched back to Chrome because Safari is simply unusable and unreliable. Nothing infuriates me more than trying to fill out a form only to not be able to finish it because an artifact prevents me from using the site as intended.


    I'm still pretty frustrated that after my initial post months ago on July 27th, 2012, my post being viewed almost 15,000 times with ten pages of concurring comments, and after multiple feedback forms filled out, Apple still hasn't even acknowledged that there is an issue.


    I understand that tracking down a bug, and testing the fix for compatability can take awhile when that fix is going to be deployed to millions of devices. But, at least when they screwed up on Maps for iOS, they acknowledged that they messed up instead of ignoring it and sweeping it under the rug.

  • Jakelong Level 1 (0 points)

    Have you tried repairing permissions using disk utility?


    Have you tried a complete reinstall of safari (deleting ALL files)?

  • Shawn McCuan Level 1 (0 points)

    Yes to both. I have tried everything I could think of, including the cache.db, and graphics switch suggestions. Basically, the only thing I have *not* done is re-install the entire OS. I shouldn't need to re-install an entire OS to fix a browser rendering issue. (It wouldn't be difficult, I have everything backed up...but, it's not worth the hassle when other browsers render correctly.)

  • Vaelian Level 1 (5 points)

    Have you tried reading the thread?  This issue arised immediately after installing Mountain Lion for some people, including myself, and persisted through the Safari updates, and yes, I did "fix permissions" at some point for unrelated reasons in the mean time, it does not solve the problem in any way.


    This problem only seems to occur to MacBook Pros with dual video cards (one built-in, another dedicated) while running on the Intel (built-in) card.


    I also had issues with Safari leaking memory like there's no tomorrow in which sometimes WebProcess grows to 4GB and beyond, consuming my entire system's memory and slowing everything else down, but after addressing those problems by preventing Safari from consuming more than 512MB of real memory (which causes further allocations to go to the swap), I can now let Safari run for longer (as the only thing that gets slow now due to memory starvation is Safari itself), which causes the rendering issues to return.

  • Jakelong Level 1 (0 points)

    When you reinstalled it, did you also delete the preference file located at /Users/username/Library/Preferences/ and the safari folder located at Users/username/Library/Safari/ ?

  • Vaelian Level 1 (5 points)

    Yes, I have deleted all that stuff due to an unrelated issue (Safari keeping local storage during private sessions even through complete resets), it does not fix this in any way.

Previous 1 8 9 10 11 12 Next