Previous 1 2 3 4 Next 53 Replies Latest reply: Feb 3, 2014 10:48 PM by edward67 Go to original post
  • softwater Level 5 (5,370 points)

    So you mean when you create a new user account, the same problem occurs?


    What if you start in Safe Mode? Do you still get the same issue?

  • edward67 Level 1 (0 points)

    So sorry not to have replied before, but I've been having terrible problems with my MBP


    It's now decided it can't see the @£$%^#! SSD on my laptop, so I am having to boot up from the backup drive, which is still running 10.7.4 - and on which everything is working fine.


    Thank goodness for DropBox, otherwise I'd have no access to all my work over the past couple of weeks...


    I think I'll just have to wait until Apple posts an update to Mountain Lion.




    Thanks again for all your suggestions - I do appreciate you taking the time to try and help!  :-)

  • morberg Level 1 (10 points)

    My screensaver has stopped working again, something is definitely not as is should. Here's my console log when I try to start the screensaver:


    2012-08-18 12:29:31,472 WindowServer[94]: CGXSetWindowBackgroundBlurRadius: Invalid window 0xffffffff

    2012-08-18 12:29:31,473 loginwindow[33788]: find_shared_window: WID -1

    2012-08-18 12:29:31,473 loginwindow[33788]: CGSGetWindowTags: Invalid window 0xffffffff

    2012-08-18 12:29:31,473 loginwindow[33788]: find_shared_window: WID -1

    2012-08-18 12:29:31,473 loginwindow[33788]: CGSSetWindowTags: Invalid window 0xffffffff

    2012-08-18 12:29:31,483 coreservicesd[31]: Application App:"loginwindow" [ 0x0/0x1eb8eb7]  @ 0x0x7f98bbe2ca60 tried to be brought forward, but isn't in fPermittedFrontASNs ( ( ASN:0x0-0x21b61b4:) ), so denying.

    2012-08-18 12:29:31,483 WindowServer[94]: [cps/setfront] Failed setting the front application to loginwindow, psn 0x0-0x1eb8eb7, securitySessionID=0x18870, err=-13066

    2012-08-18 12:29:31,873 ScreenSaverEngine[35763]: void *NSMapGet(NSMapTable *, const void *): map table argument is NULL


    [72 instances of the same entry removed]


    2012-08-18 12:29:31,891 ScreenSaverEngine[35763]: void *NSMapGet(NSMapTable *, const void *): map table argument is NULL

    2012-08-18 12:29:36,211 ScreenSaverEngine[35763]: *** -[__NSArrayM insertObject:atIndex:]: object cannot be nil

    2012-08-18 12:29:36,212 ScreenSaverEngine[35763]: (

              0   CoreFoundation                      0x00007fff8f1db716 __exceptionPreprocess + 198

              1   libobjc.A.dylib                     0x00007fff90147470 objc_exception_throw + 43

              2   CoreFoundation                      0x00007fff8f18bf2a -[__NSArrayM insertObject:atIndex:] + 282

              3   ScreenSaver                         0x00007fff8c5cd7ae -[ScreenSaverPhotoChooser _imagePathsForMediaGroupID:] + 269

              4   ScreenSaver                         0x00007fff8c5cbc62 -[ScreenSaverPhotoChooser listOfPhotoPathsFromSelectedSource] + 165

              5   iLifeSlideshows                     0x000000010e734d82 __47-[iLifeSlideshowScreenSaverView startAnimation]_block_invoke_0 + 54

              6   ScreenSaver                         0x00007fff8c5ccd7f -[ScreenSaverPhotoChooser checkLoadingMediaManagersForPhotoListRequest] + 312

              7   Foundation                          0x00007fff8a91cfe5 __NSFireDelayedPerform + 358

              8   CoreFoundation                      0x00007fff8f1984b4 __CFRUNLOOP_IS_CALLING_OUT_TO_A_TIMER_CALLBACK_FUNCTION__ + 20

              9   CoreFoundation                      0x00007fff8f197fcd __CFRunLoopDoTimer + 557

              10  CoreFoundation                      0x00007fff8f17d7b9 __CFRunLoopRun + 1513

              11  CoreFoundation                      0x00007fff8f17cdd2 CFRunLoopRunSpecific + 290

              12  HIToolbox                           0x00007fff90932774 RunCurrentEventLoopInMode + 209

              13  HIToolbox                           0x00007fff90932512 ReceiveNextEventCommon + 356

              14  HIToolbox                           0x00007fff909323a3 BlockUntilNextEventMatchingListInMode + 62

              15  AppKit                              0x00007fff9208ffa3 _DPSNextEvent + 685

              16  AppKit                              0x00007fff9208f862 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128

              17  ScreenSaverEngine                   0x000000010c0bd747 -[ScreenSaverApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 49

              18  AppKit                              0x00007fff92086c03 -[NSApplication run] + 517

              19  ScreenSaverEngine                   0x000000010c0bd5a3 main + 551

              20  libdyld.dylib                       0x00007fff8e79d7e1 start + 0

              21  ???                                 0x0000000000000001 0x0 + 1


  • Ernst Vikne Level 2 (365 points)

    I found a solution that worked! At least for me. I had a smart folder in Aperture and wanted these photos in my screensaver. Some of the photos were offline, on another network disc. I discovered that when the images were online, the screensaver worked, otherwise it could load forever (I tried at least one hour). I have tried several times to mount and unmount the disc, and my suspicion holds true.


    Now I have changed the smart folder to only contain online photos, and the screensaver works always! I don't know why the sceensaver needs the original files, because the previews are more than large enough, and the original files didn't need to be online before I updated to Mountain Lion.

  • morberg Level 1 (10 points)

    After installing 10.8.1 the problem seemed to go away, but it was only the reboot after installation that gave temporary relief.


    Screensaver is unfortunately still broken in 10.8.1 and the error messages in the log are the same.

  • johannes.mahne Level 1 (0 points)

    Looks like I am getting the same problem:


    I selected one of the Default Collections as screensaver, and presumably these images are online... The behaviour I have is that when I want to log in to my MBP again, it doesn't bring up the login window, and I have to hard reset the machine.


    My behaviour is confirmed by what I see in the logs:


    CalendarAgent[314]: [] [Account refresh failed with error: Error Domain=NSURLErrorDomain Code=-1004 "Could not connect to the server."

    and then a couple of lines down:


    Application App:"loginwindow" [ 0x0/0x1001]  @ 0x0x7f8229610ed0 tried to be brought forward, but isn't in fPermittedFrontASNs ( ( ASN:0x0-0x30e30e:) ), so denying.

  • licores222 Level 1 (0 points)

    I've solved the problem. I installed Aperture and the screensaver started working again.

    I had deleted Aperture last year, but I looks like the screensaver is liked to it in some way.


    Hope it helps.

  • johannes.mahne Level 1 (0 points)

    Aperture is $80. Too steep for me to fix a bug.

  • morberg Level 1 (10 points)

    I have Aperture installed on my system but the screensaver doesn't work anyway. No need for you to shell out $80 to test it.


    The suggestion from Ernst Vikne is interesting, I'll try it when I get a moment. I have my original raw files on a network disk, but previews locally (of course).

  • edward67 Level 1 (0 points)

    I also have Aperture, but the screensaver doesn't work for me either.

    I tried Ernst Vikne's suggestion, but problem persists in my case...

  • morberg Level 1 (10 points)

    Thanks, this seems to have solved my problem. I had the share with my raw files automount on login which is why a reboot helped me. Sometimes the share gets disconnected and then the screensaver will not work anymore.


    Now on to see if I can make the share persistent...

  • Mssanity Level 1 (0 points)

    me neither.

  • eagillan Level 1 (0 points)

    There are a couple of work-arounds you can do, but I really doubt the problem will be fixed in 10.8.3 or any other future updates. I've learned that in order to have the screensaver work like it always did before you must purchase the iPhoto11 upgrade for $14.99. I just did it and of course "magically" it all works fine again. I believe it was all preplanned and is just one more way for Apple to squeeze out hundreds of millions of more dollars from its "loyal customers". Why is it we can't just get our upgrades such as iPhoto, Garage Band, iMovie etc., right along with the upgrades for the newest OS X?  Now that would be a fine goodwill gesture for all of Apple's loyal customers.

  • Mssanity Level 1 (0 points)

    True. Screensaver is not important, but it is annoying that it doesn't work right with the Lion upgrade. Really. How hard can it be to do something the same as before, huh?

  • Onkelpazuzu Level 1 (15 points)

    I had the same problem and the terminal commanddid not help. What I just found out is that re-naming the iPhoto library file (located in User - Pictures - I just renamed it from iPhoto Library to iPhoto Library_test) solved the problem. I suspected that the issue had to do with iPhoto referring to an external disk and ML somehow thinking that this then was the case for all pictures.