Previous 1 2 3 4 Next 53 Replies Latest reply: Feb 3, 2014 10:48 PM by edward67 Go to original post
  • Greg Parks Level 1 (135 points)

    I have resolved the issue on my machine, too. I had tried just renaming the Aperture and iPhoto libraries, but hadn't opened those apps or created new libraries. Once I did that, the screensaver worked and I could choose any folder I want. Once I reverted to the old iPhoto library it stopped working again. My conclusion is that there's a problem with the way the libraries are shared with the screensaver when there are photos in the library that have missing originals causing the screensaver system prefs panel to hang.

  • PrettyGreenParrot Level 1 (0 points)

    Thanks for that extra info. Sounds like I need to create a new library and try importing the old library into it.

  • jfaughnan Level 3 (785 points)

    Lots of good tips in this thread. I saw mentions of several things that can cause an Aperture based screensaver slideshow to fail including referenced images, inclusion of videos, etc.

     

    In my case, after months of the screensaver unpredictablly failing to start (thus creating a security issue) the problem was resolved.

     

    I don't know what the fix was, as I did 3 things:

     

    • upgraded to 10.8.3
    • ran Aperture repair database [1]
    • ran Aperture fix permissions

     

    If I had to bet I'd say repairing the database did the trick for me.

     

    [1] http://documentation.apple.com/en/aperture/usermanual/index.html#chapter=27%26se ction=10%26tasks=true

  • jrhaskew Level 1 (0 points)

    The problem with malfunction of the screen saver was resolved magically when I downloaded a free screen saver "Mandelbrot Screen Saver".  Maybe this will help others experiencing this frustrating problem.  I hope so and wish you success.

     

    Rich

  • H100 Level 1 (0 points)

    What worked for me was booting into recovery mode and fixing the disk and permissions, then running all three of the Aperture repair options

  • georgefromniagara falls Level 1 (0 points)

    boo hoo.

  • vitaal Level 1 (0 points)

    In my case the problem with screensaver loading pictures for ever was in damaged iPhoto library.

    It contained reference to photos stored on network drive which was not in use anymore.

     

    I tried all tools & methods described here, but here's two that were helpful in my case:

     

    1. Renaming iPhoto/Aperture library - worked out, but such solution just temporary.

    As soon as you connect renamed library to iPhoto/Apperture the problem reiterates.

     

    2. Use iPhoto Library Manager - that's what did solve the issue.

    I completely rebuilt library with it and finally fixed all "broken" references.

    Whole thing took a long time but it's worth to try.

     

    Just try it

  • sarahipad2user Level 1 (0 points)

    Hi edward67,

     

    I've been having the same issue. I have 2 monitors plugged in, one with through the Thunderbolt and one through the USB on my MB Air (OS 10.9.1). If I unplug them the external monitors, I can get the screensaver to work... if I then plug in the one through the Thunderbolt, it still works. However, as soon as I plug in the monitor through the USB, the screensaver stops working. Were you able to find any solutions?

  • edward67 Level 1 (0 points)

    Hi sarahipad2user

     

    I'm afraid not.  What was working (2 new thunderbolt displays with late 2012 MBP Retina) has now stopped working since upgrading to 10.9.1.  I've given up trying to use the screensaver / photo option, and am back to 'Flurry' - a waste of time and energy.

     

    Sorry not to be of more help,

     

    Edward

Previous 1 2 3 4 Next