13 Replies Latest reply: Jan 25, 2013 3:14 AM by Ah Kenn
nikmyers Level 1 (40 points)

I hadn't used the App Store in about a month until yesterday after I installed Mountain Lion, so I can't know for sure whether this would have occured in the month before the upgrade. I cannot get *any* application to install and as soon as one of the apps in question finish downloading a dialog explaining that the app failed to download and to try again from the purchases page (which also doesn't work).


I've restarted, deleted the App Store cache folder, deleted the App Store cookies, and scoured the internet for a solution.


If anyone can figure out where this problem came from I would be extraordinarily grateful.


Screen Shot 2012-07-28 at 6.45.39 AM.png

Screen Shot 2012-07-28 at 6.46.16 AM.png






Message was edited by: nikmyers [Added second screenshot]

  • Carolyn Samit Level 10 (102,820 points)

    Try turning off the Firewall in System Preferences > Security  & Privacy > Firewall


    And if you have anti virus software installed, you may need to disable that before downloading apps..



    A side note..   I see you were trying to download CCleaner.


    Third party cleaning utilties are not necessary on Mac and often do more harm than good. Your Mac runs maintenance for you.

  • AStemerman Level 1 (0 points)

    Carolyn Samit pretty much nailed it. This is usually caused by a firewall or virus scanning software.

    Next, you can try a hard reboot by unplugging your modem, router and computer.

    If you have neither of this than you should check your ISP connection as some companies don't send a consistant signal making downloads pause constantly.

  • nikmyers Level 1 (40 points)

    I was only downloading it as it was one of the top free apps and I wanted to take a screenshot.


    I don't keep firewall or an antivirus running. Sometimes I'll run ClamAV if I'm feeling particularly bored but since it has yet to do anything worthwhile in 6 years it's never very high on my list of priorities.


    As for it being a network issue -- I don't have any similar problems with the other computer in the house, the Xbox 360 or the PS3, and downloads from outside of the Mac App Store work fine on this computer (the one in question). Just to make sure all of the bases were covered so far I went ahead and reset everything to no avail.


    Perhaps I didn't explain this well enough, but the downloads will complete but they won't "finish"... If that makes sense.


    Screen Shot 2012-07-28 at 3.19.48 PM.pngScreen Shot 2012-07-28 at 3.20.04 PM.png


    The first screenshot is what the failed app looks like in Launchpad after I receive the error message and the second one is what it looks like in my Applications folder/stack.

  • citrus101 Level 2 (235 points)

    Are you able to deactivate the red error warning in MAS?


    If you are not, try to open MAS > click "Store" in menu bar > reload page


    This fixed this issue in my case. I had to download the app a second time, but then the installation worked as expected.

  • nikmyers Level 1 (40 points)

    Nope, refreshing doesn't remove the error, and if I try to install the application from the Purchases page it just throws back the same alert that tells me to try again from the Purchases page.

  • citrus101 Level 2 (235 points)

    Yes, I had this issue, too. Same story. I had to wait 24 hours, but then it worked again (after reloading the page).


    I downloaded iPhoto and the download finished to 100%, but the installation never started and I saw this red error warning. Wired ... I think it was a corrupt download in my case.


    Probably you have just to wait until the error warning disappears.

  • nikmyers Level 1 (40 points)

    After browsing this board again I ran across this thread from a user that had a problem that I also had (and simply hadn't bothered to ask about, luckily). I had no idea that MAS uses the Spotlight index to compile the list of what you have installed and one of the first things I did after upgrading to Mountain Lion was add Macintosh HD to Spotlight's blacklist.


    I just removed it from that list and Spotlight has begun the far-too-lengthy indexing procedure once again, so hopefully by the end of this entirely unnecessary three hour wait it will have solved some of the problems I've been encountering.


    I really wish there was a way to disable Spotlight outside of Terminal and remove the menu bar icon. I'm fairly sure I've only used it a handful of times in the last six years.

  • nikmyers Level 1 (40 points)

    Just to keep this going so we can potentially figure out my initial problem, I thought I'd update that my previous post worked to stop the Apple ID problem I was having but didn't help to stop the problem I explained in my original post.


    This whole thing is quite frustrating simply because it's not a serious enough problem to take all of the time required to install from scratch and pull my documents and applications from a backup, but I know it's going to irritate me to no end for the foreseeable future (especially as fewer developers offer their applications outside of the App Store).

  • doug.wp Level 1 (0 points)

    I have the same problem as Nik. Reload doesn't work. The firewall is off. I've had the problem with a couple different apps over the last several days -- ever since downloading Mountain Lion.

  • nikmyers Level 1 (40 points)

    Surprisingly enough the problem seemingly worked itself out on its own. Hopefully you will get the same stroke of luck!

  • mrhangz Level 1 (0 points)

    I got this problem probably by leaving my Mac on idle while downloading.

    I fixed this by running "killall Dock" in the terminal, and re-downloading the apps from purchases page.

    Hope this help.

  • GeekNeck Level 1 (0 points)

    I also had this problem, but none of the solutions worked.  I finally resolved the issue by looking in Console, and I found this entry:

    11/21/12 8:13:48.141 AM storeagent[542]: underlyingError Error Domain=NSURLErrorDomain Code=-1100 "The requested URL was not found on this server." UserInfo=0x7fed724f4300 {NSUnderlyingError=0x7fed75394630 "The requested URL was not found on this server.", NSErrorFailingURLStringKey=file:///var/folders/7d/ptxyzbjx29121pm279b9y3vm0000g n/C/com.apple.appstore/407963104/mzps6156376318489886776.pkg/index.sproduct, NSErrorFailingURLKey=file:///var/folders/7d/ptxyzbjx29121pm279b9y3vm0000gn/C/co m.apple.appstore/407963104/mzps6156376318489886776.pkg/index.sproduct, NSLocalizedDescription=The requested URL was not found on this server.}

    I simply removed the offending file in Terminal thusly:

    mv /var/folders/7d/ptxyzbjx29121pm279b9y3vm0000gn/C/com.apple.appstore/407963104/m zps6156376318489886776.pkg ~/.Trash/

    Note that you will need to substitute the file name as it appears in your log.  Also note that "rm <file>" would have also worked, but I wanted to play it safe :-)


    Once the file was gone, I hit the Install button in the App Store app, it re-downloaded and installed just fine.  I hope this works for you!

  • Ah Kenn Level 1 (0 points)

    http://reviews.cnet.com/8301-13727_7-57530446-263/fix-corrupt-mac-app-store-down loads/


    I had the same problem, read this article and it worked for me. Maybe you could give the delete app store cache thing another go?