Previous 1 2 3 4 5 Next 116 Replies Latest reply: Jul 31, 2014 1:08 AM by aminasadi Go to original post
  • carlos134 Level 1 (0 points)

    Hi ttrq01,


    Thanks for the feedback I will try creating a new user and to see if the problem is user related...I'm still dealing with the issue today, I thought it was fixed but it came back..





  • carlos134 Level 1 (0 points)

    Hi Everyone,


    I created a new user and the problem didn't occur while on battery. The SSD MBA woke up blazing fast this morning.

    NOTE: I still haven't tested it plugged in, with 'Power nap' checked/unchecked.


    The steps I took:

    - Created a new user (Admin)

    - Configured the System Preferences just like I like them and reset Energy Preferences back to default

    - Transfered the home folder contents to the new user (music, documents, downloads and iphoto library etc)

    - Copied over the preferences for a few of the apps ( just a few important ones for me)

    - Deleted the old user account with secure Delete option checked.


    It took me a while to get the new user to work just like the old one, maybe there is an easier way. But the problem seems to be gone! I'll be posting as soon as I complete my testing with the computer plugged in.



  • bwb1981 Level 1 (0 points)

    Just though I would share my situation too. I have a mid 2009 15inch macbook pro. I upgrade from snow leopard to mountain lion. After the upgrade and if I was running on battery, my mbp would not wake after shutting the lid. When I would open the lid it would be the off white apple screen and show a progress bar at the bottom. The only other time I have seen this progress bar is when I would let the battery drain completely and restart after plugging it in. But this time the progress bar would not finish. It would make it all the way to the very end but would never fully finish and the mbp would never start. Then the only way to resolve this was to hold the power button and restart.

    This is what I did and it seems to have fixed the problem.


    1. In terminal "sudo pmset -a hibernatemode 0"

    2. Tested by closing the lid while powered by battery. Sleep and woke normally.

    3. In terminal "sudo pmset -a hibernatemode 3"

    4. Again tested by closing the lid while powered by battery. And again sleep and woke normally.


    It seems that changing hibernatemode fixed the problem for me.

  • ttrq01 Level 1 (5 points)

    Well folks, my exuberance was short-lived.  My 2011 MBA is back to restarting upon sleeping.  Apple L2 working with develpment. Fyi, a fresh user seems to work fine.

  • paulofromnew york Level 1 (0 points)

    Hi everyone,


    Let me start with a quote:


    “For every complex problem there is an answer that is clear, simple, and wrong”. (H. L. Mencken)


         I spent a week with the sleeping/waking problem with Mountain Lion, at first a I blamed Apple software engineers, Apple Inc. itself and programmers for my headaches with Osx and after I’ve started to try to figure out what is truly happening in my computer. In my home office I have one Imac 27’ late 2009, one Macmini early 2009, one Macmini mid 2010 and one Macbook Air 11’mid 2011. First is my main computer and is the Imac and I’ve tried the ML in this computer first. I use to leave this computer on, all the time, 24/30 and sleeping in programed basis from 1 to 8am. That is why nice power management is so important and useful to me.

         I tried all simple solutions (changing pmset) and no solution, after this I tried to uninstall the most obvious programs that interfere with the power management set.



    • Caffeine and SmartSleep

         No results


         Reading someone post I decided to examine my system log at /var/log/system.log, reading the log I discovered so many errors related to login and unlogin I started to change/update as many software as possible to solve the puzzle.



    • Jack OS X – this software has know issues with ML
    • Candelair – installed by Plex – was giving warning before sleep



    • SoundSource – incompatible with ML
    • Growl – I don’t know about ML support



    • Video Glide – my version was incompatible with ML
    • Currency Converter - a widget that was freezing my dashboard on sleep
    • Wacon Banboo tablet driver – causing irresponsiveness - the last change i did


    Stop using:

    • Microsoft messenger – change to aMSN – messenger left some parts when logoff


         Result: my system is working very well, fast, sleeping and waking as fast as never did before. I am using hibernate mode 0 but I will try to test with 30 (my favorite set) as soon as possible. Now I can enjoy the new ML! It's a crazy thing!


         I hope my, complex, solution can help everyone.


         Best regards,




    PS. Do not forget to check the permissions in the filesystem with disk utility.


    Message was edited by: paulofromnew york

  • paulofromnew york Level 1 (0 points)

    Update: sleeping with mode 0 is ok but mode 30 and 25 has problems to wakeup.

  • ttrq01 Level 1 (5 points)

    Hello everyone...I am delighted to tell you that after a long week battling the Kernel panics upon going into Sleep-mode that I am finally up and running--perfectly! 


    After my problem came back after it appeared that it was fixed above, Apple L2 Support had the Mountain Lion dev team review my case and they were able to figure out that my AirDisplay program from Avatron was causing the problem.  AirDisplay is used to use an iOS device as a second monitor for your Mac session.  It is pretty cool!


    If any of you are using this program, go here to find out the details of their work-around or uninstall AirDisplay like I did as I am going to wait until they update their s/w and Apple updates Mtn Lion: th


    Also, I had a leftover issue after the above where my bluetooth Magic Mouse lost it's right-click functionality which eventuyally required a reinstall of Mountain Lion into my existing partition after much diagnosis. We don't know for sure that this was related to the above AirDisplay issue but if you look at the Avatron blog-post, they do refer to a bluetooth workaround so seems like it could have been??


    Anyways...thx to everyone for your support on this thread and good luck.  I encourage anyone having issues that is also on AppleCare to reach out to Apple support for assistance--they were great for me all week long.

  • InfinitebB-FR Level 1 (0 points)

    Thanks for sharing bwb1981! I have had very much the same issues since upgrading to Mountain Lion on my mid-2010 13" MacBook Pro. One more that I have had is a black screen when opening the lid but with the keyboard all light-up and fans running and same need to hard-shut everything down... so I tried your method and "sudo pmset -a hibernatemode 0" worked fine but then "sudo pmset -a hibernatemode 3" made the issue reappear again... so I came back to "sudo pmset -a hibernatemode 0" and it seemed to fix the issue.

  • FleshFear Level 1 (0 points)

    Hi i have a Mid-2010 macbook air, og also have this problem. When the machine have been a sleep for a while, when i open the lid. The logon screen comes on but the machine is complely froozen.


    I have talk white apple support, and they got me to run a disk premissions repair. So ill return white the result when i have run whit it for a while.

  • aminasadi Level 1 (0 points)

    I just did that, still the issue is there. Btw, I upgraded to moutain lion from lion. Has anyone tried a fresh install?

  • FleshFear Level 1 (0 points)

    I did a fresh install...

  • aminasadi Level 1 (0 points)

    I realized something that seems to work for me! (I didn't do any recomenndation given above except I did a repair on my permissions which didn't work for me).


    I adjusted a startup/wake time in schedule option provided in Energy Saver setting and restarted my MacAir late 2011. It worked and I was happy about it and then I turned that option off since I don't need it for now. What I've noticed is, I DO NOT HAVE ANY LAGS now when I open the lid from the sleep mode since I played around with schedule option. Could it be related? Doing that might reset a timestamp or a clock somewhere in the system. Well I don't know until one of you try that.


    Just set a time for 3 minutes later, shutdown your system and wait for it to wakeup. Then just turn the option off and close the lid and see what happens.

  • Martin Reuben Level 1 (5 points)

    FWIW, on my 2009 Mac Pro if I keep Final Cut Pro (Original 7.03 version) open but minimized, the computer will not lock up after going to sleep.     In my case the screen would come to life, but there was no response from the input device.   (Either wired or using the trackpad).


    The same thing happened when Lion originally came out and went away after a few updates.

  • FleshFear Level 1 (0 points)

    hmmmm.... Well that didnt work... Ill call apple support again....

  • ttrq01 Level 1 (5 points)

    I did a ML "reinstall" on my existing HD. No TM restore or anything was involved that I could see.


    Also, when Apple Support had me check another user account and found it was working, we started zeroing in on start-up items only associated with my main account which led us to the AirDisplay program.


    Good luck!

Previous 1 2 3 4 5 Next