Previous 1 2 3 Next 30 Replies Latest reply: Mar 7, 2013 6:09 AM by ath.pap.
LindaSMu Level 1 Level 1

I prefer to use OpenOffice for word processing. Since I downloaded Mountain Lion, my documents now appear in TextEdit. Is it possible to change this?


iMac (20-inch Mid 2007), OS X Mountain Lion
Solved by Ravindra Holalkere on Jul 28, 2012 7:51 AM Solved

Hmm, not sure how the privileges are set up on your machine...

 

Here's is another way, assuming you are using ML:

 

Select the document in Finder, right click (control click) to get the contextual menu, choose Open with. A list of typical apps for the doc type would be visible. Don't choose directly from there-instead click on Other at the end of the list. This will open a Choose Application window; select 'All Applications' in the Enable dropdown, choose OOO and check the 'Always open with' option

Reply by Lost in Asia on Sep 24, 2012 6:49 AM Helpful

Thanks for suffering the pain for all this - your pain likely saved me many hours of trying to figure out what was going on when I had the same problem!

 

Note that, rather than totally changing to "Allow applications from anywhere", you can just allow an exception for OpenOffice (copied from somewhere in Mac's Help Center):

 

  1. In the Finder, locate the app you want to open. Most apps can be found in the Applications folder.
  2. Press the Control-key and click the app icon.
  3. Choose Open from the pop-up menu.
  4. Click Open.

The app will be stored as an exception to your security settings, and you will be able to open it in the future by double-clicking it.

 

I did it this way, although to be honest the whole "unidentified developer" thing is proving so annoying I may soon switch it off anyway.

All replies

  • Ravindra Holalkere Level 1 Level 1

    I'm assuming you are referring to files with .doc or .docx extensions (and even maybe .rtf or .rtfd).

     

    In Finder, select one such document file (don't open it), CMD+I to 'Get Info'.

    In the Get Info popup, you should see an option "Open with:" (if you can't, click the little triangles to expand each option), with a drop-down menu. Choose your preferred Word Processor in the drop-down and then click the Change All button to make that default to all documents of that type.

     

    Repeat for the other file types as necessary. You may have to Relaunch Finder if the file doesn't open with the new application (rare though)

  • LindaSMu Level 1 Level 1

    Thank you. This worked until I got to "Open with." The default is TextEdit and when I checked OpenOffice, it would not change; therefore, I could not choose Change All.

  • Ravindra Holalkere Level 1 Level 1

    Do you have adminstrator privileges on your Mac?

    In the same Get Info window, expand the Sharing and Permissions option. Is your user name listed there with  Read & Write Privileges?

     

    Did you get any messages while trying to change the default?

  • LindaSMu Level 1 Level 1

    Yes, I have read and write privileges. I tried your suggestions with several documents and was unable to change any of them. Thank you for your patience!

  • LindaSMu Level 1 Level 1

    ...and, no messages came up.

  • Ravindra Holalkere Level 1 Level 1

    Hmm, not sure how the privileges are set up on your machine...

     

    Here's is another way, assuming you are using ML:

     

    Select the document in Finder, right click (control click) to get the contextual menu, choose Open with. A list of typical apps for the doc type would be visible. Don't choose directly from there-instead click on Other at the end of the list. This will open a Choose Application window; select 'All Applications' in the Enable dropdown, choose OOO and check the 'Always open with' option

  • LindaSMu Level 1 Level 1

    YES YES YES. Thank you so much!

  • Ravindra Holalkere Level 1 Level 1

     

  • Randy Kilwag Level 1 Level 1

    I'm having the same problem, slightly different details. I cannot get rid of Preview as my default app for opening .XLS files after upgrading to Mountain Lion.

     

    I have tried all methods mentioned in this post, I can override for one launch (by checking always use) but if I quit and double click the same doc it reverts back to Preview.

     

    I am the only user account on my machine, I am listed with read/write for these documents, I get no error message. I can select OpenOffice in the pull down from "Get Info" but it immediately reverts back to Preview when I let go.

  • LindaSMu Level 1 Level 1

    I thought my problems were solved, too. Today's problem came with Pages, which I do not have. I could not change the default on it either. The only way I could open the document was to open OpenOffice and drag the file there. Even when I save it as .docx, it still tells me that I can open it only in Pages.

     

    I hope someone has an answer for a universal way to change (and keep) defaults from appearing.

  • Ravindra Holalkere Level 1 Level 1

    To both the posters above, the link describes the 'change all' option in Get Info window which is typically how one can change the default application for a file type as well as set the owner. But in both your cases this does not work.

     

    http://blogmines.com/blog/2012/01/28/how-to-change-file-association-on-mac-os-x- lion/

     

    http://support.apple.com/kb/PH3774

     

    Have you run disk utility and checked/repaired permissions?

  • LindaSMu Level 1 Level 1

    Hello again! Yes, I have run disk utility and all is well. In another twist, all of my .docx files have changed to .odt and all open in TextEdit. Does that give you any clue?

  • LindaSMu Level 1 Level 1

    After much agony , the problem is solved! I received a pop-up message this morning that there was an update available for OpenOffice -- 3.4. I downloaded it and then went back through the steps that you suggested when I first posted. I was able to choose OpenOffice 3.4 and click "Change All." AND IT WORKED!

     

    Again, thank you for showing me how to get to this point! I appreciate it!

  • Ravindra Holalkere Level 1 Level 1

    Hmm, installing an OOO update allowed you to use the 'change all' functionality!! That's interesting...

     

    anyway glad it worked out for you

Previous 1 2 3 Next