Previous 1 2 3 4 Next 59 Replies Latest reply: Aug 16, 2014 5:03 PM by NiagaraTim Go to original post
  • lochsaw Level 1 Level 1

    Actually, PeterBreis0807, it does "just happen."

     

    I have my iPhone, iPad and macbook all set up so that adding a note, calendar event, or iCloud stored pages/numbers docs to one device distributes them automatically to the other devices. Although I don't use the cloud much for storing real documents.

     

    I think the problem is that it can be a little bit confusing to set up properly, but I found that it wasn't a big deal to fix it once I had the proper info. I'm sure the Apple store folks can help you.

  • PeterBreis0807 Level 7 Level 7
    expertise.iwork
    iWork

    lochsaw

     

    Don't think you were following what happened.

     

    Never mind.

     

    P.

  • lochsaw Level 1 Level 1

    probably.

  • Kenneth Collins1 Level 1 Level 1

    There is a problem with iCal's UI that might be causing part of the problem of vanishing iCal events.

     

    Apple apparently assumes that you are going to create a calendar entry with its command-line interface; that is, click on the calendar and type everything in their "natural" language system. The problem is that the "natural" language isn't natural enough, so you have to press CMD+I to finish the entry. That's where the problem comes in. In the lower right corner, there is a Delete button where there should be an Apply button. I was very frustrated, because I'd enter events only to have them mysteriously disappear, until I figured out that I was actually deleting them as fast as I was entering them. Sometimes there is an Apply button; sometimes there is a Delete button where there should be a Delete button, and sometimes there is a Delete button where there should be an Apply button. You have to pay close attention. If there is no button at all, it is an implicitly Apply button, so you don't have to click on anything at all.

     

    I wonder sometimes if Apple uses its own products. You'd think they'd notice this (along with the four-year-old bugs in Pages) within two days of using iCal in the office.

  • PeterBreis0807 Level 7 Level 7
    expertise.iwork
    iWork

    The price of Apple being ludicrously secretive and only valuing its own opinions is exactly this.

     

    The products are designed for themselves, and like Marie Antoinette they experience the "real world" by playing dress-ups and pretending to be milkmaids with silver pails in the Royal "village" on the grounds of Versailles.

     

    ie The illusion of reality trumps reality, but for those not exposed to real life it looks absolutely convincing and remains a mystery as to why it isn't.

     

    If they even cared, because all us yobs are "just not holding it right".

     

    Peter

  • ByronBound Level 1 Level 1

    Hi Alistair.  Changing the default to On My Mac does give you the normal file structure dialogue when opening a file, but when saving it still defaults to the cumbersome iCloud option, meaning several keystrokes to get back to the file structure.

     

    What is going on at Apple these days?  Doesn't anyone use a Mac at Apple for anything serious?  You can't paginate a spreadsheet in Numbers and now Pages assumes you use a flat file structure - useless if you have any sort of requirement to structure a large quantity of business documents which need to be stored in an orderly manner...

     

    Someone should remind Apple that the Mac is not a toy for all of us...

  • Alistair Cullum Level 1 Level 1

    Byron-

     

    The Save problem is actually what brought me to this discussion in the first place.  Luckily, Bernie_uk followed up my query with information on a fix.  It's back on page 1, so I'll repeat it for future users:

     

    This annoyed me also, so did some digging. You can run this on the command line:

     

      defaults write NSGlobalDomain NSDocumentSaveNewDocumentsToCloud -bool false

     

    You can leave iCloud's Data and Documents, and select iCloud from the dropdown if you need it.

     

    No idea why there's a button to change the option in Open but not Save, but Bernie's fix has kept me sane.

  • ByronBound Level 1 Level 1

    Thanks mate.  Yes, I saw that - but I decided I didn't use my iPad often enough for Pages documents to be bothered changing stuff in the command line...  I did that once to show hidden files and i have never set aside the time to find out how i did it to turn it off...

     

    I really hate the iCloud implementation - I have had no end of trouble with mail ever since Mountain Lion and my poor old iPhone 3G is now virtually a brick...

     

    But thanks for the note.  If Apple ever figure out how to replace the mouse with something that doesn't require a long arm stretch (when using a proper keyboard) I might even use Pages.  Well, if and when it has all the functionality of the Mac version.

     

    The poor old Mac has been rather starved of development resources I think since the iPhone/iPad revolution...

  • The_Mad_Hatter Level 1 Level 1

    Bernie is a lifesaver. I'm a writer. I use my iPad for notes. It's great for that. Serious writing is on my MacBook.

     

    So I want to save to the Cloud from the iPad, and have access to it, but I sure as **** don't want to save my current project to the Cloud, because trying to edit something that is 90K+ words long on an iPad is an exercise in frustration.

     

    I held off on upgrading to Mountain Lion until the other week, so that most of the changes, like this one, would have solutions found out other people. And thankfully they have, though I'll admit that I still haven't gotten Apache back up and running (another really dumb idea - kill a feature that a lot of us rely on). That I'll do this week.

     

    I like my MacBook. It's a really comfortable machine to write on. It has the best keyboard I've ever used.

     

    But OSX is getting to be a pain in the neck, and I'm seriously thinking of installing Linux as a dual boot to see if that will work better. No, I won't touch Windows. Never, ever, again. It has cost me too much, and Microsoft will never, ever, get another cent out of me.

     

    Wayne

  • bryce_1 Level 1 Level 1

    thanks!!

  • _jh_ Level 1 Level 1

    Thank you!

  • Kenneth Collins1 Level 1 Level 1

    There's also a fix for Apache

     

    Apparently Apple is now designing Macs and OSX for people who are using a computer for the very first time in their lives. Those of us who are using a Mac for the second time are left behind. OS X has different use cases than iOS and while they can be made similar, that can only go so far. The last time I talked to someone at Apple, I got the impression that they know they went too far and will fix it. We'll see.

     

    You've found the solution for saving documents to iCloud by default, which was a very bad idea. Your next problem is Apache. There is a third-party solution that adds a preference pane to System Preferences. I think you'll be pleased with it.

  • Steadinan Level 1 Level 1

    This solution worked for me.  First, you have to go into the Terminal.

     

    Re: How do I change the default save location for new files in Pages back from iCloud to my Documents folder?

     

    Aug 5, 2012 5:26 PM (in response to JGinDC)

    This annoyed me also, so did some digging. You can run this on the command line:

     

      defaults write NSGlobalDomain NSDocumentSaveNewDocumentsToCloud -bool false

     

    You can leave iCloud's Data and Documents, and select iCloud from the dropdown if you need it.

     

    -----------------------------------

     

    From Steadinan:

     

    After you run this in Terminal, it will still try to save to iCloud one last time.  Once you change it to a folder on your computer, it will remember that the next time.

     

    If it still doesn't work, you might have to Relaunch the Finder (Click on the Apple and go to "Force Quit").

     

    I really think that you, as the original poster of this question, should give Bernie_UK some credit and mark his answer as This solved my question.  That would allow other people to find the answer quicker.


  • NiagaraTim Level 1 Level 1

    go to System Preferences > Docs and Data > click 'options' then here you can uncheck pages and any other data you do not wish saved to iCloud. click done. now you can save all your new pages to any folder you want saved to.  just simply save to documents or any folder you normally use just once and then from there any doc you save from now on will always save to your favorite folder.. I tried a test doc to my documents folder and worked like a charm

  • NiagaraTim Level 1 Level 1

    Whoops missed a step! sorry!

    System Preferences > iCloud >Docs and Data > click 'options' then here you can uncheck pages

Previous 1 2 3 4 Next