1 Reply Latest reply: Aug 28, 2012 7:31 PM by tbham
tbham Level 1 Level 1 (0 points)

Ok so this problem has just occured in the last week or so when trying to attach a new iPad 2 to my Home Share. Everything was working fine before then.

 

I have a Mac Mini running the latest version of OS X Lion, a laptop running Windows 7 Home Premium 64-bit and an iPhone 4S with the latest software. The Mac Mini and Laptop both have the latest version of iTunes. All devices are on the same wireless network and are connected with the same Apple ID.

 

So basically I was trying to attach the ipad to the currently working home share, which it was unable to find. So I attemtped turning off home sharing on all the devices and turning it back on, but now none of the devices can find each other.

 

I have forwarded the required ports (TCP port 3689 and UDP port 5353) for all devices, all which have static ip addresses. I have also attempted setting up the home share with all firewalls turned off but still no luck. And of course, I have tried turning everything on and off several times and have reinstalled iTunes on both computers. 

 

Not sure what else I can do. Quite frustrated as now I can't sync my iPhone at all becuase it wont connect to either of the computers by usb, but that a whole other problem.

 

If anyone has answers let me know!


iTunes, Mac OS X (10.7.4), Home Sharing
  • tbham Level 1 Level 1 (0 points)

    Solved.

     

    Not sure why this causes a problem but the Wireless Multicast Forwarding option in the router (mine is a Billion 7800N) settings must be DISABLED. Not sure what this feature does or when it was turned on but it causes a major conflict with bonjour.

     

    Hope this helps anyone having the same problem.