Previous 1 9 10 11 12 13 Next 191 Replies Latest reply: Nov 29, 2013 8:56 PM by whappen'd? Go to original post
  • leodanger Level 1 (0 points)

    That's because you've still never reached the new time limit you set. So, autopoweroff isn't coming into effect (same as turning it off).


    I've turned mine back on, and am going to try W M R's suggestion tonight. Will get back to you tomorrow...

  • woofers02 Level 1 (0 points)

    leodanger wrote:


    I've found that you can leave hibernate settigns alone. Using Terminal (in utilities), enter this:


    sudo pmset -a autopoweroff 0




    Confirming this has resolved the issue for me as well.


    Well done Apple. (sarcasm)

  • leodanger Level 1 (0 points)

    Sorry W M R – that didn't work on my Mid 2012 MacBook Pro. I'm going to test it in safemode first, then after that I'll be swtiching autopoweroff off again, as that works for me.


    I'll send all the details, once it's properly narrowed down, to Apple tonight, and will let you know how I get on.


    Glad autopoweroff is working for you Crackers and Erik

  • W M R Level 1 (145 points)

    Strange! I wonder why it worked for me and not for you...

  • mxo11 Level 1 (25 points)

    As promised, here's my update: I just opened the laptop after ~16 hours of inactivity and it woke up immediately (FYI: I changed the autopoweroffdelay to 24 hours).  Let's see what happens in the next few days.

  • leodanger Level 1 (0 points)

    That's great mxo11. Please can you confirm what you'd done to get to this state, to aid others looking for an answer?

  • mxo11 Level 1 (25 points)

    Let's see whether this helps.  After several experiments with the power management set up (with no positive effects), I settled for the default settings, except the autopoweroffdelay. That said, my current set up is as follows:


    Active Profiles:

    Battery Power        -1

    AC Power        -1*

    Currently in use:

    standbydelay         4200

    standby              0

    womp                 1

    halfdim              1

    hibernatefile        /var/vm/sleepimage

    sms                  1

    networkoversleep     0

    disksleep            10

    sleep                10

    autopoweroffdelay    86400

    hibernatemode        3

    autopoweroff         1

    ttyskeepawake        1

    displaysleep         10

    acwake               0

    lidwake              1


    The command line was:


    sudo pmset -a autopoweroffdelay 86400


    As you (leodanger) can see, it's pretty much based on one of your suggestions.  Note that the standbydelay is still 4200 seconds and that the autopoweroff is still on (1).  Hope this helps, folks.

  • sumoSANDALZ Level 1 (0 points)

    This worked for me! Thanks leodanger

  • bigbadjohn Level 1 (0 points)

    This worked for me too: (autopoweroff = 0) Thanks!

  • MikeTheBike2010 Level 1 (0 points)

    Further to my previous posts regarding this problem and a bizarre issue I have where the MBP will NOT sleep on idle, I have had a call back from Mounir, a very helpful member of Applecare staff (my machine was purchased in December).

    Mounir, who has been excellent at keeping in contact and following up my problems assures me that Apple are aware of the slow wake from sleep issue.

    Presumably this will be attended to in a future upgrade?

    Mounir is continuing to liase with me to establish why the MBP occasionally refuses to sleep but that is an issue for another thread and forum.

  • leodanger Level 1 (0 points)

    Really glad this worked for you! I'm waiting to hear back from Apple as to what autopoweroff actually does...


    However, you'll notice you still have a slight issue – if you unplug your MBP from the AC adaptor before opening the lid, the light on the front will illuminate fully as the machine enters a darkwake. If you now open the lid, you'll find the screen stays dark, and won't turn on for about 40 seconds. Of course, the computer is still running far better than before chainging autopoweroff to 0, but I wasn't totally happy...


    I made a TimeMachine backup, then booted up in recovery mode (hold cmd R while restarting). I then erased the hard drive, reinstalled the OS, then restored from Time Machine, just unchecking the box for "settings" (don't know if this bit is necessary, but wanted to try). With the laptop up and running again, I went to updates in the App store. There were three at this time – Safari, Camera RAW, and "MacBook Air and MacBook Pro Update 2.0 2.0". I set the two other updates going, but hid the "2.0 2.0" one (holding ctrl and clicking anywhere but on the update button).


    My laptop is now running exactly as it should be. The only issue I had with turning settings off seems to have been losing my printers. All other settings are reset, but it's not an problem for me.


    Here's the interesting bit... now I haven't applied the update, there is NO mention of autopoweroff or autopoweroff delay in pmset! Also, acwake is still at 0, but it seems to actually work now (as in my MBP doesn't wake when the AC is connected or disconnected). I've passed all this on to my Apple Senior Technician, so I'll let you know if I hear anything back... To me, it's as if this update is meant for the Retina and Air MBPs that have Power Nap, but is causing problems with our mid-2012 MBPs.

  • crackers8199 Level 1 (0 points)



    with my modified version of your fix (i.e. leave autopoweroff on but set the delay to one day), i don't see the problem you described where the MBP goes deep sleep when pulling the power cord with the lid closed...

  • mxo11 Level 1 (25 points)

    Hey all,  after several 23-hour tests, I can report that my MBP is responding as I expected: it wakes up immediately after opening the lid.  It does go into deep sleep if I leave it plugged in and inactive for more than 24 hours.  I did the same thing as crackers 8199: I left autopoweroff on (i.e. "1") but changed the autopowerdelay parameter.   I still need to test whether pulling the cord while the lid is closed may lead to deep sleep, as described by leo.  At least, for now, things are fine.

  • Oliver82 Level 1 (0 points)


    just registrated for the Forums to write this and perhaps help others in the same situation as me just 10 minutes before writing this.


    I had the very same problem Hotwheels22 and mxo11 had and described on page 7 of this thread, too.


    My MPB 2012 non-retina hibernates while charging at night and everytime I woke it next morning it resumed with the grayed screen and progress bar and after that i had a normal login screen and a mouse pointer without beachball but was not able to move the pointer or input my password for about 20 seconds.


    Of course, one can workaround this problem by messing around with pmset and disabling hibernation completely. Especially for the filevault users here this might not be the best solution though, as hibernation is a safer state for filevault than just sleep.


    So if you have the same problem as me, but want to keep hibernation and just want your system to respond immediately after its resume (progress bar completed), you can try what I did and what solved my problem:


    I removed the from Library/LaunchDeamons as suggested in this thread and also removed another suspective plist related to my old Graphics Tablet (Aiptek U600). This was migrated from my old mac and didn't run properly anyway. If you have another USB-related LaunchDeamon, it might be worth a try to remove that, too.


    After that I shutdown the machine and made a SMC Reset. Then put it to hibernation manually, woke it up and: System responds immediately after the resume bar completed. 


    Please note that this was a quick-and-dirty approach of problem analysis and though it solved my problem I don't know if every step was necessary. A real analysis would seperate every step (delete only one plist => reboot&try, delete 2nd plist => reboot&try, smc-reset => reboot&try).


    I suggest that you move the suspicious plists to trash the gui way (not via terminal) to be able to use the "put it back" feature of the trash if that didn't solve your problem or created a new one.

  • Erik421 Level 1 (0 points)

    After a few days of work with setting of LEODANGER that solved my problem (autopoweroff 0), I want to report my actual setting:


    Active Profiles:

    Battery Power          -1*

    AC Power          -1

    Currently in use:

    standbydelay         0

    standby              0

    halfdim              1

    sms                  1

    hibernatefile        /var/vm/sleepimage

    disksleep            10

    sleep                0

    autopoweroffdelay    14400

    hibernatemode        3

    autopoweroff         0

    ttyskeepawake        1

    displaysleep         30

    acwake               0

    lidwake              1


    With this setting I haven't any problem. I've tryed to set standbydelay to 0, not 4200. What change do you think?? And to change autopoweroffdelay??


    Only problem like Leodanger:   if I unplug your MBP from the AC adaptor before opening the lid, the light on the front will illuminate fully as the machine enters a darkwake. If you now open the lid, you'll find the screen stays dark, and won't turn on for about 40 seconds.

    But I don't remember if this problem was there before the upgrade to ML.

    Fixable do you think without reinstalling OS?


    Anyway I can live with this little problem, that perhaps it's normal....


    Thanks boyz!!!