Previous 1 2 3 Next 136 Replies Latest reply: Dec 4, 2014 1:23 PM by markkuarimo
mjbentoc Level 1 Level 1

I have a Macbook Pro early 2008 2.4 Intel Core 2 Duo, 4GB ram 667 MHz, GeForce 8600M GT 256MB, HDD500GB 7200 rpm.

The superdrive was working just great with OSX Lion, I've upgradded to Mountain Lion and it stopped working.


It try to read the disks and after 5 to 10 seconds after it ejects it. It doesn't matter if it it a CD or a DVD or if it ir empty or a original music CD. It simply ejects every type of media.


Did this happened with anyone?


I've tried to downgrade to Lion again but I only have Lion in DVD to make a clean intall but the superdrive doesn´t accept it. I don't know what else to do.


Can somebody help me?

MacBook Pro, OS X Mountain Lion
Reply by Londoner86 on Sep 17, 2012 1:02 AM Helpful

I have had the same problem. I upgraded from Snow leopard to ML and my dvd drive stopped working. I don't burn dvd's/cd's often so it took a month after the update to figure it out! I couldn't even read something on VM fusion! So i tried downgrading to snow leopard but that didn't work so i went all the way back down to Leopard, and then installed updates, and then installed snow leopard - my drive WAS working after i did all this. This leads me to believe it is a software issue and i for the love of god hope apple do something about this soon because i've had enough of their bugs so much so after this macbookpro dies i'm going to go back to windows!


So anyhow after this upgrade back to snow leopard i couldn't restore any of my time machine data because "my time machine backup was created on a newer OS" - ridiculous! So after a day of faffing around i had to upgrade to ML to get all my setting and stuff back and i restored it from time machine and have a drive that doesn't work again - back to square 1!


I've half a mind of flogging this crap machine on ebay and getting a cheapie £300 laptop from somewhere!


Apple if you see this please release an update so i can use my DVD 'superdrive' again please!




P.S. i've got a late 2008 macbookpro.

All replies

  • mjbentoc Level 1 Level 1

    I was abble to reinstall Lion and the drive still doesn't work, but just before installing mountain lion I've recorded a DVD and it was working fine.
    Maybe Muntain Lion made some update to the "BIOS" (pc language, sorry I don't remember the name for MAC) and now "Killed" my superdrive

  • edisc Level 1 Level 1

    I'm having the same issue.  If I put in a data cd, blank cd, DVD movie, etc. it just spins for a minute and then ejects it.  Superdrive is being recognized in disk utility but it just doesn't do anything.  It was working fine in Lion.

  • mjbentoc Level 1 Level 1

    Can it be that only we both have this problem?


    Does Apple see this threads?


    We need an answer.

  • wannatripp Level 1 Level 1

    I have this same problem.... just installed Mountain Lion today.... and now my DVD super drive wont accept a dvd into the drive.... the drive is emtpy too becuase a couple of days ago i just watched a dvd fine before i updated to mountain lion....


    symptoms... when i first reboot the computer or restart the laptop.. theres a clicking sound comming from the superdrive like its trying to accept or eject a disk... i've try placing a dvd in the super drive while it is making these clicking noise.. still doesnt work..



  • JMFralick Level 1 Level 1

    I have the same issue. Burned a disk the day before - did the update and now it doesn't work.This happened to me once before with an old macbook pro, too. I wouldn't be surprised if it was planned obsolescence.

  • edisc Level 1 Level 1

    To be clear, the drive is recognized in Disk Utility.  It just won't read any disc, written or blank, DVD or cd.  Really annoying!!

  • tony92532 Level 1 Level 1

    I have the same problem.  I have the new MacBook with retina that orinally came with Lion and did reliably access my super drive when I used it under Lion.  I also have MacMini 2010 and it also performed well under Lion.  Since installing Mountain Lion neither can access the super drive.  I need this resolved otherwise I will have to try to find a way back to Lion.  Maybe with USB.  If that means going through Snow Leopard to get there it is that important to me.  I need help.

  • Paul.Urmston Level 1 Level 1

    Same here.... and only just realized.


    I clean installed Mountain Lion from a USB (just wanted to make a nice clean start!)


    Everything working fine, and just today I needed to install some HP drivers for our printer.. and yeah.. same thing.


    Disk Utility shows everything ok

      Name : SuperDrive

              Type :           Optical Device


              Device Name :           MATSHITA DVD-R   UJ-868

              Connection Bus :           ATAPI

              Connection Type :           Internal

              Burn Support :           Apple Shipping

              Writes CD :           Yes

              Writes DVD :           Yes

              Media is present :           No

              Capabilities :           Open System Information


    But the **** thing spits out blank DVD's, CD's and any other kind of media.



  • vbfire359 Level 1 Level 1

    Same problem here, drive will not burn get error code saying it is not supported

  • JustPerfect Level 1 Level 1

    I agree. This is enforced behavior modification, like the elimination of firewire ports. Fortunately I paid for Apple Care, so I'm going to make this Tim Cook's problem, not mine (I'm a lawyer.) My MBP is late 2010--not yet two years old--and if this doesn't get resolved I smell a class-action in the offing. It was a Snow Leopard native machine, and the Lion upgrade put it into the hands of the Genius Bar FOUR times for various hardware/software repairs, including TWO new logic boards w/in a month, but Lion still caused constant hanging with interminable Spinning Beachballs of Death when just Safari and Apple Mail were open (4Gb RAM, so it's inexplicable that way.) Mountain Lion stopped this, and actually had me happy with the MBP again in a way that I hadn't been since ditching Snow. Then I discovered that Airplay is non-functional in ML. OK, I thought, screw it, I'll just get Air Parrot for $9.95 and chalk it up. Now I have a Superdrive that's behaving like a mental case and will neither play nor burn, just spin and refuse to eject the CD/DVD WITHOUT A FORCE SHUTDOWN, and holding an otherwise non-responsive eject key during reboot. ***, is wrong with the new management team at Apple? Why did they neither discover, nor warn us in advance about, these problems before seducing us with yet another OS "upgrade" that's a disaster. I thought that I was cured of Early Adopter's Syndrome, but my hatred of Lion left me little choice. Boy, am I sorry now. I don't think that I'll ever trust Apple again in taking a machine off its native OS. IMPROVEMENTS? Only in their bottom line. Welcome to the new Microsoft experience! Size DOES matter I guess. To fantasy-quote Stewie Griffin: "**** you, Tim Cook!"

  • JustPerfect Level 1 Level 1

    My MBP actually gives me TWO error messages. One says it's a connection stability error (code-32030), and when I close that one, the one underneath it says "Couldn't complete the last command because if an OS error". The superdrive shows up in Disk Utility in faint type, and none of the options work. It WILL play and eject a pre-recorded DVD, so it's obviously a coding issue. The clue that it's INTENTIONAL? The new version of iTunes doesn't have a burn button anymore! "D aM n you, Tim Cook!" in Stewie Griffin-speak

  • wannatripp Level 1 Level 1

    Anyluck people???


    i cant even insert a dvd to the dvd drive...??

  • JustPerfect Level 1 Level 1

    Apple Care visit to GeniusBar resulted in replacement Superdrive installation. Now I can burn via iTunes only. Toast Titanium non-functional until I get the paid upgrade required for me to use it on ML. Never upgraded from Toast 10, so now I can't upgrade without $$ to Roxio. I will never take an MBP off its native OS ever again--unless it's unavoidable, and then a clean install ONLY--never an upgrade. Had similar nightmares upgrading from Leopard to Snow Leopard on my previous MBP.

  • mjbentoc Level 1 Level 1

    Why don't you try "Simply Burns" it's free and very fast. Is the one I always used.


    But I have also tried with Toast Titanium and still didn't work.


    I'm considering stop buying apple products. I never had this kind of problem with PC's. I had other problems but there was a solution to every one of them and I'm not seeing any light in the end of the tunnel to solve this problem.

Previous 1 2 3 Next