Previous 1 2 3 Next 43 Replies Latest reply: Feb 11, 2013 8:16 PM by Juan Pablo Go to original post
  • nimoon2 Level 1 Level 1

    I cannot find the folder Library under my user name. Can someone please help me out? I don't want to use iCloud either to sync my calendars already on my iPhone. I've tried it and it has duplicated (sometimes 6 times) my info on my calendar on my mac. This is really annoying. Thank you for any help!

  • MPD01605 Level 1 Level 1

    Open up Finder (or click on your desktop so "Finder" appears in the status bar), click "Go", press and hold the option key, and click on "Library" when it appears.  It's a hidden folder now.  If you'd like to enable it permanently, search for how to make it always be shown.

  • nimoon2 Level 1 Level 1

    I got it to work by finding the way to un-hide the library (as I couldn't find the "Go"). I did all the steps above and it is still not syncing to my iPhone's calendar. I did it several times and even turned off my MBP and my iPhone. No luck. I have my iTunes "Sync Calendars" checked. Not sure what else to do...

  • nimoon2 Level 1 Level 1

    Now it deleted all of my Calendar... All my appointments are gone... AGHHHH!

  • Dudikowski Level 1 Level 1

    I have the problem with iCal asking for passwords for Google all the time. I tried the tip here but I had do put the cache files back. After removing them all my appointments was gone and I only had the birthday calendar left in the side panel. Not good.

     

    So in my case all my impotant data is stored in a cache file. Very strange in my mind.

  • diftong Level 1 Level 1

    Deleting the files in Library did not help.

     

    Deleting the files in Library > Preferences

     

    com.apple.CalendarAgent.plist

    com.apple.iCal.helper.plist

    com.apple.iCal.plist

    com.apple.iCalExternalSync.plist

    com.apple.syncserver.plist

    ...did the job. Thanks!

  • lagante Level 1 Level 1

    Hello! I could not find the cache files so I could not see if the solution workd for me. Can anyone help me to find them please? I have a macbook pro.

    Thanks

  • diftong Level 1 Level 1

    Ok, what language is your Mac OS in? Anyway, you know what the Finder is. There is a Menu called "Gehe zu" (in german) or I think "Go to" in english. FIRST put one of your Fingers on "alt" (aka the Option key) on your keyboard. LEAVE IT THERE. Now go to the menu called "Go to". There is a new item called "Library". Click on it, et voilà, you are there!

  • lagante Level 1 Level 1

    thank you very much for your help and I found the files with the help from your post. Nevertheless I decided to use iCloud and stop having these difficulties because I also believe apple will push us more to it....

  • diftong Level 1 Level 1

    I would repair it anyway.  And then decide, if you want iCloud or not. I don't know if using iCloud stops your difficulties. But thats your decision!

  • lagante Level 1 Level 1

    yes, that's what I have done. Repair and still use iCloud. Using iCloud repaired what I wanted except for the notes synchronization which also stopped working with mountain lion.

    Thank you very much for your help

  • Julatron Level 1 Level 1

    Tried this and the earlier solution - hasnt seemed to make a difference here - iCal and the iphone still arent synching.

  • Millians Level 1 Level 1

    Thanks to everyone for the solutions here. Thankfully I realized my syncing issues coincided with Mountain Lion so I could find this thread. At first, tossing the cache files didn't work for me so I backed up iCal, restarted all of my devices, cleared the files again, disabled my Google Calendar in ICal, turned off and on Calendar syncing in iTunes and now everything works. I'm not sure which of those steps did the trick but I decided to go thermonuclear and just do everything I could think of that might be interfering.

  • diftong Level 1 Level 1

    Thermonuclear is if you do ANYTHING without backup or archive your calendars first. Otherwise you are quite safe. There is one solution from Apple itself:

     

    http://support.apple.com/kb/TS1627

     

    I still hope this is fixed in 10.8.1 (like for people who go from 10.7 to 10.8.1), but I did not hear anything - which might be a good sign.

     

    Patric

  • jojocino Level 1 Level 1

    I am having the same issue and cannot find any of these files in my Library > Preferences folder. Any advice?