Previous 1 2 3 Next 43 Replies Latest reply: Feb 11, 2013 8:16 PM by Juan Pablo
graemecod Level 1 (0 points)

I upgraded to Mountain Lion yesterday, and now iCal does not sync to my iPhone.  I do not use iCloud (and don't want to), so sync via USB cable and iTunes.  How can I get my calendars syncing again?


iPhone 4S, OS X Mountain Lion
  • rbrian Scotland Level 2 (430 points)

    I can't help, except to say that it's not just you.  It doesn't work on my Mac mini, but it does work on my MacBook Air.  I have no idea why one works and the other doesn't, but it does suggest a fix is possible, and if anybody can think of anything to compare between the two machines to try to isolate the problem, let me know and I'll experiment.

  • chineseguy38 Level 1 (0 points)

    I do have the same issue after upgrading to Mountain Lion.

  • mrchief Level 1 (0 points)

    (cross-posting from another thread)

     

    I'm having the same problem. It's as if my iPhone and MacBook Pro now have two separate calendars.

     

    Basically, I have a MacBook Pro (Mountain Lion, 13", late 2011) that I sync via USB with an iPhone 4S (iOS 5.1.1). Before upgrading to Mountain Lion, all of my iCal events would sync flawlessly. But none of the events I've created in iCal (Calendars) since upgrading have synced to the iPhone. Likewise, no new events that I create on the iPhone Calendar will sync to iCal. Also, changes to an existing event (even one created before upgrading to Mountain Lion) don't get synced either.

     

    Everything else seems to be syncing just fine though (music, apps, contacts, etc).

  • graemecod Level 1 (0 points)

    That's precisely my situation.  Looks like a bug.  Hopefully Apple gives us a fix soon.  This is a crisis for me.

  • graemecod Level 1 (0 points)

    Hi people, I think I have a solution:

     

    Quit Calendar, and try removing the cache files from your Macintosh HD/Users/yourusername/Library/Preferences Folder. To find that Library folder, use Finder>Go Menu>Depress the "Option" key>Library. Delete any files with CACHE in their name in the Calendars folder.

     

    When you open iCal again, it says "Updating calendars", and the sync now seems to work.

     

    Of course, do a backup of all calendars before doing any of this.

  • mrchief Level 1 (0 points)

    I can confirm that graemecod's solution appears to work. I went to /Users/username/Library/Calendars/, and deleted the files "Calendar Cache" (no extension) and "Email Cache.plist". After that, I relaunched Calendars, and it spent a few seconds on "Updating Calendars". When syncing to my iPhone, I had to resolve a couple of oddball conflicts, but it was fairly easy, and now everything seems to be syncing properly. I also had a couple of duplicate events, but I've been making a lot of calendar changes this week, so I think that the combination of that plus the Mountain Lion upgrade probably means that those issues are more specific to my situation.

     

    Anyway, cheers graemecod! It looks like you've found a working solution!

  • chineseguy38 Level 1 (0 points)

    Thanks guys. I switched on iCloud on my iPhone 4s then switch it back off to remove all in calendar. Then select all the sync options back on iTunes, and sync the iPhone.  It works!

  • srnair Level 1 (0 points)

    Thanks graemecod.  Your solution worked for me too.  But I had to restart my iphone to get it working properly.

  • CSMatMV Level 1 (0 points)

    Yep, thanks for the good word.  I finally got mine syncing too by shutting it all down, deleting the Calendar cache AND Email Cache.plist files, restarting my MBP and voila, it's finally all there!  Thanks again!

  • gchoban Level 1 (0 points)

    MUCHO Thanks!  This worked for me as well!  Both my Iphone and iPad are back in the saddle with calendar syncing and NO ICLOUD requirement.

  • MPD01605 Level 1 (0 points)

    Thank you very much.  This solved my problem, too. 

  • sixnon Level 1 (0 points)

    alas, whilst i have the updating calendar message, it still does not sync for me despite following this and official Apple help for resetting calendars etc..

  • Little Birdie Level 1 (0 points)

    sixnon I also did not manage to resolve the issue using the above method - you are not alone! 

  • moosenhoothers Level 1 (0 points)

    This worked for me with one slight alteration.  I use gmail (google cal).  I first did as graemecod instructed and deleted the cache files, however this did not reset anything in calendar (OS 10.8). So I opened calendar preferences and deleted my gmail account from there.  I then quite calendar, deleted the calendar cache, and then opened system preferences>mail, contact & Calendars>chose gmail>checked calendar then I reopend calendar and there was my full google calendar.  I am currently waiting on all of my delegate calendars to open up but I think this has solved my issue.

     

    Issue:  Calendar would say that google cal PW was incorrect or that there was a server issue.  Sometimes entering in the PW several times would fix the problem for a day or so but this has been getting worse since over the last several days (started with Mountain Lion update).

Previous 1 2 3 Next