Previous 1 7 8 9 10 11 Next 162 Replies Latest reply: Dec 14, 2014 7:54 AM by arkling Go to original post
  • igroucho Level 1 (0 points)

    I think many here have done that, I for one have set it to 6 hs. Even if it were as U say it still would be a huge problem if the MB wouldn't "wake" from a blank screen. No this is NOT the issue here. I have no problems since shutting down bluetooth, the machine wakes up instantly AND working from sleep. It takes some time for it to wake up from powernap which is to be expected and natural.

    I wonder if hardware is different related to the bluetooth module so some MBs will have this problem while most don't??

    This is my report:

    Apple Bluetooth Software Version:          4.1.2f9 11046

      Hardware Settings:

      Address:          B8-F6-B1-16-A4-0C

      Manufacturer:          Broadcom

      Firmware Version:          v100 c5055

      Bluetooth Power:          Off

      Discoverable:          Off

      Vendor ID:          0x5ac

      Product ID:          0x8286

      HCI Version:          6 (0x6)

      HCI Revision:          5055 (0x13bf)

      LMP Version:          6 (0x6)

      LMP Subversion:          8804 (0x2264)

    Any input on this is welcome!

  • liltunechi Level 1 (0 points)

    i was having the same issues because i had ReFind install on my MBPr, no wake up frome sleep after 4-5 hours close .... I remove ReFind and everything it's ok now !

  • Andrew Montgomery3 Level 1 (0 points)

    Summer Storm Pictures wrote:

    These were the Terminal commands I ran and in this order:

    sudo pmset -a hibernatemode 3

    sudo pmset -a autopoweroff 0

    sudo pmset -a autopoweroffdelay 36000

    sudo pmset -a standby 0

    sudo pmset -a standbydelay 36000

    sudo pmset -a acwake 0


    The two 'delay' entries will be ignored.  The standbydelay specifies the delay, in seconds, before writing the hibernation image to disk.  Since hibernatemode is set to '3', this hibernation image file will only be used in the event of a loss of power.  If hibernationmode were set to '25', as soon as the hibernation image file is written, memory would be powered off and waking from sleep would require reading the hibernation image file.


    But since 'standby' is OFF (set to 0), it will never write the hibernation image to disk.  So the standbydelay is irrelivant.


    The autopoweroffdelay specifies the delay, in seconds, before powering off memory when hibernationmode is set to '3'.


    But since 'autopoweroff' is OFF (set to 0), it will never power off memory (unless power is lost, of course).  So the autopoweroffdelay is irrelivant.


    This essentially turns off hibernation, which can be accomplished directly with a single commmand:


    sudo pmset -a hibernatemode 0


    Note that the '-a' option applies this setting to all power situations (battery, wall power, and UPS).  That may not be what you want.


    If this works for you, fantastic.  But it's hardly something Apple Support should be broadly recommending for everyone reporting a "wake from sleep" issue.  As we've seen in this thread alone, there are many, many different causes for the same symptom.

  • Summer Storm Pictures Level 1 (0 points)

    Wow. People are still responding to this.


    Again, and to reiterate one more time...I am well aware that some of these commands do nothing in context with themselves.


    My reason for including the entire set was to conform a wide variety of settings that people had been tinkering with at the time to some sort of uniformity.


    Also, if you look back through the entire discussion, you'll see that many had tried just the "sudo pmset -a hibernatemode 0" command with no success, and probably because everything else was out of conformity.


    As for me,  mine has been working perfectly now since however long ago I posted last, and what's more, I'm getting consistently on average, 7-hours of battery life with my kind of normal use.

  • Andrew Montgomery3 Level 1 (0 points)

    Apologies, Summer Storm Pictures.  Your concise list of commands was very valuable, both to me and many others.  I only hoped to pull the curtain back a bit further with some explanation of these settings.


    I read the vast majority of this discussion.  I saw no mention of setting 'hibernatemode' to 0 by anyone in the thread, although I may have missed it.  If I've repeated this, apologies.


    Just to be clear, I think this workaround seems useful, reasonably safe to implement, and simple to reverse.  I'm only taking issue with several posts that were surprised that Apple hadn't figured this out themselves.  The question isn't whether they figured it out or not, but whether they should be broadly recommending this workaround.


    Again, great find.  Thank you for posting it.

  • YoungTurk Level 1 (5 points)

    Summer Storm - regarding your 6 commands. Do I copy and paste all 6 commands at one time in Terminal, or enter each line separately, one at a time, followed by the Return key, then the next line etc?

  • Summer Storm Pictures Level 1 (0 points)

    (Just re-read your last post) NO--One-at-a-time/line-by-line in Terminal with a return. The first time you will probably have to enter your password, which while you key it in, won't show anything, just do it and hit enter, then follow with the rest of the commands with enter after each one.


    Hope this works for you. I've been going for over a month now.

  • YoungTurk Level 1 (5 points)

    Got it, and thanks for the quick reply. Just entered the commands one at a time, line by line in Terminal. You're correct - the first time it requested my password, then I entered each of the commands without incident. Did a quick test - closed my rMacBook Pro, came back about 5 minutes later, opened it up and my screen lit up and the computer awoke instantly from sleep. I'm going to plug it in now for several hours, let it sleep, then see what happens.


    I'm running the latest 10.8.3 build (customer seed) on a 13" rMacBook Pro (8/256) with 2.5 ghz i5.


    Thanks again.

  • YoungTurk Level 1 (5 points)

    After about 4 hours plugged in, in clamshell mode, I opened my rMacBook Pro, and my screen lit up instantly from sleep.

  • Summer Storm Pictures Level 1 (0 points)

    Glad it helped you. It'll do likewise on battery. I know this is a strange work-around for whatever seems to be ailing the Apple coders lately, but there's really no excuse for a "pro" rated machine to be as problematic as this...and for the buyer to have to come up with their own solution.


    It just seems like there are fails far too often when it comes to badly Q-C'd software updates lately. The iOS isn't even immune.

    What the heck's going on at Apple?

  • kljohnson Level 1 (0 points)

    Just went to apple store and they replaced my rMBP.  No problems for 3 days now.

  • WPWoodJr Level 1 (0 points)

    Apple seems to have added a new setting, "autopoweroff", to allow the system to hibernate when the lid is closed and the laptop is on AC power.  This complements the "standby" setting which is only active when on battery power.


    Some power settings are configurable for different power sources, for example "darkwakes".  Some settings, like "standby" and "standbydelay", despite being independently configurable for AC and battery power, seem to only ever have been active when the system is on battery power.


    Apple wanted to introduce a hibernate setting for AC power, and since the the historical use of "standby" was only for battery, people would be upset if "standby" settings started to apply while on AC.  So Apple probably thought it was best to create a new setting just for AC - "autopoweroff".   They should have called it "acstandby", that would have been less confusing.


    The new "autopoweroff" setting is causing our laptops to hibernate more often.  Hibernating Macs seem to sometimes have problems with the graphics card when resuming from hibernation, causing issues for people that didn't have them before "autopoweroff".

  • YoungTurk Level 1 (5 points)

    Ok, so today I unplugged my rMB Pro from the TB display where it had been charging only, moved to my desk, opened it up, and unlike the last week, this time my screen was black and I had to push the power button to awaken it. I don't remember whether it re-booted on its own, or if I did, but it booted in Safe Boot mode. I zapped the PRAM a couple of times before typing this. Am I SOL? Can/should I reverse the fix?

  • Bandik Level 1 (0 points)

    I have the same issue, but can't add anything helpful here.


    I have a rMB Pro, brand new. No Backup was restored on it. I am using a Synology NAS (running DSM 4.1) for Time Machine Backups. The NAS goes to sleep from time to time, reading the console entries it seems to be doing fine.


    In the console of the Mac the last entries before freeze were

    27.02.13 07:18:54,000 kernel[0]: LE is supported - Disable LE meta event

    27.02.13 07:18:54,000 kernel[0]: IOThunderboltSwitch(0x0)::listenerCallback - Thunderbolt HPD packet for route = 0x0 port = 11 unplug = 0

    27.02.13 07:18:54,000 kernel[0]: Wake reason: XHC1


    (no Thunderbolt Hardware or other is attached to the Mac)

  • Erictronique Level 1 (0 points)

    Same with me!