Previous 1 2 Next 17 Replies Latest reply: Dec 27, 2014 9:43 AM by dddmusic
m. hannan Level 1 Level 1

Since installing Mountain Lion I keep getting the message "CalendarAgent wants to use your confidential information stored in "Exchange Access Group" in your keychain." Even when I accept allow, it keeps prompting, let alone when I deny it. It is super-irritating. What happened?

 

I have cleaned my machine, and did disk repair from my Disk Utility. The problem still persists.

 

Advice, pls.


MacBook Pro, Mac OS X (10.6.8)
Solved by Daniel Prince on Aug 11, 2012 9:33 PM Solved

I had an "Always Allow" button. I pressed that and it stopped asking. Why did you guys delete everything?

Reply by Flexrkr on Aug 1, 2012 10:18 PM Helpful

I have had the same problem after upgrading my macs to mountain lion on two machines.  The error-

 

---

 

calendaragent wants to use your confidential infomation stored in "Exchange Access Group" in your keychain

 

--

 

I went to my keychain and deleted everything.  No more issues.

 

Am an advanced user but haven't ever really found much use for the Keychain feature.  More trouble than anything.

 

Hope that helps.

All replies

  • pxlmnky Level 1 Level 1

    I have the same problem having just moved to Mountain Lion. I have had similar issue before when upgrading, I'm fairly sure its something in my private (locked) keychain that needs to be moved to my login keychain - thus avoiding the prompt as this keychain is by default unlocked.

     

    The problem is that Mountain Lion seems to have put a dozen or so things in to my keychain, most of which arent easily identifiable and none of which makes any reference to Calendar Agent. I guess the easiest thing would be to switch them all to the login keychain and move them back one by one until the culprit is triggers the prompt again.

  • Flexrkr Level 1 Level 1

    I have had the same problem after upgrading my macs to mountain lion on two machines.  The error-

     

    ---

     

    calendaragent wants to use your confidential infomation stored in "Exchange Access Group" in your keychain

     

    --

     

    I went to my keychain and deleted everything.  No more issues.

     

    Am an advanced user but haven't ever really found much use for the Keychain feature.  More trouble than anything.

     

    Hope that helps.

  • pxlmnky Level 1 Level 1

    That did it for me, although I don't have "Exchange Access Group" in my keychain it rang a bell. It turned out to be the details of a new exchange email account I recently added, once I moved them to the login keychain the prompts stopped.

     

    I didn't use keychain until I got a laptop and subsequently paranoid about it getting nicked. I mainly use keychain for peace of mind with browser autofill. It allows me to make lots of different strong passwords but only have to remember one.

     

    Thanks for the help Flexrkr.

  • Daniel Prince Level 1 Level 1

    I had an "Always Allow" button. I pressed that and it stopped asking. Why did you guys delete everything?

  • pxlmnky Level 1 Level 1

    There was no "Always Allow" option for me.

  • cosmo-lv Level 1 Level 1

    I have similar problem it appears every time i restart my mac

     

    CalendarAgent wants to use the "passwords" keychain

     


  • Riccardo S. Level 1 Level 1

    happens to me all the time, that and sometimes even Mac Os X wants to use my login pass, I tried to unlock Keychain, but nothing, I can't delete all those passwords, has nobody foud a solution for this?

  • m. hannan Level 1 Level 1

    I had that "Always Allow" option, but I was hesitant to use this. I was not sure what it entails, and I did not want to jeopardize the security of my machine. Nonetheless, I used this option and thus far I face no problem (I hope).

  • m. hannan Level 1 Level 1

    *Flexrkr, this sounds a good option, but I opted for the Always Allow before I considered your option.

    I checked my keychain and I saw a list of names/accesses. I was not sure what to delete, what not to delete or delete all. I therefore opted for Always Allow. May not be the best option though.

     

    BTW, what is the function of the keychain?

  • veedow Level 1 Level 1

    Me too. Always Allow did not fix for me. The solution for me was... System Prefs/Mail, Contacts & Calendars. Select the Exchange Account, click on Details button. Password field was blank. Enter password and all was fine after that. Hope this helps someone else.

  • general_error Level 1 Level 1

    What a HUGE failure of Apple (yet again).

     

    I just upgraded to 10.8 and am getting this error constantly.  All my co-workers who upgraded to 10.8 are getting this popping up on their screens CONSTANTLY now:

     

    "CalednarAgent wants to use your confidential information stored in 'www.google.com' in your keychain.  Do you want to allow access to this item?"

     

    And no matter how many times you click DENY  -- IT KEEPS POPPING BACK UP.  Over and over and over and over and over and over and over and over and over and over and over again.

     

     

    HUGE FAILURE of Apple here.

     

    The only way I've found to stop this problem is to drop into shell, sudo su to become root, and chmod 000 the CalendarAgent binary, and then ps and kill -9 the CalendarAgent to MAKE IT STOP !!!

  • Brett Humphreys Level 1 Level 1

    I fixed this on Mountain Lion by:

    1.  Opening Key Chain Access

    2.  Right click "login" Key Chain and selecting "Change settings for key chain login"

    3.  Untick lock after inactivity and lock when sleeping.

    4.  Manually lock the login key chain and then unlock again.

     

    Everything has been fine since.

  • berkoz912 Level 1 Level 1

    I just started getting this once I updated to Maverick. Going into keychain access sin't working for me.

     

    Any suggestions?

  • amulz Level 1 Level 1

    This seems to have fixed the problem for me. I opened Calendar.app and chose Accounts. From there I saw an old Exchange account, so I deleted it. I then disabled calendar sync in iCloud.

     

    Hope this helps cause this was ANNOYING!

Previous 1 2 Next