Previous 1 2 3 4 Next 50 Replies Latest reply: Nov 20, 2014 11:04 AM by puzne Go to original post
  • qtrules Level 1 (10 points)

    i don't know how... but updating to 10.8.2 completely fixed my problem.

     

    this isn't the first time that a system update has "unfreed" safari. safari 5 was slow on my machine, to the point of being unusable. upgrading to mountain lion seemed to liberate it! so i switched over to it again, and was annoyed when it stopped working.

     

    why does it do this...? there's no rational explanation. i haven't changed any settings - everything is the same.

  • dev.apple Level 1 (0 points)

    Same here, annoyed by the radomly not loading the pages. On my ML these also happens on both chrome and firefox too. I think this issue is OS network related and not just limited to safari.

    Oh! updating to 10.8.2. I am bewildered, as when was at my friends house i got a notification for the updating 2 updates

    1. xcode 4.5
    2. update to 10.8.2

     

    But when i came on my home network it only showed xcode 4.5 update, although i did not update earlier to 10.8.2

     

    what a confusion.

  • huwon9 Level 1 (0 points)

    The solution is to use Chrome.  It will solve all the Safari issues immediately.

  • nocabari Level 1 (0 points)

    Safari was working fine before I  downloaded the security update for Java.  Now, I'm using Firefox instead.

  • de-cive Level 1 (10 points)

    Same problem here. WLAN and Bluetooth is off. I tried Chrome -> same problem. Disabled prefetching -> same problem. When I quit Safari and start Safari again it works.

     

    Kind regards,

    Torsten,

    Germany

  • mattrwilson Level 1 (0 points)

    Just wanted to say that I'm having the exact same problem. 10.8.2, WebGL off. Happens on both my home wifi and my work wifi. Just started a few days ago. About to reset safari and hope that it fixes the issue. 

  • nocabari Level 1 (0 points)

    Finally had the nerve to re-install Mountain Lion from Time Machine backups and this fixed Safari too.  Eventually the Safari update popped up again and this time after upgrading to 6.0.2, Safari remained stable and loaded web pages just fine.

  • Obi-Morpheus Level 1 (0 points)

    Check the Develop dropped down menu and make sure you haven't unintentionally checked Disable Images instead of emptying Caches.  That's what happened to me.

  • hisyam Level 1 (0 points)

    I'm having the same problem especially when opening Facebook.com , some of the image will not load properly either in safari, chrome or firefox.

     

    I just solved this problem a few hours ago by updating silverlight plugin in firefox and others plugin. I also check every extension/add-on in every browser and remove the unwanted one.

  • Tjayau Level 1 (0 points)

    thanks,  that was the perfect fix!

  • de-cive Level 1 (10 points)

    But I have no plugins/extensions/add-ons installed. And Safari still stops loading pages.By the way: FTP is very slow.

  • zweitwo Level 1 (0 points)

    Same problem here: no plugins/extensions/add-ons installed, WebGL disabled and Safari still stop loading pages or loads them incomplete on 10.8.2. After pressing + R pages are loaded correctly.

  • hisyam Level 1 (0 points)

    try open safari in 32-bit mode

     

    in Application folder , right/ctrl click Safari app , Get Info , tick open in 32-bit mode checkbox

  • marianfromquincy Level 1 (0 points)

    Thank you hisyam!! That really helped.

  • hisyam Level 1 (0 points)

    No problem marianfromquincy , I'm glad it helped ..