Previous 1 2 3 Next 129 Replies Latest reply: Jun 2, 2013 3:21 PM by Christopher Murphy
taylor136 Level 1 Level 1

I have a very new iMac and had Win 7 installed on Bootcamp with minimal trouble and it's been running great, had it set up so that if I just restarted it would automatically boot Windows. Awesome, I love Mac. Problem now is, I just installed Mountain Lion and not only does it not auto-boot to windows, I can't get the Dual boot screen (holsing Option after restart) at all. I've tried several times to make sure that Option is regestering upon startup, and it's all good.


I usually have good luck finding answers to stuff like this on the forums but I'm not seeing any cases exactly like mine yet. I would love any advice anyone can offer and I'm happy to provide any info about my system that could help.

iMac, OS X Mountain Lion, 27" 3.4 GHz Intel Core i7
Solved by The hatter on Jul 29, 2012 6:43 AM Solved

Why not just try Windows 7 DVD and boot that, maybe you need to edit the BCD was all.

  • McManni Level 1 Level 1

    I have exactly the same issue. The partition is still there, but for some reason ML is unable to select if for boot.


    Here is how to solve it:


    Check that the paretition is still there. It should show up on your desktop, otherwise check with disk utility.

    If it is then:

    0) If there is any essential data on it, copy the data to another drive, just in case the below doesn't work. Also make a backup of your OSX partition and data to be on the safe side. All should go smoothly, but we're talking computers, so pelase make sure you backup everything before.

    1) Get Winclone from TwoCanoes (it's a great utility which will help you if you want to upgrade your HDD without having to reinstall Win)

    2) Use Winclone (make sure it's the latest version, compatible with Mountain Lion, not one of the old free ones) to backup your Windows partition. You can back it up on your OS X partition, it's just one file. Ideally do it on an external HDD, it will be faster.

    3) Use Bootcamp assistant to go back to one partition. Your Windows partition will be deleted, and you'll be back to have only one OSX partition taking the whole HDD

    4) Restart

    5) Use Bootcamp assistant to create a new Bootcamp partition. You can use the opportunity to change the size of the Windows partition to make it smaller or larger than it used to be. Winclone doesn't care about the size when it restores, so it doesn't have to match. Don't redownload the tools, and don't install Windows, it's not necessary. When Bootcamp assistant has created the BC partition, stop it before it installs windows and reboot.

    6) Use Winclone to restore your bootcamp partition.

    7) Restart, and hope for the best...


    Let us know if that worked for you as it did for me.

  • The hatter Level 9 Level 9

    Why not just try Windows 7 DVD and boot that, maybe you need to edit the BCD was all.

  • McManni Level 1 Level 1

    That could be a good first call, just make sure you have a backup of both partitions.


    Also I thought if you have upgraded Paragon NTFS before ugrading SL to ML, the NTFS drivers of Paragon prevent you from selecting the Bootcamp partition to boot. You either have to select it for boot from the Parangon settings in the pref panel, or disable the Parangon drivers to make sure OS X is able to see the partition and therefore allow you to select it.

  • The hatter Level 9 Level 9

    NTFS as startup disk is one thing but people use it to write and mount NTFS volumes to use under OS X.


    Where does the "can't access NTFS partition" fit in? odd?

  • McManni Level 1 Level 1

    It might be odd, but that's the way Parangon NTFS works.


    When it's enabled, OS X can't select the Bootcamp partition as a startup disk, that's why it provides an option in its own panel in the preferences to select Bootcamp and boot from it.


    Of course it can read/write to/from any partition (including the Bootcamp). But OS X can't select BC to boot.


    If you only use NTFS occasionally, you can disable the drivers and that way the usual control panel fromn OS X allows you to select the Bootcamp partition.


    It just occured to me that the OP might have forgotten about this if (s)he uses Parangon NTFS.

  • The hatter Level 9 Level 9

    yes I own and know that startup disk preferences change but it isn't really disabled, is it.

    Option key works so it isn't blocking or preventing that either.


    If someone forgot they would likely see Paragon though in the control panels.

    Paragon sent out emails about 10.0 so that should trigger their memory!

  • Christopher Murphy Level 3 Level 3

    There are no GUI tools on Mac OS X that will properly show you the disk's partition after Boot Camp has altered the disk. There are TWO partition tables after Boot Camp Assistant has created the partition for Windows, MBR and GPT. Disk Utility only shows you the GPT. And Disk Utility does not repair either partition table, it only repairs file systems (HFS+ and FAT).


    I request that anyone who has upgraded to ML, who can no longer boot into Windows, go to Terminal and type the following read-only commands, which do not change any information on the disk, and post the results to the forum. No private data is in any of this, other than possibly the name of your hard drive.


    sudo gpt -r -vv show disk0

    sudo fdisk /dev/disk0


    I'm curious what the GPT and MBR look like relative to one another, and if possibly the MBR has somehow been reset to a PMBR, which would explain the problem.

  • Caillin Level 1 Level 1

    I'm having the exact same issue after doing in-place upgrade to ML with a Win8 Bootcamp partition.  After upgrade, I no longer have the option to boot into Windows by holding option.


    Here are the results of the commands as requested:


    gpt show: disk0: mediasize=500107862016; sectorsize=512; blocks=976773168

    gpt show: disk0: Suspicious MBR at sector 0

    gpt show: disk0: Pri GPT at sector 1

    gpt show: disk0: Sec GPT at sector 976773167

          start       size  index  contents

              0          1         MBR

              1          1         Pri GPT header

              2         32         Pri GPT table

             34          6       

             40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B

         409640  742851896      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC

      743261536    1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC

      744531072  153633664       

      898164736   78608384      4  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7

      976773120         15       

      976773135         32         Sec GPT table

      976773167          1         Sec GPT header






    Disk: /dev/disk0geometry: 60801/255/63 [976773168 sectors]

    Signature: 0xAA55

             Starting       Ending

    #: id  cyl  hd sec -  cyl  hd sec [     start -       size]


    1: EE 1023 254  63 - 1023 254  63 [         1 -     409639] <Unknown ID>

    2: AF 1023 254  63 - 1023 254  63 [    409640 -  742851896] HFS+       

    3: AB 1023 254  63 - 1023 254  63 [ 743261536 -    1269536] Darwin Boot

    4: 0C 1023 254  63 - 1023 254  63 [ 898164736 -   78608384] Win95 FAT32L

  • McManni Level 1 Level 1

    I have no idea which version of OS X you have, but Disk Utility is perfectly able to display ALL the partions on a drive, including the bootcamp one, so my advice to use it to see if the partition is still there is perfectly valid.


    True, it will not repair it if something is wrong, but it will allow you to check if it's there or not.


    Anyway, I've given advice:


    1) Check if Paragon NTFS is not preventing your bootcamp partition from showing up in the startup panel

    2) Otherwise follow the procedure I initially outlined. It worked for me.


    One thing though, Winclone can restore in a larger Bootcamp partition, but not a smaller one, so make sure if you use BC assistant to reformat that your new BC partition is the same size or larger, otherwise Winclone's restore will fail.


    Signing off now as I don't understand all the pseudo advice going on here. It's a simple situation and it's easy to resolve if you follow the above.

  • Christopher Murphy Level 3 Level 3

    I see two things. First, notice this fourth line from your GPT. It says ~73GB of disk space is not allocated to any partition, it's free space. Why?


    40          409600       1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B

    409640      742851896    2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC

    743261536   1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC

    744531072   153633664      

    898164736   78608384     4  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7


    The good news is that partition 4 for Windows in the GPT and MBR have the same start - end sectors. However in the MBR no partition is marked bootable. One must be bootable and it's customary for Apple to mark the Windows partition bootable. I strongly suspect this is why Windows is not a boot option, and it's rather easy to fix.


    4: 0C 1023 254  63 - 1023 254  63 [ 898164736 -   78608384] Win95 FAT32L


    My suggestion is that you reclaim the missing free space before you proceed with MBR repair, but missing ~73GB of space isn't hurting anything. Try the following and report back:


    diskutil list /dev/disk0

    diskutil resizevolume /dev/disk0 limits


    Again both are read-only commands and do not alter the disk information in any way.

  • taylor136 Level 1 Level 1

    Wow thanks for the responses!! Just another reason why I love Apple.


    After posting this I didn't see a reply for a bit (it was late at night) so I called AppleCare, and sure enough, they recommended I boot from the Win 7 disk, so I booted from the Win 7 disk it kicked something into gear, now I've been able to boot back to bootcamp without *much* problem-


    the one issue remaining, which isn't a big one, is that I have a wireless aluminum keyboard, and for whatever reason if I don't hit the Option key at the precise right time, bootcamp won't show up, I've had to retry it 2-3 timesalmost everytime I restart and try to change- So I know it's a long shot, but if any of you are also using a wireless Apple Keyboard, there may be some issue with getting it to register in time for Bootcamp to kick in at the startup.


    Just a thought, sorry if it's not enough to help you guys. 

  • Christopher Murphy Level 3 Level 3


    What I said is that Disk Utility only shows the partitions as described by the GPT. It does not inform you at all about the state of the MBR. It is a nearly useless tool for troubleshooting Boot Camp problems, a large percentage of which have to do with the MBR, not the GPT.


    You admit you don't understand what's being discussed, yet you call it pseudo advice? Before you essentially call someone a liar on a public list, you might actually like to understand what's being discussed.

  • Caillin Level 1 Level 1

    Not sure why the unclaimed disk space is there.  I had originally upgraded the built-in hard drive to a 120Gb SSD, but due to space constraints and my frustration with Mac OS' unwillingness to show me where it was using disk space to effectively manage, I used winclone and moved to a 500Gb 7200 RPM hard disk.  This is most likely where the funny partition information is coming from.  Saying that though, after the upgrade, and while still on lion, everything was working perfectly for dual boot.


    Here is the output from the commands you requested:



       #:                       TYPE NAME                    SIZE       IDENTIFIER

       0:      GUID_partition_scheme                        *500.1 GB   disk0

       1:                        EFI                         209.7 MB   disk0s1

       2:                  Apple_HFS Macintosh HD            380.3 GB   disk0s2

       3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3

       4:       Microsoft Basic Data                         40.2 GB    disk0s4




    Volume format does not support resizing



    disk0s4 shows up in disk utility, but as mentioned, OSX can't do anything with it.  I definitely lack the skills on OSX to repair the MBR on the windows partition, though it's a straight forward (read: familiar ) process in windows.  Very much appreciate the help, and goes a long way to show just how good the community can be for Apple.

  • Christopher Murphy Level 3 Level 3

    My mistake, try this instead:

    diskutil resizevolume /dev/disk0s2 limits

Previous 1 2 3 Next