Previous 1 2 Next 29 Replies Latest reply: Jul 31, 2012 8:29 PM by WZZZ
jackthelad Level 1 (10 points)

I have tried every suggestion that I can find to disable Google's auto update including the Terminal command:

sudo /Library/Google/GoogleSoftwareUpdate/GoogleSoftwareUpdate.bundle/Contents/Resou rces/ --uninstall


According to my Console, this software update is being launched every 10 seconds. All Google software has been removed, as well as all Google Keystone related .plist that I could find, but to no avail.


Have anyone found a viable solution to this agent that continues to flood my Console searching for something that seemingly doesn't exist?

MacBook, Mac OS X (10.6.8), Intel Core 2 Duo Processor
  • roam Level 6 (13,565 points)

    Post just the one line from the Console log, showing us the message.

  • jackthelad Level 1 (10 points)

    This is the command that is endlessly repeated:


    Sun Jul 22 20:01:28 mm-computer[1] ([565]) <Warning>: Exited with exit code: 1

    Sun Jul 22 20:01:28 mm-computer[1] ( <Warning>: Throttling respawn: Will start in 10 seconds

    Sun Jul 22 20:01:38 mm-computer[1] ([566]) <Warning>: Exited with exit code: 1

    Sun Jul 22 20:01:38 mm-computer[1] ( <Warning>: Throttling respawn: Will start in 10 seconds

    Sun Jul 22 20:01:48 mm-computer[1] ([567]) <Warning>: Exited with exit code: 1

    Sun Jul 22 20:01:48 mm-computer[1] ( <Warning>: Throttling respawn: Will start in 10 seconds



    After trying ds store's suggestion, I continue to receive the 'throttling respawn' every 10 seconds, but now with the addition of "No such file or directory'


    7/28/12 2:25:19[1]([19996]) Exited with exit code: 1
    7/28/12 2:25:19[1]( Throttling respawn: Will start in 10 seconds
    7/28/12 2:25:29[1]([19997]) posix_spawn("/Library/Google/GoogleSoftwareUpdate/GoogleSoftwareUpdate.bundle/C ontents/MacOS/GoogleSoftwareUpdateDaemon", ...): No such file or directory
  • roam Level 6 (13,565 points)

    You would think ds-store's pointer would had have worked.


    Have you searched for "" for any reference to it on your computer?


    I have not installed Google Chrome, nor had the problem of getting rid of it so what follows is more out of curiosity than troubleshooting… In Terminal, what is the output of the following command. Copy and paste it to avoid errors


    kextstat | grep -v apple

  • jackthelad Level 1 (10 points)

    After entering 'kextstat | grep -v apple' in Terminal, this was the result:


    Last login: Sat Jul 28 23:17:19 on console

    You have mail.

    mm-computer:~ miles$

    Index Refs Address    Size       Wired      Name (Version) <Linked Against>

       95    0 0x1154000  0x4000     0x3000     com.globaldelight.driver.BoomDevice (1.1) <93 5 4 3 1>

      100    0 0x925000   0x4000     0x3000     com.Cycling74.driver.Soundflower (1.3.1) <93 92 8 5 4 3 1>

      120    0 0x4615f000 0x5000     0x4000 (1.0.0) <5 4 3 1>


    What is this indicating?


    I should point out once again that all Google related programs have been removed (Chrome, Google Desktop, etc.), however some of the peripheral files may still be present, buried in sub-folders somewhere.

  • WZZZ Level 6 (12,795 points)

    This is everything keystone on my system. I only have Chrome (and only as a backup browser) installed in my user and nowhere else, so it's possible you might find it elsewhere, depending on your settings.








    /Users/****/Library/Google/GoogleSoftwareUpdate/TicketStore/Keystone.ticketstore .lock




    Get EasyFind and search.


  • jackthelad Level 1 (10 points)



    The only references to Keystone or GoogleSoftwareUpdate/TicketStore are in my crash log. When following the paths that you listed, none of the files are present.

  • roam Level 6 (13,565 points)

    This may be the cause. Concentrate on removing that.



    I could suggest a command to unload that, but as I have not actually unloaded that driver, I can't confirm the command would work. In other words I can't test it and don't want to put your system at risk if something was mistyped. This driver sits at a fundamental level but that is what I'd be angling to get rid of.

  • WZZZ Level 6 (12,795 points)

    What's in /Library/LaunchDaemons and, same place, LaunchAgents? Also, Accounts>Login Items?


    Have you tried EasyFind? Make sure you have show invisible checked and search all files folders. Also check your home folder/Library for LaunchAgents


    If you find any in LaunchDaemons or Agents, you can disable them using the following:


    sudo launchctl unload -w (space) path to file


    or just use  sudo launchctl unload -w  leave a space and drag in the file.


    This can easily be reversed by substituting


    sudo launchctl load -w


    After hitting return, you will be asked for your admin pword, which you won't see as you type it in, then hit return again.


    This won't work for the file roam gave you. There is an easily reversible command for that as well. For that, have a look in /System/Library/Extensions.

  • jackthelad Level 1 (10 points)



    '' does ot exist. The only Google files that i can find are included in System/Library/Google file which includes a Frameworks folder containing 'Gild.frameworks' and a 'GoogleML' folder with a 'GoogleML.bundle.' All other references to Google have been eliminated as far as I can tell. I might also add that I've searched for 'invisible' files and folders as well utilizing Easy Find.

  • jackthelad Level 1 (10 points)



    Launch Daemons and Launch Agents related to Google Keystone are no where to be found. The only Google related Launch Agent found is: '' Could that be the culprit? I'm uncertain what GoogleML really is.



    Meanwhile, the following are included in my Log In items:


    Growl Helper

    Smart Reporter


    Microsoft AU Daemon

    Expander Daemon

    Space Control












    HP Scheduler


    I will try your command options if you think that that still might apply.

  • roam Level 6 (13,565 points)' does ot exist.

    It does exist. You have already proved that. But it is not something to be found in Finder. It is a process that is loaded in the kernel.

    I said "This driver sits at a fundamental level"


    It does not have to be removed, it has to be unloaded. using the correct command in Terminal.


    I cannot specify the command because I don't have that driver loaded to test it. If you unload the wrong thing, and there are dozens and dozens of kernel extensions, you can make your system inoperable. This is no time for me to try an experiment on your computer.


    edit: deleted extraneous information.


    Message was edited by: roam

  • roam Level 6 (13,565 points)

    The only Google related Launch Agent found is: '' Could that be the culprit? I'm uncertain what GoogleML really is

    You seem to have Google stuff still being loaded after all.

  • jackthelad Level 1 (10 points)



    I searched specifically for ',' not realizing that 'Gild.frameworks' might be in some way related. Likewise with 'GoogleML.' Since I've been focused on uncovering anything containing 'google.Keystone' and its corresponding Launch Agents, I ignored anything else assuming they were independent. Obviously, I'm getting in over my head at this point. I'm very wary of tinkering with System files for fear of making things inoperable (as you pointed out).


    I believe at this point I'll just let things sit for awhile and come back to it later. My head's swimming right now. Perhaps after letting the dust settle a bit, things will make a bit more sense to me and become clear.


    Thanks to all --- yourself, ds store, and WZZZ --- for your input regarding this. Much appreciated.


    Message was edited by: jackthelad

Previous 1 2 Next