Previous 1 2 3 4 5 Next 56 Replies Latest reply: Oct 1, 2013 9:14 AM by tobiamoo Go to original post
  • noilnoil Level 1 Level 1
  • Magnat Level 1 Level 1

    Solved, make a alias of your Windows (or whatever name is your NTFS drive) and place it on the desktop, it will work just like usual disk, to do it delete lines on fstab file, unmount and mount make alias and re add lines to fstab and unmount and mount again    Screen Shot 2013-09-28 at 1.23.38 AM.jpg

  • diegoleo Level 1 Level 1

    I works properly with 10.8.5 with diskutil info /Volumes/Data | grep UUID, and monting the drive on the file with:

     

    head -1 /etc/fstab

    UUID=AEE2EA9A-821B-4E31-A024-F4E8BAF1DC39 none ntfs rw,auto,nobrowse


  • C F McBlob Level 4 Level 4

    Magnat wrote:

     

      Screen Shot 2013-09-28 at 1.23.38 AM.jpg

    O.T.   "Nice bug. Is that a vert or a makeshift Hebmuller?"

  • Magnat Level 1 Level 1

    It was a 1969 VW Beetle sedan before, was modified to be a cabrio speedster, you can see more of it if you want on my FB page

     

     

    https://www.facebook.com/chicojacomo/

  • tobiamoo Level 1 Level 1

    Hello guys, i still need help with my hard drive.

     

    How do i go about deleting lines on the fstab files and re adding them?

     

    Also I tried to mount the drive with the "head -1 /etc/fstab" command you suggested but it didnt work.

  • diegoleo Level 1 Level 1

    Connect your HDD and from a terminal

    type the below to infer the UUID from your USB (replace name of your drive):

    diskutil info /Volumes/<LabelOfYourDrive>

     

    With above information of your drive you must create the below file:

     

    /etc/fstab

     

    (You can create the file with:    sudo vi /etc/fstab)

    And add the below line to the above file using the information that you got on the first command:

     

    UUID=<replace here your diskutil info above> none ntfs rw,auto,nobrowse

     

    Once file  /etc/fstab is saved you can plugin your usb hdd again, you will note that it is not on your desktop, but it is already available under:

     

    /Volumes/<LabelOfYourDrive>

     

    Therefore as an advise you can create a simbolic link to your desktop with the below command:

     

    sudo ln -s /Volumes/<LabelOfYourDrive> /Users/<your user name>/Desktop/<Label of your drive>

     

    That will allow you to open the drive from desktop and disconnect the drive properly.

  • tobiamoo Level 1 Level 1

    Hello

     

    When i try to create the file using the sudo command, i get this

    Untitled.png

    And when i proceed by typing E or D, i get this window which i am not allowed to edit

     

    Untitledd.png

    Am i doing it wrong?

  • diegoleo Level 1 Level 1

    If you are not good with vi, you can use the below as it was advised by thawn1 in order to create the /etc/fstab:


    From a terminal type (all on one line and the quotation marks must be exactly where they are):
    sudo echo "UUID=<replace here your diskutil info above> none ntfs rw,auto,nobrowse" >> /etc/fstab

  • tobiamoo Level 1 Level 1

    Just tried what you suggested and i got 'permission denied' as a reply

  • thawn1 Level 1 Level 1

    either you forgot to add "sudo" in  front of your command, or you don't have administrator privileges on your user account. In the latter case, you need to get someone with administrator privileges to enter the command for you or give you admin privileges on your account.

  • tobiamoo Level 1 Level 1

    I did remember to add 'sudo' in front of the command as you can see below

     

    Untitleddd.png

    Also i believe i have admin privileges for my user account as it is the only one active on my computer

  • thawn1 Level 1 Level 1

    Did the command prompt ask for your password after you entered the command? If not, I'd wager that you do not have admin privileges. Otherwise, you may have entered a wrong password.

     

    Can you please confirm that you have admin privileges? Check System preferences -> Users & Groups. It should say admin below your username and the box "allow this user to administer this computer" should be checked.

  • tobiamoo Level 1 Level 1

    No, the command didnt prompt me for a password when i entered the 'sudo echo' command. Although the 'sudo vi' prompted me for one when i tried it earlier.

     

    I can confirm that i have admin privelges as evidenced by this screen shot.

     

    Untitled.png

  • thawn1 Level 1 Level 1

    o.k. sudo asks for the password only after not using sudo for 15 min or so...

     

    however, I am completely at a loss, why you should get a permission error if you used sudo.

     

    maybe, vi still had a lock on the file or something. I suggest you confirm that the file is empty (sudo less /etc/fstab) and then delete it (sudo rm -f /etc/fstab) and try the sudo echo command again.