Previous 1 2 3 4 Next 55 Replies Latest reply: Feb 3, 2014 7:10 AM by andre244
Carl Pullein Level 1 (15 points)

I upgraded to Mountain Lion a few days ago and have not needed to use my iWork applications until this morning.

 

After opening my Pages document to write a new file I discovered that all my favourite fonts, which are non-Apple standard, do not work properly. Spacing is wrong the look is wrong, basically it just looks a mess.

 

Does anyone else have this issue with non-Apple standard fonts? I really need to have a fix for this as I use my keynote presentation software and I have discovered that my standard company fonts are not working in my 500 slide presentation. (Don't worry this is for a two day, 16 hour presentation) and I really do not fancy the idea of going through every single slide to change the font!!!!

 

I would really appreciate some help, if anyone can help me.


iMac, OS X Mountain Lion, 27 inch - 8GB memory - 1T HD
  • ~Bee Level 7 (31,425 points)

    Tom, Peggy, Peter, et al . . .

     

    I promised Carl that if he came over here, he would be well taken care of.

     

  • PeterBreis0807 Level 7 (34,587 points)

    What do you mean by "non-Apple standard"?

     

    We are terrible at guessing. Disregarding the occassional fluke.

     

    I convert all the fonts I use to .otf using Font XChange which has been well worth the money I paid for it.

     

    I do not believe in making a system work harder than it needs to, and kissing goodbye to the old font formats has been one of the joys of OSX and modern operating systems.

     

    Peter

  • Carl Pullein Level 1 (15 points)

    My apologies Peter.

     

    What I mean by "non-Apple standard" are fonts like MetaPro, MyriadPro etc. Essentailly fonts that do not come pre-installed by Apple's OS, yet are essentail fonts to the work I do.

     

    NB: The issue is only with iWorks as far as I can tell.

  • PeterBreis0807 Level 7 (34,587 points)

    The point is what format are they?

     

    Type 1 Postscript? Mac/PC?

     

    Peter

  • Carl Pullein Level 1 (15 points)

    All fonts that appear not to be working are otf

  • PeterBreis0807 Level 7 (34,587 points)

    I can't check that until I install ML but if that is so, that is a serious problem.

     

    You have upgraded to Pages '09 v4.2, the one for ML?

     

    Peter

  • Carl Pullein Level 1 (15 points)

    Yes, I am running Ml and Pages 4.2.

     

    Also, this does not just effect Pages. It also effects Keynote.

     

    A bigger problem font is Myriad Pro otf. This is completely illegible. At least with MetaPro you can actually read the words, althought the spacing between letters is irregular.

     

    The only fonts that seem to work are ones that come with the OS.

     

    Not good for designers who have to use different fonts for their work.

  • PeterBreis0807 Level 7 (34,587 points)

    Carl

     

    I also am a designer and long ago learnt not to jump in feet first especially to anything version zero.

     

    I'm standing back and waiting for the dust to settle on Mountain Lion. Lion suycked big time and I kept it only installed on an external HDD and will do the same for Mountain Lion before it can join the big boys on my internal HDD.

     

    It is not unusual for there to be numerous teething problems with new OSes and unfortunate that the early adopters are going to be unwitting beta testers. If it is any comfort yours appears to just another reported glitch and it has only been out 3 days.

     

    Peter

  • Carl Pullein Level 1 (15 points)

    Hi Peter,

     

    I have just tested my MB Pro laptop to see if the problem was computer specific rather than OS specific and I find that fortunately this seems to be only effecting my iMac. My MB Pro is working fine and all fonts are working fine.

     

    So I do not think it is a Mountain Lion problem. It seems to be my iMac's response to ML.

     

    I shall reinstall iWork and see if that fixes the issue.

  • PeterBreis0807 Level 7 (34,587 points)

    Just try it from a different account.

     

    It sounds like the iMac doesn't have the fonts open or the Font cache is corrupted.

     

    Peter

  • Carl Pullein Level 1 (15 points)

    Here's what I have tried throughout the day.

     

    Reinstalled ML 10.8, repaired disk permissions and rebooted - Still have problem

    deleted caches, extensions and preferences - Still have problem.

    Deleted and reinstalled iWorks - still have problem.

     

    As I mentioned above there is no problem with my MB Pro - all fonts work perfectly. My MB Pro is almost a mirror image of my iMac as I use Dropbox to store all documents. Essentially my computers just hold the software.

     

    There is only one account on my iMac so I am unable to try a different account. Perhaps tomorrow I could create a guest account and try that.

     

    I am running out of ideas now :-(

  • ~Bee Level 7 (31,425 points)

    Carl --

     

    I'm runnning 10.8, and fired up my Pages app and tried MyriaPro.  It works fine.

    Did you try a Safe Boot?  Did you use Onxy to clear out all of your Font caches?

    Are there more than those two that don't work?

  • Carl Pullein Level 1 (15 points)

    Hi Bee,

     

    Yes, I cleared font caches with Onyx and still had the same problem.

     

    I have also verified the fonts using Font Book and all fonts are fine.

     

    I checked both fonts in the new Notes app and they work fine. This seems to be problem only with iWorks and I have installed a fresh copy of iWorks and made sure the copy is the latest version.

     

    So tomorrow, it's nearly 1am here, I am going to use my Time Capule and restore the computer back to Lion and begin the process again.

  • PeterBreis0807 Level 7 (34,587 points)

    You can very quickly create a new account in:

     

    Menu > Apple > System Preferences > Accounts

     

    and then switch to it. Often it leaves the problem behind.

     

    Peter

Previous 1 2 3 4 Next