Previous 1 2 3 4 Next 55 Replies Latest reply: Feb 3, 2014 7:10 AM by andre244 Go to original post
  • Kurt Lang Level 8 (36,670 points)

    Font Book's database probably got damaged when upgrading to Mountain Lion.


    The following will completely reset Font Book and clear all cache files.


    Restart your Mac and immediately hold down the Shift key when you hear the startup chime to boot into Safe Mode. Keep holding the Shift key until you see a progress bar towards the bottom of the screen. You can let go of the Shift key at that point.


    OS X asks you to log in (you will get this screen on a Safe Mode boot even if your Mac is set to automatically log in). Let the Mac finish booting to the desktop and then restart normally. This will clear Font Book's database and the cache files of the user account you logged into in Safe Mode.


    Now to clear the system's font cache files.


    Close all running applications. From an administrator account, open the Terminal app and enter the following command. You can also copy/paste it from here into the Terminal window:


    sudo atsutil databases -remove


    Terminal will then ask for your admin password. As you type, it will not show anything, so be sure to enter it correctly.


    This removes all font cache files. Both for the system and the current user font cache files. After running the command, close Terminal and immediately restart your Mac.

  • ~Bee Level 7 (31,425 points)

    YAY, Kurt!!!!!


  • Carl Pullein Level 1 (15 points)

    WOW! Thanks for that Kurt.


    I am currently restoring my Mac from my Time Capsule to how it was before I upgraded to Mountain Lion. Once that restoration has completed I will re-install Mountain Lion (after checking that Pages works fine) and see if that works.


    Failing that, I shall be following your instructions.


    Once again, thank you for the instructions.

  • Carl Pullein Level 1 (15 points)

    Hi Kurt,


    I restored my iMac to OS Lion and checked that Pages worked fine and it did. There were no problems at all.


    I then reinstalled Mountain Lion and then did a repair disk permissions - restarted my computer and checked pages.


    Unfortunately the problem returned.


    I then followed your instructions to clear the Font Book cache, restarted my computer and tested Pages. Unfortunately the problem was still there.


    This only happens in Pages, Keynote and I guess Numbers (I have not tested Numbers)


    All other applications work fine whether it is the new Notes app or Photoshop.


    I shall test Peter's suggestion about creating a new user account to see if that helps.

  • Carl Pullein Level 1 (15 points)



    you are a genius.


    I tried setting up a new account and tested Pages. Both MetaPro and Myriad Pro worked fine in the new account.


    It seems the problem is with my administrator account :-(


    Does this mean I should create a new administrator account and then delete the old one?

  • Kurt Lang Level 8 (36,670 points)

    Unfortunately the problem was still there.

    95 times out of a 100, a damaged Font Book database is why you can't activate or deactivate fonts with FB. This wasn't one of those times.

    Does this mean I should create a new administrator account and then delete the old one?

    You can certainly do that. You'll have to reset things the way you like them (desktop pattern, Dock, etc.), but at least you'll know you have a working account. Depending on where certain apps save their registration info to, you also may need to enter that info again running such apps the first time from the new account. They'll behave as if you never entered a serial number for them.


    The problem could simply be damaged preference files, all the way to a damaged user account (rare). I'd probably go with creating a new admin account to be sure and can the old one.

  • odellcs04 Level 1 (10 points)

    I tried on a different account and my font issues were solved, so I used Onyx to clear/delete all caches related to fonts and I'm good to go, so thanks for all the awesome work on this forum!

  • ~Bee Level 7 (31,425 points)

    Yay, Carl!

    You had the very best helping you.

    So glad you're sorted now!


  • Giraffe07 Level 1 (0 points)

    Hi Kurt,


    I am having similar issues with a Gotham light font only in iwork apps (pages 09 and numbers 08).  Interestingly the fonts are appearing correctly in TextEdit.  This has happened since going from Snow Leopard up to Mountain Lion and its seems like the font is getting squashed.


    I have run though your 'resitting the font book and clearing cache files' to no avail and have also tried creating a new user which also doesnt solve the problem.


    I was wondering if you had any other suggestions which might be worth a try?


    Thanks in advance

  • Kurt Lang Level 8 (36,670 points)

    When those steps don't work, they only thing I've found which normally will is to reinstall the OS.


    Though before you go through all of that, is it just the one font that won't work, or are there others?

  • Giraffe07 Level 1 (0 points)

    Having a quick flick though various fonts it does only seem to be effecting only 3 of the 20 fonts in this particular font family  (Gotham HTF).  The other standard fonts are all okay.


    Its not just my machine, everyone in my office who has upgraded to moutain lion is having this issue and even one person with a brand new laptop that has a fresh install of the mountain lion.  This makes me doubt that reinstalling the OS will work.


    The obvious solution is to just stop using this font however its on a lot of our standard documents and will involve re-formatting all sorts of material so if there was a way to get it working it would be great.  Its a shame where a font was working on leopard, snow leopard and lion and then upgrade to mountain lion and find its not working anymore.  I suppose an alternative solution is to roll back to lion.

  • Carl Pullein Level 1 (15 points)

    All you need to do is create a new user account. Once you have transferred your user account info over ro the new account you should find all fonts work. It worked for me.

  • Giraffe07 Level 1 (0 points)

    Hi Carl,


    Thanks for this.  I have already tried this and it doesnt make any difference. Looking into it a bit more I think its something to do with the font kerning (but im no font expert)

  • Kurt Lang Level 8 (36,670 points)

    Kerning has to do with the spacing between characters. It has no effect on whether or not a font will load.

  • Carl Pullein Level 1 (15 points)

    Hi Kurt,


    The transfer and deletion of my original Admin Account went smoothly. Everything is working perfectly in my new administration account.


    Thanks so much for you advice and help :-)