Skip navigation

Font Issues with iWorks and OS Mountain Lion

12127 Views 55 Replies Latest reply: Feb 3, 2014 7:10 AM by andre244 RSS
  • Giraffe07 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 24, 2012 8:59 AM (in response to Kurt Lang)

    Its the spacing of the fonts that I am having an issue with.  Its loads, it just looks 'squashed' since mountain lion.  Perhaps this is not the same problem everyone else has been having on this thread

  • Kurt Lang Level 7 Level 7 (31,470 points)
    Currently Being Moderated
    Aug 24, 2012 10:28 AM (in response to Giraffe07)

    I'm afraid I could only make a guess what's happening with Gotham HTF. It's a commercial font I don't have.

  • ElZitouni Calculating status...
    Currently Being Moderated
    Sep 3, 2012 9:43 AM (in response to Giraffe07)

    Dear Giraffe07,

    I have been experiencing exactly the same problem as you, but with some Fonts of the Futura Family.  And, like you, I have not stumbled upon a solution.

     

    I bought Futura a while ago.  It has been working perfectly with Lion, but, under Mountain Lion, not all types continued to do so: Futura Bold and Futura Light can no longer be used in iWork applications.  Here, in all iWork applications, the characters are "squashed", ie., the kerning is off.  This does not happen in Font Book or any other application.  Manually adjusting kerning in iWork, however, does not work, as this will just put them farther apart but not correct the problem, as the wrong offset is now just kind of spread out.  So it is a problem of how iWork sets these characters in these families.  Here is how the affected fonts look like in Keynote.  Interestingly, the corresponding Italic fonts are not affected.  Go figure.

     

    Screen Shot 2012-09-03 at 12.31.47 PM.png

     

    Like you, I have tried EVERYTHING mentioned here, setting up new accounts, cleaning cashes, removing fonts, reinstalling fonts, you name it.  Nothing worked.

     

    This has been extremely frustrating as I have worked months on developing and perfecting a Keynote layout using these fonts, and simply replacing the fonts will not work for me.  There is a reason I used Futura, and Futura Bold cannot be replaced by, for example, Futura Heavy.  As I have only switched my MacBook Air to Mountain Lion, but not the MacBook Pro, I am not completely screwed up.

     

    To conclude, it seems that this is a bug in iWork under Mountain Lion.  I will go the Apple Store this week and ask one of their Masters of the Universe to see what is written in the Kabbalah about this.  I cannot understand how this kind of major screw up can happen to a company that has been synonymous with desktop publishing, and here to their very own flagship applications in that sector -- how can it be they don't work any more within their own ecosystem?  I just don't get it.

     

    The alternative for me would be to use for InDesign for presentations.  But I am not yet prepared to invest in this.

  • ElZitouni Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 3, 2012 11:20 AM (in response to Giraffe07)

    Hello Giraffe07,

     

    I found a possible solution to the problem. Maybe there is some issue with PostScript fonts -- the Futura Font family I use is PostScript.  I just downloaded and installed a free TrueType version of Futura Bold, and iWork typeset it correctly.  You can check the font format with FontBook.  In FontBook select the font, and then click the Info button in the toolbar.

     

    Thus, check whether your font is a PostScript font.  If it is, replace it with a TrueType version.

  • AsaHersh5 Calculating status...
    Currently Being Moderated
    Sep 4, 2012 2:46 AM (in response to Carl Pullein)

    YES.. All Postscript fonts are screwed up on KEYNOTE! Incredible.

    Also, creating PDF in various programs under Mountain Lion creates jibberish. So the problem is with Mountain Lion, but there is likely a bug fix that COULD be done in Keynote. Dont hold your breath.

    A rant here is useless, but this is absolutely TYPICAL of apple.. buggy software and no fixes, ever. I have been a Mac user for over 20 years. Used to love them. Still use Mac, but hate the arrogance and slovenliness of the company. It is about money folks, NOT customer care.

  • ElZitouni Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 7, 2012 5:48 PM (in response to AsaHersh5)

    Supposedly, Mountain Lion can handle PostScript Type 1 fonts. 

    Apparently, it can handle only some of them, as the Futura family I use is PostScript Type 1.

     

    These are the options I see for people facing a similar conundrum:

    1. Switch to professional software, like Adobe InDesign.  A lot of work to port existing slides into InDesign, but once you are done, you don't have to worry, as Adobe, for example, will unlikely abandon widely used software, as Apple frequently and without warning and without offering a functioning alternative does (e.g. iWeb, mobileMe, etc);
    2. Replace the font with another one (might not work for cases where the font is part of some brand or corporate identity); 
    3. Buy an OpenType or TrueType version of the Font (e.g., at Linotype).  However, if in a new OS version that font stops working unexpecedly, one is back to square one.  Hence, one might be better off with option (1) or (2).

     

    Naturally, this font issue annoys me to no end. There is this unprofessional attitude at Apple sometimes when it comes to their software, it betrays the image the company likes to project of itself.  I know it is infantile to wish for this, but it would really be great if someone at Apple would at least indicate that they recognize the problem and will fix it, or that they don't care, so one could go look for an alternative.  What a wonderful world would that be!  Well, I just have to learn to think different(ly) ... or be smart and not adopt these first incarnations of software, like OS X 10.8.1.

  • ElZitouni Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2012 2:06 PM (in response to ElZitouni)

    The Mountain Lion 10.8.2. Update does not resolve this issue.

  • BG21 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 26, 2012 4:23 PM (in response to ElZitouni)

    After trying lots of the solutions listed above, and elsewhere, I finally came up with a solution that worked for me.

     

    It turns out my trouble with some of my older fonts was due to the fact that when I upgraded to ML (from Lion) I had migrated my files into ML from a different user's account. When the font files migrated the 'sharing and permissions' settings, (you know - under 'get info') for each font was restricted to "read only" or 'no access' for my new (ML) user.

     

    So for each font (sigh) I had to open 'Get Info', unlock the 'Sharing and Permissions', then change the setting to 'Read and Write' for my new user account.

     

    After that all the fonts that would appear to load, but not show up in Font Book were where they belonged.

     

    I hope this helps someone else!

  • Kurt Lang Level 7 Level 7 (31,470 points)
    Currently Being Moderated
    Sep 27, 2012 6:10 AM (in response to BG21)

    That is a great catch! Something migrating definitely shouldn't be doing. Until yourself, I don't think anyone else even thought of looking at permissions as a possible cause.

  • ElZitouni Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 27, 2012 7:19 AM (in response to BG21)

    Good to be able to exclude additional sources of font problems.

     

    However, in the case of the PostScript 1 fonts that get mis-typeset only in Keynote, Pages, and Numbers (as far as I can tell), but seem to be fine in other applications (including FontBook), the bug is someplace else.  I assume it is a bug in the applications that only an application-specific update can fix.

  • Ernest Blake Calculating status...
    Currently Being Moderated
    Oct 5, 2012 12:06 PM (in response to ElZitouni)

    Hi,

    Thanks for the suggestion. I'm having a problem with Century Gothic, which is a True Type font but every document can only be opened asa copy on iPad etc.. and the documents are reformatted.

    Any more suggestions?

     

    Thanks

  • Oaksusu Calculating status...
    Currently Being Moderated
    Jan 16, 2013 8:44 AM (in response to Carl Pullein)

    EIZitouni is right. Pages has issues rendering some PostScript Type 1 on Mountain Lion. I upgraded to 10.8 from 10.7, which was an upgrade from the venerable 10.6.

     

    None of the workarounds mentioned in this thread worked for me, possibly because odd behavior like this can happen when upgrading OS's twice. But still, this is a big issue for some Mac users, not being able to render PS fonts??? That's basic.

  • Matt Eide Calculating status...
    Currently Being Moderated
    Jan 23, 2013 11:21 AM (in response to ElZitouni)

    I am having the same kerning problem with a font I use all the time. (My problem looks just like the Futura example above (although some versions of the font are stretched, rather than squeezed; also, adjusting character spacing in the inspector has no effect.) As far as I can tell, mine is a True Type font. It's name, anyway, is Humana Serif ITC TT and I take the TT for True Type. Getting Info on the file says its kind is "Font Suitcase"

     

    Anyway, in case it helps anyone (especially Apple to fix it!) I have found a work around that is annoying, but works for me. I experience the problem in Pages (haven't tested other iWork apps)

     

    1. Close Pages

    2. Remove the font from its folder (I move it to the Desktop); leave the Finder window open.

    3. Open Pages (if you left your document open when you quit, now you'll see font substitution.)

    4. Close Pages

    5. Put the font back (drag it from the Desktop to the Finder window you left open)

    6. Open Pages. (The font works correctly now and will until the computer boots again)

     

    Anyway, that's my experience. Hope it helps somebody else out there (and that Apple fixes this!)

     

    Regards,

    Matt

  • andre244 Calculating status...
    Currently Being Moderated
    Feb 1, 2014 8:09 AM (in response to ElZitouni)

    Hi ElZitouni, I'm having a similar problem with Myriad Pro Fonts, five of the fonts in that family will output gibberish in Pages'09 (4.3). I'm on a MacBook Pro 2010 running Mountain Lion 10.8.5.  I have no such problems with TextEdit or Scrivener. I have exported a pagefull of gibberish from Pages to an rtf document and opened it with TextEdit and the text showed up "perfect" and in the exact font which created gibberish in Pages.

     

    I have tried all the remedies suggested here with no positive results, in some cases some of the fonts which were not good became good for no reason that I could make out and others that were good became no good.

     

    I have already spent hours on this problem and decided to cut it short and move on to Helvetica Neue which is somewhat similar to Myriad Pro.

     

    I'm still hoping that Apple will find a cure but I'm not holding my breath knowing that there isn't much money to be made in fixing anything in Mountain Lion.  Not sure if Maverick has that problem with Pages 5 (?)

     

    Regards,

    Andre

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.