Previous 1 5 6 7 8 9 Next 126 Replies Latest reply: Jun 21, 2013 1:47 AM by Mad-Hias Go to original post
  • Karl Johnson Level 1 (15 points)

    The error message you got when trying to reinstall the Power Nap update software is normal. It's a firmware update, so once it's run it stays there even if you reinstall the OS. However, it would be much better if the error message just said it was already installed.


    After watching 10.8.1 on my rMBP for a couple of days, I've found Power Nap is now not working at all. Before 10.8.1 Time Machine was backing up to my Time Capsule and Mail was processing about half the time. Now neither work.


    Other than being non-functional, Power Nap is actually better behaved now. Before Mail would seem to get confused and leave flagged spam messages in the InBox. A few times, on waking, Mail would get a spinning beach ball and hang. When that happened and I had Calander and Contacts open, they'd hang too. It seemed very Power Nap related.


    Worse Power Nap seemed to slow down the rMBP's wake-up speed....and even seemed to be the cause of some failed wakeups (the machine was unresponsive and wouldn't wake up).


    Now that the bad side effects seem to be under control, if Apple could actually make it work it would be handy indeed.

  • brianwilson71 Level 1 (0 points)

    Hi Karl,


    I have updated to 10.8.1.


    Last night I put the rMBP to sleep using keyboard shortcut (Fn-Option-Cmd-Power) at approx 1:00am. I left the Time Machine Preferences opened just before sleeping.


    As soon as I woke the rMBP this morning, it said last backup was at approx 2:30am.


    So, this would seem to be working for me. I don't think it would make further backups if there were no further changes to be backed up (while I was sleeping)


    I was hoping for a few spam messages last night to test the Mail part but none came - unusual ;-) so I couldn't really test the Mail just yet.





  • Mad-Hias Level 1 (5 points)

    On my rMBP the wakeup speed seems to be faster since 10.8.1... The whole thing is really strange to me...

  • Karl Johnson Level 1 (15 points)

    Hi Brian. Thanks for the info.


    It's good to hear it's working for someone. I hope it's working for most people. At the very least is should be working for people who have new machines or people who have done clean installs.


    For me, it certainly could be because of some old stuff that got imported with Migration Assistant usage over the years. Although I don't expect Apple to be able to safeguard their software functions against 3rd party programs, I'd appreciate it if some of the functions could be a bit more robust or at least be somewhat informative about why they might be non functioning.


    On some of my older accounts I get lots of spam nowadays. If you need any for testing, just let me know (grin).

  • Mad-Hias Level 1 (5 points)

    brianwilson71 wrote:


    Last night I put the rMBP to sleep using keyboard shortcut (Fn-Option-Cmd-Power) at approx 1:00am.

    I tried that as well, but as soon as I wake the rMBP I get the "volume not ejected properly" error...

  • brianwilson71 Level 1 (0 points)

    Hi Karl,


    Yes I know what you are saying... I have a bit of 'baggage' too though as I used Setup Assistance from Lion to ML and I didn't do a clean install between SL and Lion either. Anyhow, will keep you updated if the mail works... I have more than enough spam too thanks very much :-) but I am trying to filter as much of it as I can at the server level. Anything that falls though then hopefully gets picked up locally... and thats why I would like the powernap to work - stop it getting to my iPhone.


    Mad-Hias... never got the error before so not sure why that is happening... strange... hope you find out whats causing it.



  • gmansc1 Level 1 (0 points)

    I'm also experiencing problems with power nap.  My main interest is in having mail updates.  It would be great to flip open my mac and be able to start working, withough having to wait for mail to sync up.


    I have a new MB air that came with ML preinstalled.  I did both the firmware and 10.8.1 updates.  Power nap is intermittant, at best.  Sometimes, I'll open my MBA and find mail has been updated, other times nothing.  An interesting observation -- I have several gmail accounts and will find that one has been updated, while another has not.  I'm guessing that power nap is trying to function, but to save power, quickly times out after initiating a mail sync. 


    I imagine that apple will get this sorted out in future ML releases.  Sure hope so.  Would be a very nice feature if one could count on it.

  • Montrose Level 1 (5 points)

    When my computer is sleeping and power nap is on, mail will sometimes  be found when I wake the computer. Obviously there are no mail arrival sounds heard while sleeping. However,  when I start using the mail app after awake all the mail sounds (get mail, send mail, recieveve mail) are gone or silent. I have to close mail and open again or restart computer to restore sounds.   Lastly I can restore the sound by quitting the coreaudiod file in the activity monitor. Has anyone had similar problems with power nap and mail sounds?

  • eliseman Level 1 (0 points)

    My main problem with Powernap is that my rMBP tries to close Mail whilst in Powernap. When I wake it, I get a dialogue box saying that Mail prevented the rMBP from shutting down because I hadn't logged out of Mail. But I didn't want Mail to be shut down, I just wanted it to collect and filter Spam. Time Machine backups work OK though.

  • Mad-Hias Level 1 (5 points)

    What kind of external drive do you make Time Machine backups with?

  • Smokolator Level 1 (0 points)

    Mad-Hias, have you tried connecting a USB thumb drive to see if it survives Power Nap? I'd be curious to know if it gets ejected, remains mounted, or if it successfully ejects and remounts.


    FYI I've submitted this issue to Apple as a bug using their feedback forms.



  • Mad-Hias Level 1 (5 points)

    USB thumbs remain mounted after waking the MacBook. Now I'm really confused...

    Thanks for submitting the issue to Apple!

  • Smokolator Level 1 (0 points)

    Yeah, so here's what seems to be happening:


    External drives powered by the MBPs USB port work fine with Sleep/Power Nap.


    USB thumbs work fine connected either directly or via a USB hub.


    External drives not powered by the MBP are "not properly ejected" when the MBP goes to sleep/power naps.


    Is this consistent with what others are experiencing?

  • eliseman Level 1 (0 points)

    My external Time Machine drive is powered by a hub and this works OK if the rMBP is on mains while it is Powernapping.


    This doesn't explain my mail log out issues though.

  • Smokolator Level 1 (0 points)

    eliseman, does your time machine drive have any other volumes on it?  Mine has 2 others and I'm wondering if maybe power nap keeps the time machine volume mounted, but tries to eject the other volumes??  I'll try a time machine backup to a single volume drive connected via a hub to see if it prevents the "not properly ejected" problem.


    I haven't been keeping tabs on Mail during power naps but I'll check it out tonight.

Previous 1 5 6 7 8 9 Next