Previous 1 2 3 4 Next 45 Replies Latest reply: Aug 10, 2015 9:07 AM by stacyd123
SULiik Level 1 (5 points)

My iMac (mid 2011) with Mountain Lion is just transfering video and no sound to ATV (the newest one)... I set the AirPlay Mirroring with no problems, everything has the latest update and still I can see only video while audio is playing via my internal speakers. When I tried to set the audio output to "Apple TV - Airplay" I couldn't do it. When I clicked on any other option it just hops back to internal speakers. For now I just tried it in Preview and no ther app but still, it should work from any app, right? Thanks for any help!


iMac, Mac OS X (10.7.3)
  • SULiik Level 1 (5 points)

    Ok, reboot helped the sound. But earlier I could turn the screen off while playing video. Now I can't because when I do the video freezes and stops playing until I move the mouse or press any key...

  • BeenJaminRocks Level 1 (0 points)

    I found that if my AirPort Extreme is connected at 5GHz it does not work.  When I switch to 2.5 it started working but somewhat intermittently. The AppleTV also needs to be at 2.5 GHz.

  • effgen Level 1 (0 points)

    Please correct me if Im wrong, is Airport extreme same as Apple TV, but in America? Im trying to find where to change this GHz thing, but fail to do so.. when I open AirPort utility, there's nothing i can change there.. I dont have any Airport base station... where do i change that? Im on MacBook Pro 2012, ATV 3rd gen. Thank u guys!

  • BeenJaminRocks Level 1 (0 points)

    Airport Extreme is Apple's router.  It can be set up for 2.4 GHz or 5 GHz or both.  If it is set up for both and the Mac grabs a different band then the AppleTV it appears then the sound does not work for Airplay. If you have a 3rd party router you will need to find out how it is setup.

  • Osakasky Level 1 (0 points)

    Been having the same issue and believe it occurs when you force on Atv with mirror connection.  I believe is you turn on Atv w/ mouse first this will not happen however I have a few components to work through to test this and not quite enough time.  While BeenJasmin has a valid thought I can say it might be off the mark as my AirPort and Atv are wired via CAT6 and I still have the same issue as you. 

     

    ATV 3gen

    AirportExtreme

    MacBook Pro 2.2 Ghz i7

    OSX 10.8

  • FreekM Level 1 (25 points)

    Changing the wifi network solved the problem for me (after rebooting didn't).

     

    My Time Capsule offers 2.4mhz and 5mhz networking and my Apple TV was probably on a different connection than my MacBook Air.

     

    The Airplay audio output is now available and the video output is switching without complaints.

  • VikkyPal Level 1 (0 points)

    You have to follow the following two steps when doing AirPlay from iMac:

     

    Step 1: Open System Preferences and click on sound. Then Click on the output tab and select Apple TV instead of Built-in

     

    Step 2: Click on AirPlay on the Menu bar and Click on Apple TV as you have already done.

     

    It will work just fine. The trick is that you have to set the Sound option BEFORE you send the video to ATV. I don't know why this is but it is not automatic unlike MacBook Air. When you turn off AirPlay you have to change the sound option to Built-in to go back to listening to sound on your iMac.

  • Anders Level 1 (0 points)

    I have the same issue, Imac mid 2011.

     

    When i start my atv before my iMac i only get video, no audio.

     

    It's really anoying, I always have to restart my apple tv.

     

    If I go to audio I cannot choose atv, it keeps jumping back to my iMac.

     

    Any idea?

  • Anders Level 1 (0 points)

    Edit, the best way for me is to put the atv to sleep and then restart it, works everytime but something is wrong...

  • tdavis1198 Level 1 (5 points)

    Had the same problem. Had to move both the ATV2 and my Macbook Pro both to 2.4GHz wifi. Did NOT work on 5GHz

  • FreekM Level 1 (25 points)

    Reminder: some apps (including VLC player) have their own sound output settings. In VLC player, go to the sound menu and choose Apple TV.

  • scottcurry Level 1 (0 points)

    I tried all of the suggestions from this and other posts...setting audio output to appletv before turning on airplay, restarting the laptop, turning wifi off and on, putting appletv to sleep, etc. Nothing worked. It worked for me many times before. Then I realized I was using Chrome. I just switched to Safari, opened up the same game on ESPN, and it works.

  • Screw It Level 1 (0 points)

    Yes having the exact same problem for some time now... I'm still running 5.0.2 os. Does the update fix this issue?

  • Gistropod Level 1 (0 points)

    I have the exact same issue with my 2012 Mac mini and 2012 time capsule (2012 Apple TV).  I have everything set to 2.4ghz and AirPlay works perfectly. 

     

    When I try to use 5ghz I have intermittent issues with AirPlay from Mac mini showing only video but no sound and the only way to fix is to restart Mac mini or router.  No issue with iPhone mirroring on either 2.4ghz or 5ghz.

Previous 1 2 3 4 Next