Previous 1 2 3 4 Next 45 Replies Latest reply: Aug 10, 2015 9:07 AM by stacyd123 Go to original post
  • WeepingAngel Level 1 (0 points)

    I will add weight to the argument about 5.0 vs 2.4 Ghz networks.


    From best I can tell, an easy way to test if it will work (without actaully mirroring) is to open up the audio output settings. If things are hosed, then you will not be able to select the AppleTV audio device. It will be in the list, but selecting it will just jump to another option in the list.


    My Air and AppleTV were both on the 5.0 network. Audio has been an issue (but has, at times, worked).


    START = both devices (Air and AppleTV) on 5.0

    Changed the AppleTV to the 2.4 (left the Air on 5.0) - NOT WORKING

    Changed the Air to 2.4 (to match the AppleTV) - WORKS


    Those are the ONLY changes I made. No restarts, just setting changes and network connections.


    Seems clear to me that my problem is with the types of network connection.


    After the quick testing showed that I could connect to the audio device, I actually mirrored and the sound worked first time. I may not do anymore testing since things like this seem so "simple" to have work yet i spend time troubleshooting and googling that it leaves me so aggravated that I move on to something unrelated. Hopefully, this aggravation will not lead me to leaving Apple products ....

  • Attilas Level 1 (45 points)

    To add to the discussion. Im experiencing video with no sound problem won my macbook air to apple tv. No problem with airplay from any IOS devices.


    My apple tv is connected with wires.

    My macbook air is connected with wires.


    I do have the problem. Rebooting Apple tv doesn't fix. Rebooting Macbook Air do fix the problem until it happen again.


    Look like the problem is OSX related. If it was network related both video and audio should have problem. That a video network stream work but the audio one doesn't does not seems to be network related in my mind.

  • netsoup Level 1 (0 points)

    It seems very clearly a bug with airplay and not an application specific thing.

    The same applications sometimes work and sometimes don't, and invariably I've had to reboot the computer to get airplay to pass audio.

    There are no options that work when the bug hits.  If I choose airplay as the output in audio settings, before or after activating airplay, it doesn't work.  audio settings don't accept airplay, and if airplay is on, trying to choose airplay as the audio output kicks airplay off.

    rebooting computer, as someone suggested a while ago, works every time so far, thankfully.  Even if it doesn't work one day, i'm pretty sure by now based on behavior so far it's just a bug with airplay.

  • netsoup Level 1 (0 points)

    same experience.  ios devices play airplay audio and video just fine consistently.

    Every so often, some times really often, the macbook air stops passing audio via airplay until rebooted, is my experience since upgrading to mountain lion and purchasing an apple tv, both around the same time.

  • Serkane Level 1 (0 points)

    What works for me everytime is to put my iMac to sleep and wake it up and everything works.


    When I have this problem I can't even select the audio output to Apple TV. When I "Option Click" the speaker icon and select AppleTV for output it doesn't accept my selection even though I can mirror my desktop to ATV.


    My setup is, both my iMac and ATV is connected to a last generation Airport Express iMac via Cat5 ATV via wireless.


    I don't think my issue is with Wireless network and it might be a bug with OSX

  • halfgeek Level 1 (0 points)

    I ran into this same issue with no audio on my mid 2012 Mac Mini last night. I did start mirroring to atv before setting the sound output and was never able to get it to work. I instead used my rMBP which worked just fine, following the same procedure. So, I am not sure what the issue is because I was using the same protocol to start mirroring, the same router, same atv and same versions of OS X (10.8.2), but with different results.

  • Screw It Level 1 (0 points)

    Yes this issue is still happening! Why has it not been fixed yet?

    The only solution i have found is to reboot the apple tv by pressing the play/pause button and the menu button simultaneously on the remote for about 5 or 7 seconds... The apple TV will reboot and then the mirroring works fine with audio. It's not a huge deal i guess but annoying none the less.

  • Anders Level 1 (0 points)

    I can also agree with the 2,4 and 5Ghz issues.


    I have now added a specific network for the 5Ghz.

    And I have connected my iMac and Appple TV to my 5Ghz network.


    Not problems, works fine...


    I guess you units need to be on the same, 2,4 or 5 Ghz, Might create issues if you have an router that uses both automatically.

  • oakley140 Level 1 (0 points)

    I had the same issue mirroring my Macbook's destktop to AppleTV via AirPlay. 



    AppleTV would stream video, but not audio from my Macbook Pro 2012 with retina display while my laptop was connected to Airport Extreme on the 5 GHz wifi network.  (incidently, AirParrot never had an issue regardless of wifi signal frequency) 


    Whenever I switched over to the Airport Extreme's 2.4 GHz network, BOTH audio and video work without any issues, whatsoever. 


    Also, I should mention that my AppleTV is connected to Airport Extreme through an ethernet cable, so my AppleTV doesn't actually use my wireless network.


    The interesting thing, however, is that my iPhone 5 and iPad 2 (which can both use the 5 GHz wireless) don't seem to have this issue. 

  • zhongqili Level 1 (0 points)

    I have the same issue. The sound transferring does not always work. Sometimes restarting VLC helps, but not always work.


    I am using Mac air 2013, with atv 3.

  • netsoup Level 1 (0 points)

    I got the answer to my similar problem from this thread -


    Opening terminal, and running sudo killall coreaudiod fixed it for me, as a couple suggested.


    Also suggested, if you want to use the gui instead of terminal, killing "coreaudiod" from activity monitor.


    Aparantly some bug or corruption in that process is fixed by restarting it, which ending it does since it relaunches automatically.  Not sure if everyone has the same problem.  I used to have to restart the computer each time, but ending the above process is way more convenient for me.

  • david125 Level 1 (0 points)

    Yeah, I though it was this too but I have been turning on ATV with remote 1st before starting airplay recently and it still happens.  I have 3 ATVs on my network as well as an airport express.  It seems to default to the 1st ATV that shows up alphabetically in the list.  Even though the video will stream to the correct ATV, the audio doesn't.  The audio continues to play through my macbook pro, the video will play correctly through the selected ATV, although the ATV that is shown as active on airplay mirroring is incorrect. Weird.  Can't change it by selecting alternative ATV and only thing that seems to rectify it is a reboot.

  • david125 Level 1 (0 points)

    This "coreaudio reboot" sounds promising and logical!  Can't see how different network frequencies would make any difference.  The only thing I have found that works to date is a reboot of my macbook pro which is a bit of a hassle.  I'll give this method a try next time.  Thanks

  • eskie2010 Level 1 (0 points)

    Yup, switching both Macbook Pro w/ Mountain Lion OSX 10.8.3 and Apple TV to the 2.4 GHz worked to get sound and video on TV.

  • Meer Wim Level 1 (0 points)

    Usually typing sudo killall coreaudiod in terminal (or quit coreaudiod in activity monitor) does the trick for me. But I also noted that some video's are particularly tricky. I have one (avi with video MPEG-xvideo and audio A52/AC3 codec) that doesn't play at all in the quicktime 10.2 player, in quicktime 7 it plays without sound (and complains about missing components) but it plays well in VLC. HOWEVER, when airplaying this movie to appletv the sound doesn't come through initially. This can be solved by going to audio>audio device>airplay. Normally this is automatic, but apparently some movies require some manual prodding... I love VLC for its capacity to play virtually anything, but some tricks remain quirky.