Previous 1 2 3 Next 44 Replies Latest reply: Jan 20, 2015 1:58 AM by boobiestar Go to original post
  • orchetect Level 1 Level 1 (10 points)

    @Meer Wim

     

    The 'sudo killall coreaudiod' command does work, thanks for that little tip.  This points directly toward issues with the AirPlay audio device and other under-the-hood elements on OS X.  It has nothing to do with the network of course.  I hope they fix this in OS X 10.9 Mavericks.

  • Dominar Level 1 Level 1 (15 points)

    Same thing here. No audio when air playing video. Early 2011 MBP, ATV2 and last gen time capsule. Killing coreaudio worked.

     

    Is there a script that we could use to automate the process?

  • nikoli1978 Level 1 Level 1 (0 points)

    Thanks netsoup, killing coreaudiod worked for me.

  • nikoli1978 Level 1 Level 1 (0 points)

    Apparently not... I'm running Mavericks and had the problemo

  • zman999 Level 1 Level 1 (0 points)

    I'm running Mavericks and am still experiencing this problem. Only fix is to kill coreaudiod or reboot. What a pain.

  • FarewellFire Level 1 Level 1 (0 points)

    I found out that the built in firewall interferes with AirPlay (which I know is weird).

     

    Try turning the OS X firewall off using System Settings -> Security. If AirPlay now works, turn on the firewall and add "coreaudio" to the list of exceptions. This worked for me.

     

    By the way, Coreaudio is the OS X system driver for audio.

  • netsoup Level 1 Level 1 (0 points)

    Wow.  Thank you for the additional info.

    I did not even think the OSX firewall would interfere with Airplay audio.  That's never happened to me, but good to know to add that to the list of possible issue cause/effects!

    Every airplay audio issue I've had, it's come down to closing what I'm doing, killing(restarting) coreaudiod, then going about my way.  At first I needed to restart the computer, which was super annoying and unworthy of such a fantastic product, then I realized thanks to others posting solutions I could just exit airplay and restart coreaudiod.  Since then I found out sometimes I need to actually close safari or whatever is having issues, restart coreaudiod, then resume my merry way.

    I am not an OSX developer (yet), but if anyone here is, this is a perfect bug to report.  It's been happening to me off and on since Snow Leopard.

  • AgentTy Level 1 Level 1 (0 points)

    I am also having this problem.

    I have brand new Late 2013 MBP 15" Retina and lastest model Apple TV.

    Reboot fixes the issue.

     

    The only thing "unique" about my network is that I have 2 Apple TV's on the network, perhaps this is significant in triggering the bug.

     

    This is a bug... Apple please fix!

  • a18ion Level 1 Level 1 (0 points)

    I notice that the no-sound-over-airplay-when mirroring-to-appletv problem only occurs on my imac after I've used headphones.  Whether the imac has been to sleep or not doesn't affect the working of sound to the AppleTV.  It will work all the time, except if I've used headphones, after which, the sound won't play when mirroring to the ATV.  [Rebooting makes the sound work again.]  Anyone else notice whether use of headphones "causes" the problem?

  • Dashony Level 1 Level 1 (0 points)

    sudo killall coreaudiod          does work

  • mw.overflow Level 1 Level 1 (0 points)

    We have a 13" rMBP running Mountain Lion.  Streams perfectly.  We have a 15" rMPB running Mavericks, streaming w/o audio.

     

    * Firewall is off

    * Rebooting/sleeping/etc doesn't help

    * sudo kill coreaudiod doesn't help

    * switching to 2.4MHz doesn't help

    * using AirParrot instead AirPlay works perfectly!

     

    What??  Anyway, my suggestion for people who have tried everything else is to buy AirParrot.

  • Prateekhak Level 1 Level 1 (0 points)

    sudo killall coreaudiod ---- woked for me as well on Macbook air

  • Eagle Owl Level 1 Level 1 (35 points)

    I have had the same problem for well over a year with both Mountain Lion and Mavericks. When I try to select Apple TV for audio output, the selection jumps back to Internal Speakers. I use "killall coreaudiod" to get it going again. I have to do this almost every day.

     

    I noticed some differences in the System Log, which might give someone a clue. When it works properly, selecting the Apple TV results in 7 lines in the System Log:

     

    25/05/14 11:51:52,512 SystemUIServer[257]: 2014-05-25 11:51:52.511516 AM [AirPlayAVSys] Picking route 'Apple TV' (XXXX)

    25/05/14 11:51:52,513 SystemUIServer[257]: 2014-05-25 11:51:52.512780 AM [AirPlayAVSys] Selecting endpoint XXXX, item 302 for (audio only)

    25/05/14 11:51:52,513 coreaudiod[263]: 2014-05-25 11:51:52.513399 AM [AirPlay] Selecting endpoint XXXX "Apple TV" for A/V

    25/05/14 11:51:52,528 AirPlayUIAgent[5171]: 2014-05-25 11:51:52.528189 AM [AirPlayAVSys] AirPlay became the default audio device

    25/05/14 11:51:52,529 SystemUIServer[257]: 2014-05-25 11:51:52.528712 AM [AirPlayAVSys] AirPlay became the default audio device

    25/05/14 11:51:52,534 iTunes[2941]: 2014-05-25 11:51:52.533805 AM [AirPlayAVSys] AirPlay became the default audio device

    25/05/14 11:51:52,818 coreaudiod[263]: 2014-05-25 11:51:52.818224 AM [AirPlay] Set up for stream GeneralAudio, PCM/44100/16/2 -> ALAC/44100/16/2

     

    But when the selection jumps back, it only logs 3 lines:

     

    25/05/14 11:37:48,593 SystemUIServer[257]: 2014-05-25 11:37:48.593088 AM [AirPlayAVSys] Picking route 'Apple TV' (XXXX)

    25/05/14 11:37:48,594 SystemUIServer[257]: 2014-05-25 11:37:48.594412 AM [AirPlayAVSys] Selecting endpoint XXXX, item 300 for (audio only)

    25/05/14 11:37:48,595 coreaudiod[263]: 2014-05-25 11:37:48.595407 AM [AirPlay] Selecting endpoint XXXX "Apple TV" for A/V

     

    (In the above "XXXX" is the MAC address of my Apple TV.)

  • Lane C Level 1 Level 1 (0 points)

    I have OS X Mavericks 10.9.4 on my Macbook Pro Retina 2012.  I experienced a similar issue where video would display when streaming to my Apple TV but audio still came out of the notebook.  I found this forum post and used the "sudo killall coreaudiod" command to fix the issue.  I did notice that upon running this tool my third party software for amplifying the volume (Boom) quit working.  I have reached out to the author of the software for help troubleshooting the matter future but I thought it might be helpful for others to know it may be related to my problem.

  • boobiestar Level 1 Level 1 (0 points)

    I've had this problem so many times I've created an application to fix it. I've posting it here. Disclaimer: It's a commercial app so I can continue to support it and make more useful apps.

Previous 1 2 3 Next