Previous 1 8 9 10 11 12 Next 178 Replies Latest reply: Oct 29, 2013 8:07 PM by davidh Go to original post
  • Free Tibet Level 1 (10 points)

    yes I sent it from an outside server...

  • redshift82r Level 2 (325 points)

    FreeTibet,

     

    Actually - managesieve is working (can save filters) - but Sieve not working ......

     

    I'd have a look at the Dovecot Wiki 2 for sieve / dovecot troubleshooting and enable all the logging as per that - post back with sieve log and we will be able to tell whats happening!

     

    (Journey, not destination.......)

  • Free Tibet Level 1 (10 points)

    Ok,

    I have found that if I create a new user or a new mail rules group then it works...

    Old accounts have a rules group by default called "wiki rules"...

    new users have a group called roundcube...

    Obviously the wiki rules does not work but not sure why it exists in old user account sieve's...

    but if I create a new rule group and put rules there it works for old accounts...

    just checking...

    would be nice to have the date pull down start / stop from squirrel mail...

  • redshift82r Level 2 (325 points)

    I guess that's a success then!  Why not install squirrel mail if you want that functionality?

  • angryiphoneuser Level 1 (0 points)

    Gerry - SUCCESS finally.

     

    Really stupid error but dovecot.conf was missing Sieve form the protocols definition,

     

    For reference in dovecot.conf change:

     

    protocols = imap pop3 lmtp

     

    to:

     

    protocols = imap pop3 lmtp sieve

     

    Many thanks for all your advice.  I will now wait to see if this gets over written at some point.

     

    Nick

  • Free Tibet Level 1 (10 points)

    Squirrel Mail is probabbly not as good on the whole...

  • redshift82r Level 2 (325 points)

    Beaut!

  • StevePW Level 1 (10 points)

    Hi Gerry,

     

    For some reason emails listed in RoundCube don't display a time/date (everything else is fine, inc. vacation responder).

     

    Have read this entire discussion and can't see that anyone else is having the same problem and my config is exactly as you've described.

     

    Any ideas?

  • redshift82r Level 2 (325 points)

    You mean date column shows blank or no date column showing?

  • StevePW Level 1 (10 points)

    Date column is there but no dates (is a blank space). Same emails viewed in Apple Mail show dates fine.

  • redshift82r Level 2 (325 points)

    Nope no idea - check settings / user interface ?

  • StevePW Level 1 (10 points)

    Yep, even tried messing with the format and turning off "Fancy" mode.

     

    The listing looks like this (sanitised):

    listing.jpg

    And message header displays like this (sanitised):

    message_view.jpg

  • redshift82r Level 2 (325 points)

    View source of message?

  • StevePW Level 1 (10 points)

    Yep, the Date field is definitely there (and displays fine in Apple Mail).

     

     

    Date: Wed, 21 Nov 2012 13:15:22 +1030

     

    Am about to do another RoundCube install on a server so will see if it happens again!

  • jhadi624 Level 1 (0 points)

    Hi Guys,

     

    I've been following thread and manage to install roundcube mail on 10.8.2 but unable to make the sieve to work

     

    I still having the same error "unable to connect to server" the only thing I did is I put all my service data (mail etc) in different directory ie /Volumes/external/Libary/Server/Mail....  and in this Mail directory there is no Config Folder. but in /Library/Server/mail, there is a config folder,

     

    could you pls help or give direction

     

    and BTW my port 4190 is already listening

     

     

    Escape character is '^]'.

    "IMPLEMENTATION" "Dovecot Pigeonhole"

    "SIEVE" "fileinto reject envelope encoded-character vacation subaddress comparator-i;ascii-numeric relational regex imap4flags copy include variables body enotify environment mailbox date ihave"

    "NOTIFY" "mailto"

    "SASL" "CRAM-MD5 X-PLAIN-SUBMIT PLAIN LOGIN GSSAPI DIGEST-MD5"

    "STARTTLS"

    "VERSION" "1.0"

    OK "Dovecot ready."

     

     

    Thanks

     

    Jon