Previous 1 2 3 4 5 Next 178 Replies Latest reply: Oct 29, 2013 8:07 PM by davidh Go to original post
  • redshift82r Level 2 (325 points)

    Simon - Should I create a new "rule" directory for my rules in /Library/Server/Web/Data/ ?



    As you add filters, managesieve will automatically create the UID  folder and files to /L/S/Mail/Data/rules/....





  • Gary Finch Level 1 (140 points)



         I have followed your instructions to get the managesieve plugin to a sort of working state. I already had the installation of roundcube working with MySQL and the filters do not error when saving etc. My issue is the the auto reply does not happen. There is no evidence of this in the smtp log or the sieve log when debug is on.


    Where can I check if the rule is even being evaluated?


    Thanks in advance for your help.



  • redshift82r Level 2 (325 points)

    Hi Gary, seems like I'm everyone's Managesieve Agony Aunt !!


    No error is good when saving!


    1. Click on the filter. If its enabled, it will be white text highlighted in Red.  If its disabled , it will be grey text highlighted in red.

    2. If its disabled, Untick the Filter Disbaled box.


    3. Click on the wheel under the Filter Group and download the rules to make sure they make sense.

    4. If you have made a mistake in the rule, there will be a file in the /L/S/mail/data/rules/uid folder/dovecot.sieve.log which will tell you what went wrong.

    5. Messages of interest will be logged to syslog under dovecot -type dovecot into the search bar at the top of all messages in console.


    Let me know what you find.


  • redshift82r Level 2 (325 points)

    Finally, if Recipient Address  = Sender Adress , Vacation rule will NOT be triggered.....!

  • Gary Finch Level 1 (140 points)

    I guess that's what happens when you are so knowledeable and nice


    The rule set looks ok -


    require ["variables","vacation"];

    set "EDITOR" "Roundcube (Managesieve)";

    set "EDITOR_VERSION" "5.0";

    # rule:[Vacation]

    if allof (header :contains "From" "")


              vacation :days 1 :subject "out of office" "I am away";





    When I try to enable the filter set I get.


    Unable to activate selected filters set. Server error occured.


    There are no errors in the logs as far as I can see.

  • Gary Finch Level 1 (140 points)

    Also from the sieve log -


    require ["include"];

    include :personal "test.sieve";



    [06-Aug-2012 12:12:12 +0100]: S: NO {110}

    [06-Aug-2012 12:12:12 +0100]: S: USER: line 10: error: included personal script 'test.sieve' does not exist.

    USER: error: validation failed.

    [06-Aug-2012 12:12:12 +0100]: C: LOGOUT

    [06-Aug-2012 12:12:12 +0100]: S: OK "Logout completed."


    Am I missing a path in the config maybe?

  • redshift82r Level 2 (325 points)

    I just watched Aus beat Russia in the basketball so I'm full of the joy of life.

    Sounds like a permissions error.

    Check that sudo ls -Fl of the /L/S/mail/data shows the owner of rules as _dovecot:mail

    To fix


    $ sudo chown -R _dovecot:mail /L/S/mail/data/rules


    Also , you have to add the recipient address to the "list of additional recipients", otherwise it doesn't work!

  • Gary Finch Level 1 (140 points)

    Perms are fine. I have tried all sorts of filters and none of them are working. It seems I can't even enable the filter sets even though the individual entries in the filter sets save ok.

  • redshift82r Level 2 (325 points)

    So - what I see in my rules/uid directory is :

    1. an alias to dovecot.sieve ( which doesn't exist - the phantom /var/lib/dovecot/sieve)

    2. dovecot.svbin - the compiled sieve rules -  see

    3. roundcube.sieve - roundcube being the name of my filter set. with permissions of 0600 and o:g of _dovecot:mail

    4. a /tmp directory


    so - what you're indicating is that the managesieve plugin can't write that file - in your case test.sieve?

    maybe try sudo touch /l/s/mail/data/rules/uid/test.sieve ?  (rather than typing in the uid - just drag and drop into


    I'm thinking either the paths are wrong somewhere in your configs or permissions / owner

    Might have to leave that one in your court to try a few things.

  • redshift82r Level 2 (325 points)

    Gary, I'm not sure how the filter group could appear in Roundcube/Settings/Filters without existing in the /l/s/ma/data/rules/uid directory.


    If its there, then it's a permissions /owner issue because you can read it, but dovecot can't write to it.

    If its not in that directly, try a $ locate test.sieve. (locate db is updated by the monthly maintenance script so it may not have run yet - try man locate to find the command to update the locate.db )


    If you find it elsewhere that might give you a clue to a config problem.


    Good luck

  • niwrik Level 1 (0 points)

    Hey guys,


    Sorry to hijack your thread, but if you manage to get vacation rules running, please let me know.  I've been following along this morning, and with Gerry's help, I've been able to get roundcube running on 10.8 Server.  Thanks very much for taking the time to post.  Very helpful.  I seem to be having the same trouble that Gary has.  I don't know a whole lot about the backed of OSX server, so I'm not able to contribute to any active troubleshooting.  The only thing I would be able to do is to verify settings on my system to see if they match yours.




  • Gary Finch Level 1 (140 points)

    Hi again,


    I resolved the enabling issue. I copied a new default plugin into my installation from a new download of roundcube and set the details you described previously.


    I have tested a basic filter that just sets a flag when a message with a specific subject arrives and that is working ok. I have a question about the "list of additional recipients" you mentioned.


    What address are you suggesting goes in there? It would be impossible to use the vacation message if there were a need to put the addresses of the sender in there. You dont know who will be emailing you??


    Can you clarify that for me please and many thanks for you help on this.

  • A Bigger Bite Level 1 (0 points)

    Hi there,


    after re-checking everything I realized I had overlooked your initial instructions to enable the plugin managesieve and autologin in config/ After doing that I got the Filter tab. Halleluja.


    Unfortunately I could not send any emails using the webmail. And after adding a test filter to my it account I can no longer recieve any email to it.


    I solved the sending email through rouncube by:

    removing '%u' and just leaving '' in SMTP user settings in .../webmail/config/


    Still trying to figure out why one of my accounts now can't connect to read IMAP mails anymore. (Sending works, "Connection Doctor" in mail works, but no emails, even after re-creating user in 10.8 and from WGM).


    Anyways, getting closer, thanks so much for the help so far and I sure hope Apple will figure out a way to make this implementation easier in the next release. (Considering they provide scripts to configure Promise raid's, why not provide scripts to configure a users own download of roundcube.. right? ;-)



  • redshift82r Level 2 (325 points)

    Hey Gary, great!


    Re vacation filter, if you are setting the filter in "Gary" user, then put "Gary"'s full email address in the "List of Additional Recipients" field.  Otherwise, it won't trip!



  • A Bigger Bite Level 1 (0 points)

    You should work in software QA. Thanks for that, finally working vacation messages/rules!

Previous 1 2 3 4 5 Next