Previous 1 2 3 4 5 6 Next 178 Replies Latest reply: Oct 29, 2013 8:07 PM by davidh Go to original post
  • redshift82r Level 2 (325 points)

    Simon, great again. 

    Re your user unable to login to imap:

     

    Try setting the imap logging to debug.

     

    I'm on my phone at the moment so I don't have the exact command,

     

    Do a sudo serveradmin settings mail:imap

     

    Find the mail:imap logging entry - it will by default be equal to "warn"

    Change that to DEBUG

    Stop and start mail

     

    Then your logs will be full of imap logging!

     

    I use an iOS app called Server Admin

    It's super quick to get access to the various logs for troubleshooting.

     

    If you can't fix it - start a new thread with the log results and someone will help!

    Cheers

    Gerry

  • redshift82r Level 2 (325 points)

    Hi, given the amount of info within this thread, would you be able to mark it as solved so it doesn't disappear and others with the same problem can find it more easily?

    Thanks

  • A Bigger Bite Level 1 (0 points)

    Ok, I think my non functioning IMAP account is related to the fact I added it as the iCal email notification for testing. So it did not have anything to do with managesieve or roundcube.

     

    Gerry if you are up for that challange please have a look over at: https://discussions.apple.com/thread/4183859

     

    Thanks again for all help, would have lost a lot of hair trying to get webmail and vacation note | rules | filters up and running without your notes on this. Very appreciated!

  • Gary Finch Level 1 (140 points)

    Hi,

     

         I am afraid that I still do not get any auto reply. I will look at the logs today. It's odd as other filters are working ok.

  • niwrik Level 1 (0 points)

    Same here.  I've turned on logging to syslog as Gerry described in an earlier post.  Sending test messages from outside e-mail systems does not trigger vacation message with filter applied in roundcube...

  • niwrik Level 1 (0 points)

    Other message rules run, but not "reply with message"

  • niwrik Level 1 (0 points)

    OK.  I think I've got it.  After messing around endlessly with sieve rules and attempting to use 3rd party vacation plugins (which I couldn't easily make work), the solution was easy.

     

    When you create the rule, be sure to put your e-mail address in the following field:

     

    Additional list of recipient e-mails (comma separated):

     

    As soon as I did that, viola!

  • A Bigger Bite Level 1 (0 points)

    redshift82r already told you to do that in page 3 of this thread though..

     

     

    Also , you have to add the recipient address to the "list of additional recipients", otherwise it doesn't work!

     

     

    ;-)

  • niwrik Level 1 (0 points)

    Boy I wish I had seen that...  Thanks.

  • Gary Finch Level 1 (140 points)

    I have already tried that but I still don't get the mail. I do not see any evidence of it in the smtp logs, imap logs, syslog and sieve logs etc. the only thing I do see is that the hidden file in the users uuid folder called .dovecot.sieve.dupes, I think, does get created. This file is used to stop the mail being sent more than once every day for example.

  • Gary Finch Level 1 (140 points)

    Sorry it is called - .dovecot.lda-dupes

  • redshift82r Level 2 (325 points)

    Gary, start from scratch !

     

    Create a new DNS entry - webmail2@yourdomain

    Create a new website and download current roundcube and go from there.

    It will not take as long as you think - create a new database as well. It can co-exist with your current webmail and will not cause any conflict for testing purposes.

     

    If you're really bent on solving it - You'll need to get deep into the documentation on the various wiki's

    Let us know how you go!

  • redshift82r Level 2 (325 points)

    Actually, that's your clue.  Everything else works and the reply with message actually got tripped and added that file so that it wouldn't send again for the specified number of days.

     

    Check your send mail settings.? But then start from scratch!

  • Gary Finch Level 1 (140 points)

    Ok even from scratch. No email. I changed from mysql to postgres for the clean install too.

     

    I guess I will have to keep digging.

  • DarKOrange Level 1 (5 points)

    Hello,

    I've followed these instructions on a fresh install of OS X 10.8 server.

    Everything went well during the setup but I have a big issue with postgres. The service stops by himself afterr a few minutes. If I relaunch it it stays up and runs for a few minutes and stops again.

    Any idea how i can fix that ?

    many thanks.

Previous 1 2 3 4 5 6 Next