1 2 3 Previous Next 39 Replies Latest reply: Apr 18, 2014 1:12 PM by jkuzniar
sebvol Level 1 Level 1 (0 points)

Since the update to Mountain Lion Mail uses always more than 80% of cpu as long as it is running. Has anyone a solution?


MacBook Pro, OS X Mountain Lion
  • 1. Re: Mountain Lion: Mail uses 100% cpu
    jbeir Level 1 Level 1 (15 points)

    Same problem here.  Installed ML yesterday morning, and machine has been running ever since.  Mail hovers around 100% CPU.  Have closed mail, restarted computer - no change.

  • 2. Re: Mountain Lion: Mail uses 100% cpu
    softwater Level 5 Level 5 (5,370 points)

    Quit Mail.

     

    Open Console (click the Spotlight, type 'cons' and hit return).

     

    Select 'All Messages' in the sidebar, then 'Clear display' in the task bar above.

     

    Open Mail.

     

    What messages appear in the console panel related to Mail.app?

  • 3. Re: Mountain Lion: Mail uses 100% cpu
    jbeir Level 1 Level 1 (15 points)

    Might have fixed it.  I had an old email account I was keeping around just to save old messages, but the mail server no longer exists.  I temporarily disabled this account and CPU usage seems to be normal.  I can re-enable to get access to old mail, but that's kind of a pain - but at least I think it solves my CPU problem.

  • 4. Re: Mountain Lion: Mail uses 100% cpu
    sebvol Level 1 Level 1 (0 points)

    my console says

     

    29/07/2012 15:08:54.934 Mail[43196]: Using V2 Layout

    29/07/2012 15:09:25.976 Mail[43196]: [<_LibSasl2SASLClient: 0x7f821074fd50> mechanism: PLAIN security layer: no] Failed to start the SASL connection

    SASL(-1): generic failure:

    29/07/2012 15:09:26.394 Mail[43196]: [<_LibSasl2SASLClient: 0x7f82106b0e20> mechanism: PLAIN security layer: no] Failed to start the SASL connection

    SASL(-1): generic failure:

    29/07/2012 15:09:26.474 Mail[43196]: [<_LibSasl2SASLClient: 0x7f820aa99640> mechanism: PLAIN security layer: no] Failed to start the SASL connection

    SASL(-1): generic failure:

    29/07/2012 15:19:25.996 Mail[43196]: [<_LibSasl2SASLClient: 0x7f82116aa420> mechanism: PLAIN security layer: no] Failed to start the SASL connection

    SASL(-1): generic failure:

    29/07/2012 15:19:26.141 Mail[43196]: [<_LibSasl2SASLClient: 0x7f821169ccd0> mechanism: PLAIN security layer: no] Failed to start the SASL connection

    SASL(-1): generic failure:

    29/07/2012 15:19:26.144 Mail[43196]: [<_LibSasl2SASLClient: 0x7f821169ccd0> mechanism: PLAIN security layer: no] Failed to start the SASL connection

    SASL(-1): generic failure:

    29/07/2012 15:19:26.157 Mail[43196]: [<_LibSasl2SASLClient: 0x7f8210d842c0> mechanism: PLAIN security layer: no] Failed to start the SASL connection

    SASL(-1): generic failure:

  • 5. Re: Mountain Lion: Mail uses 100% cpu
    jbeir Level 1 Level 1 (15 points)

    Mail now at 0%, consistently.  

  • 6. Re: Mountain Lion: Mail uses 100% cpu
    softwater Level 5 Level 5 (5,370 points)

    Go to

     

    Mail > Preferences > Accounts | Account Information

     

    Questions:

     

    1. What does it say under 'Outgoing Mail Server'?

     

    2. Is the 'Use only this server' box checked or unchecked?

     

    3. Click on the drop-down menu. What are the choices?

     

    4. In that menu, click 'Edit SMTP Server List', click the 'Advanced' tab, is there anything mentioning SASL?

     

    5. Is 'Use Secure Sockets Layer (SSL) checked or unchecked?

     

    From your console post, I would be looking for something mentioning SASL and trying to disable it in favour of SSL.

  • 7. Re: Mountain Lion: Mail uses 100% cpu
    jbeir Level 1 Level 1 (15 points)

    Arggh - spoke too soon.  I put my computer in sleep, moved locations, reconnected on a different WiFi and now mail is back at 100%.  I enabled/disabled the old email account, but that had no effect this time. 

     

    Open to new ideas.

  • 8. Re: Mountain Lion: Mail uses 100% cpu
    jbeir Level 1 Level 1 (15 points)

    Problem solved.  Waiting a little longer and everything settled down to 0% again. 

     

    My suspicion is that Mail checks all accounts at startup/return from sleep and that consumes a lot of resources, then once complete settles back down.  Lion Mail didn't seem to exhibit the same behavior. 

  • 9. Re: Mountain Lion: Mail uses 100% cpu
    tobyfromgarland Level 1 Level 1 (0 points)

    I had the same problem with Mail, even after disabling some accounts that from my work location were unreachable. In addition, I noticed that the 'sandboxd' process was also consuming a lot of CPU. On a hunch I decided to change the "Allow Applications Downloaded From" setting in the Security & Privacy control panel to "Anywhere", and that seemed to fix the problem. UPDATE: re-enabled the unreachable Mail accounts, and CPU shot back up. Disappointing.

  • 10. Re: Mountain Lion: Mail uses 100% cpu
    geordiskywalker Level 1 Level 1 (0 points)

    I am experiencing this issue when I am at work and behind a secure firewall that blocks the ports to Gmail and iCloud mail.  I launch the mail app and it constantly is trying to ping the Gmail and iCloud servers even though it can't get through.  Get New Mail setting on Manual check, disabling the accounts brings the CPU usage down to normal, but it's annoying to have to disable and re-enable 4 accounts when I am moving locations.

     

    I hope this gets paid attention to - I love Mountain Lion, just not this!!

  • 11. Re: Mountain Lion: Mail uses 100% cpu
    rbendalin Level 1 Level 1 (0 points)

    I have the same issue - and it is clearly related to having multiple accounts - some of which cannot be accessed from behind a firewall or other corporate type filtering device.  I have an Exchange account (business) an icloud account and a gmail account (both personal).  When I am on the company network (wired OR wireless), Mail's CPU utilization is consistently between 85 and 125%, and the macbook pro heats up, and the fans start humming - then I start getting erratic behavior like the search function not working properly in Mail, or it freezes temporarily, etc).  If I switch to a wireless hotspot that is not on the company network, Mail's CPU utilization plummets to anywhere from .1 to 15%, and the macbook pro operates normally as expected. 

     

    So - clearly Mail is freaking out when there are mailboxes that are inaccessible.

     

    This is extremely annoying and needs to be fixed.  It is hard to believe that Mountain Lion got released with such a glaring bug.

  • 12. Re: Mountain Lion: Mail uses 100% cpu
    EvilPenguin_ Level 1 Level 1 (0 points)

    This made me think of my proxy I'm using with DavMail for exchange '03. I disabled the account. The mail app now sits at the right CPU percent. Thanks for the idea spawn mate.

  • 13. Re: Mountain Lion: Mail uses 100% cpu
    Eric Stiens Level 1 Level 1 (0 points)

    I can confirm this is a problem with inaccessible mail accounts. I have a hosts file I occasionally switch to that blocks my mail connections when I need to work without distraction. Within minutes of switching it on, mail CPU use shoots above 100%. Seems like a bug.

  • 14. Re: Mountain Lion: Mail uses 100% cpu
    PollieKrismis Level 1 Level 1 (0 points)

    I can also confirm this.

     

    When at the office behind a proxy, Mail CPU usage shoots up over 100%. It does not help to disable (take offline) the accounts, CPU remains high. Restarting Mail also does not help.

     

    When at home or using 3G Mail works normally.

     

    This issue is forcing me to use the web interface for my exchange account, but worse, on one of the POP accounts I cannot receive mail, which I need.

     

    At the moment I'm holding off setting up Outlook for mac. I only have 8GB RAM (which I use all of it most of the time) and cannot afford to have both mail apps running, which means I'll have to migrate all mail accounts to Outlook if this issue is not resolved.

     

    Does anyone know if a bug report has been logged yet?

     

    (I have an early 2011 MBP with ML 10.8.1 and Mail 6.0 with 2 imap and 2 pop accounts.)

1 2 3 Previous Next