6 Replies Latest reply: Feb 25, 2013 2:13 PM by lachavita
wohan Level 1 Level 1 (0 points)

install failed (download from app store), error message says HD is damaged and can't be repaired!

 

i've tried

- disk utility repair (doesn't report any error)

- restart from bootable stick ('there was a problem installing Mac OS X')

- restart via timemachine (error: doesn't find any destination disk ...)

- via startup disk (error: can't gather enough information on the selected disk ...)

 

nothing works! what more can i do?


iMac (21.5-inch Late 2009), Mac OS X (10.7.4)
  • 1. Re: install mountain lion failed, HD is damaged???
    keg55 Level 5 Level 5 (5,925 points)

    Try this link. Below is an excerpt from it. Eventhough the link is for Lion, it may still apply to Mountain Lion.

     

     

    Install failed. Mac OS X Lion couldn’t be installed, because the disk (volume name) is damaged and can’t be repaired. Click restart to restart your computer and try installing again.

    If you see this unwelcome message, chances are slim that trying again will lead to success. The same is true if the Install application simply stalls before completing. Some users report that “zapping the PRAM” is sufficient to get past this roadblock. Otherwise, according to an Apple Support Communities thread, the fix is to boot from a Snow Leopard Install disc/drive and select to Repair Disk from Disk Utility. Assuming repairs are successful, try the Lion installer again.

    Otherwise, if nothing here has any positive effect (and assuming the drive itself is not physically defective), the solution is to reformat the drive and start over.

  • 2. Re: install mountain lion failed, HD is damaged???
    a friendly user Level 1 Level 1 (0 points)

    i had the damaged disk, cannot reair message pop up. and i had read another article telling me to plug an external hard drive into my computer, go to disk utility and partition it, and back everything up onto it. wipe the hard drive on the computer, then install mountain lion. after that re install everything off the external hard drive using migration assistant. and im not sure if i just got extremely lucky, and ive only tried it once but i plugged an external hard drive attempted to format it, but was unsucessful. it would not let me access it in the disk utility. but being bull headed i attempted to install mountain lion anyway. with the external hard drive still plugged in. IT WORKED! like i said i dont know if i got lucky and it just worked, or if i tricked my computer into thinking something was different. but it was super easy.

     

    1. plug in external hard drive.

    2. go to mountain lion installer

    3. still select hdd for your laptop or desktop (not your external hard drive)

    4. complete download.

     

    now im not sure of everyone elses problems, but mine just gave me the error. i didnt lose any information from my lap top. when my laptop restarted it booted up just fine.

     

    i really hope this works for everyone. good luck.

  • 3. Re: install mountain lion failed, HD is damaged???
    Intagli Level 1 Level 1 (5 points)

    thank you so much for posting this, I had the same problem. After connecting my SuperDrive with a DVD inserted, it worked for me as well!

    Afterwards I checked my disk again and was able to repair the "incorrect number of file hard links" error with disk utility in recovery mode. So thank you again

  • 4. Re: install mountain lion failed, HD is damaged???
    Snoopn'Grabbit Level 1 Level 1 (0 points)

    bizaare. Is this the new flavour of Apple?

    This is a common enough complaint the workaround should be in a Readme on the download.

    I'm forced into upgrading to ML because Apple won't provide the Snow Leopard versions of iWork, that I paid for, on the apstore . So I spend hours of my life on this pointless endeavour, finally finding, thanks to Friendly, my drive's not damaged, just psychosomatic!

    I employed the exact 4-point fix as friendly; super-simple and it works. But, why?

    I'm happy that I'm not too much longer on this plane. Soon enough I'll be on cloud-plane. Just hope it's not iCloud

  • 5. Re: install mountain lion failed, HD is damaged???
    jeromecovington Level 1 Level 1 (0 points)

    This little trick works wonders! Thanks!

  • 6. Re: install mountain lion failed, HD is damaged???
    lachavita Level 1 Level 1 (0 points)

    I had the same problem - but when I went to try this in disk utility, my HD isn't mounted, and won't. It did the first time I went in, but it's not now. Will it become worse the more I try to fix it? Any tricks to getting it to mount? (it appears in the list on the left, but is grayed out and said there's no mount)