Previous 1 2 3 Next 34 Replies Latest reply: Nov 2, 2012 9:41 AM by Dennis_S
bman51 Level 1 (0 points)

Just upgraded to Mountain Lion and sharing of photos via email no longer works.  I've seen posts of problems with Apple mail; but not sure if others are having this issue with outlook.  When I choose 1 or multtiple photos to share vioa email; it goes through an export process, Outlook dialogue email opens, but NO attachements or files embedded. 

 

This worked fine before upgrade; others experienced or have solution?  I can certainly send photos the "old fashioned" way; but at 10mb a photo, not practical.  Very frustrating.


iMac, Mac OS X (10.7.4)
  • Rishi Garrod Level 1 (10 points)

    I just noticed the same problem. I tried using Mac Mail and it works fine. I took a look in the plugins folder of Aperture and found a comment in the "Mail" applescript about a problem with inserting attachements before the signature, in the "Mail" script thay have done a workaround but not in the "Microsoft Outlook" script. After my coffee I will try to modify the "Microsoft Outlook" script in the same way.

  • Rishi Garrod Level 1 (10 points)

    I have found it. It seems that in Lion we had to convert the filename from Mac native to Posix format, in mountain lion this is no longer necessary. If you want to modify the script here are the instructions:

     

    Finder->Applications. Right click on Aperture and choose "Open package contents"

    Contents->Plugins. Open "Microsoft Outlook.applescript" (with the applescript editor)

    You should see the following 3 lines:

     

    -- convert the image path from UNIX to Mac

    set this_imagefile_path to (POSIX file this_imagefile) as string

    make new attachment at new_message with properties {file:(this_imagefile_path)}

     

    these should be replaced with this line:

     

    make new attachment at new_message with properties {file:(this_imagefile)}

     

    You are not allow to directly edit this file so save a duplicate somewhere.

    Rename the original script file.

    Copy the modified file to the Contents->Plugins folder of the package. It has to be called "Microsoft Outlook.applescript"

    You will probably be asked for your password a number of times.

  • bman51 Level 1 (0 points)

    Thanks so much; worked like a charm.  I assume Apple will eventually fix this bug.  When this happens will my manual edits to the script cause issues?  I just renamed the original file as OLD.

  • Rishi Garrod Level 1 (10 points)

    No problem. I upgraded to ML telling my wife there would be no problems, she makes and emails many foto's so you can understand that I had no choice but to fix the problem!

     

    Make sure you keep a copy of the "good" script outside the package as each Aperture update could replace the scripts. Lets hope Apple simply fix it in the next release.

  • Rijckholt Level 1 (0 points)

    Worked for me as well!

  • CrankinSteve Level 1 (0 points)

    Nothing like getting help from the community. This worked perfectly. Thanks.

  • adeelquyoum Level 1 (0 points)

    Worked for me too ! I asked this question yesterday too. Thanks for the answer.

  • Dennis_S Level 1 (5 points)

    I had the same problem but a fellow poster Ernie Stamper directed me to your solution.

    Thanks so much for your insight and fix!

  • Dennis_S Level 1 (5 points)

    Question about this.

    It works!

    But how can I add something to the script so that when the email is created with the attached files it also includes my email signature.

    Please bear in mind I have zero A/Script knowledge.

     

    Thanks!

  • Rishi Garrod Level 1 (10 points)

    Hi. You would need to find the applescript command to add your outlook signature. Without A/Script knowledge it might me a bit tricky.

  • Bill Veeser Level 1 (20 points)

    Thanks..  it works great

  • Stephen Halloran Level 1 (0 points)

    Excellent. I'm very grateful. I wish I had looked on the Apple Community web site earlier.

  • rangle12 Level 1 (0 points)

    Help please. I found the applescript you said to change. I am able to duplicate it and change it. I can't rename the original file because it keeps telling me I don't have permission.

  • Cycle11111 Level 1 (0 points)

    Never had to do this before but it worked like a charm

     

    Thanks tons this was very irritating

Previous 1 2 3 Next