13 Replies Latest reply: Jan 13, 2013 5:11 AM by hk235m
AntonyChan Level 1 (0 points)

after upgrade to Mt lion, Trackpad handwriting for traditional Chinese input not working anymore. so disappointed.


MacBook Air, OS X Mountain Lion
  • Yanni Pang Level 1 (25 points)

    To fix this problem, just 2 finger swipe down when you are in Trackpad Handwriting.

  • yuebon Level 1 (0 points)

    Hi both,

     

    I seem to be having a similar problem. I can get the trackpad to recognise and predict traditional handwriting, however when I press on the character, it simply disappears, and the next suggestion appears- all without any of the text being entered into the application I am in.

     

    Yanni, what do you mean by 2 finger swipe? When I do this, the trackpad is still active, so I just draw two lines over my character!

     

    Many thanks!

  • Yanni Pang Level 1 (25 points)

    I'm sorry if I wasn't clear enough... What I meant was when your trackpad isn't recieveing any response, do the swipe then it would start working again.

     

    Now your question... I would like to help you further, but screenshots/video would work best because I couldn't recreate your problem. Are you using Simplified or Traditional Chinese? Are you tapping on the corresponding corner on your trackpad for your selected word? Please follow up.

  • yuebon Level 1 (0 points)

    Hi Yanni,

     

    Thanks for your speedy reply! No, my trackpad is working fine- the problem seems isolated to the point at which I tap the character I want to use, after which the character pad is cleared (normally at this point the character I tap will appear in the selected text field).

     

    For example:

     

    Screen Shot 2013-01-04 at 02.19.26.png

    Right after I tapped the top right character, (at which point I would normally expect the character to be inserted at the text cursor), the pad was cleared, and the suggestions for the next character appeared...Screen Shot 2013-01-04 at 02.19.36.png

    ...without the character being inserted! Nothing I enter via the Trackpad Handwriting window seems to be entered into any text fields.

     

    I am using Traditional Chinese, with only Trackpad Handwriting enabled. I am currently using Mountain Lion 10.8.1 - I upgraded via the updater from Lion (which was the factory install). I didn't have any problems before updating to ML. I have read elsewhere on the forums that perhaps a .plist has become corrupted somewhere, but don't know which one it might be. I'd appreciate any help you could offer!

     

    Thanks so much!

  • Yanni Pang Level 1 (25 points)

    Try this:

     

    Go into your user Library directory:  ~/Library/Preferences

     

    Find this file:  com.apple.inputmethod.ChineseHandwriting.plist

     

    There might be more files with .ChineseHandwriting.plist

     

    Move or delete all these files to your Desktop.  Then reboot your computer.  Launch your writing pad and see if that works.  If still have problem, you may have to do a PRAM to restart again but make sure above files were moved or deleted out of the Library/Preferences directory.

     

    OR Try this:

     

    In System Preferences - Language & Text - Input Sources

    There is a radio button called "Input Sources Options"

    Select "Allow a different one for each document" Please Get back to me

  • yuebon Level 1 (0 points)

    I just tried your second suggestion and it worked immediately!

     

    Hopefully that simple fix will be applicable for others with the same problem.

     

    Thank you so much for your help!

  • begamot Level 1 (0 points)

    FYI, I had the same problem in 10.8.2, but found no .plist file with that name.

     

    However, the PRAM restart did fix the problem (and I still couldn't find a .plist file with that name).

     

    Thank you for the help!

  • begamot Level 1 (0 points)

    So, the fix of restarting PRAM only lasted a few hours and now it's back to not working (same as in the screen shots provided by yuebon). Any additional advice?

  • yuebon Level 1 (0 points)

    Begamot, did you try the simple fix that worked for me?

     

     

    OR Try this:

     

    In System Preferences - Language & Text - Input Sources

    There is a radio button called "Input Sources Options"

    Select "Allow a different one for each document" Please Get back to me

  • begamot Level 1 (0 points)

    Yuebon, I tried that option first, since I was too lazy to restart (hehe). When that didn't work I went with the RPAM reset. I double check and my system preferences still show the option selected for "Allow a different one for each document."

     

    I also wanted to add that I noticed the error is behaving a bit differently this time. I tied drawing the character, but when it didn't work, I managed to find the Pinyin, and started to enter the character with the Pinyin input keyboard. As soon as I started typing, the image of the character I had entered using the trackpad appeard.

    Screen Shot 2013-01-06 at 1.00.35 PM.png

    However, there was no way for me to get that "ghost" character to stay on the document I was working on. The Pinyin input overrode anything lingering from the trackpad.

     

    Also, I noticed this happening while using certain programs/web sites but not others. I was in Google Docs (in Chrome) when the problem originally occurred, tried to replicate here in the forums, and trackpad worked perfectly, and then tried to confirm again, and trackpad works with Apple forums while browsing in Chrome, but not in Firefox...

  • Yanni Pang Level 1 (25 points)

    Are you pressing space to "insert" the word or are you pressing the numbers?

  • begamot Level 1 (0 points)

    I normally press spacebar to insert the characters, but the behavior is exactly the same if I press a number.

     

    Just to be clear, the Pinyin input is working fine — I'm only having trouble with the trackpad handwriting input.

  • hk235m Level 1 (0 points)

    Tried all suggested fix(remove plist, reset PRAM, click anoher radio button), but no luck to me....

    Chome is always no problem, but I cannt get it in Firefox...