2 Replies Latest reply: Jul 29, 2012 9:08 AM by frederic1943
jimturner7 Level 1 (0 points)

I have 2008 Macbook running OSX Lion 10.7.4 and on attempting to upgrade to Mountain Lion got a message that my compter was not compatible with Mountain Lion. is this correct/

MacBook, Mac OS X (10.7.4)