Previous 1 2 3 4 5 Next 64 Replies Latest reply: Sep 18, 2013 6:04 AM by Jamy Go to original post
  • Yann Bizeul Level 4 (1,320 points)

    This is not a fix. It just prevents notifications to popup in system notification center, but the notification tray in Calendar or iCal is still flooded by such events

  • mcg- Level 1 (20 points)

    Yann Bizeul wrote:


    This is not a fix. It just prevents notifications to popup in system notification center, but the notification tray in Calendar or iCal is still flooded by such events

    This is true.


    I'd imagine the Calendar development team will work something out and it will be addressed in a future update, hopefully in coming months.


    I hope they make it possible to turn off these 'invitations' on a per-calendar basis via iCloud. I would like to see the alerts for one of the 16 Calendars I share, the rest I don't need to know about daily changes.


    If everyone hasn't already, make a suggestion via Apple Calendar Feedback. (aka iCal)

  • Ronniebel Level 1 (85 points)

    I'm having the same problem, but it's only the invitations to my calendar events that are showing up on my wife's phone in the calendar I share with her.  When she adds stuff to her calendar, those invitaitons are not whoing up in the calendar on my iphone she shares with me.  Strange and frustrating.

  • Stema001 Level 1 (110 points)

    I have a different calendar issue, but maybe someone here could help me.


  • mcg- Level 1 (20 points)

    mcg- wrote:


    I'm going to leave them there and see if Apple have built some sort of 'aging' into them - they may eventually drop off..

    I have not made a detailed study but my list of notifications in the 'invitations' tray which had initially peaked at over 50 has now dropped down into the 30's. They're possibly dropping off the list after the event has passed, which would make sense.

  • Killfox Level 1 (0 points)





    Make sure the shared calendars are deselected - on the iPhone AND in iCloud.


    So far, no new notices.

  • dan3ny Level 1 (0 points)

    Wish that worked for me killfox, but it doesn't

  • mcbmail Level 1 (0 points)

    This is one of the few threads that resembled the troubles i was having with annoying calendar notifications on my iphone.  As stated above the "Shared Calendar Alerts" did not work for me either.  My problem and final solution pertains to Google calendars, so this may not help many. 


    My digital life, for better or worse, is Google.  My calendar, my work calendar, my family's and my wife's.  Long story short i wanted her calendar on my phone so i could see her schedule.  But all of her alerts that she set for her calendar reminders were passed on to me and popped up on my phone.


    Here's the fix i found as it pertains to shared Google calendars.  I had originally had her calendar set up as another mail account, but with the mail and contacts portion turned off.  I went in and deleted this account.  I went to Add Account > Other > Add Subscribed Calendar.  In the Settings > Calendar Details of my wife's Google Calendar i got the ICAL private address.  (Long private URL that ends in */basic.ics.)  I put this in the Subscribed calendar and hit next. 


    Now i can see her calendar without the annoying alerts and pop-ups.  Now it is under Shared Calendars and i have even more options for removing alarms and alerts. 


    I'm not sure if this will help everyone, but if you can find the ICAL *.ics address of the calendar you want to view from its provider this might be a fix.  This had plagued me for a while so i had to post.  If this post is better placed somewhere else, please advise.



  • prouss Level 1 (0 points)

    I followed your suggestion and added a calendar (my kids' school) as an "Other", and now it shows up as a Subscribed Calendar.  I've checked "Remove Alarms" but I'm still getting notifications on it - where do you see other options for removing alarms and alerts?



  • snailgarden Level 1 (0 points)

    I recommend submitting feedback to Apple under the iCloud category. Once you chose that, you can select iCal as an iCloud product.

  • Ryttergaard Level 1 (0 points)

    Hello Apple,


    What is your view on this major bug. It is difficult to continue to use Ical as a business tool with all the notifications from other users that disturb constantly!


    Please get this fixed.

  • sandrift Level 2 (395 points)

    Ryttergaard - this is a forum for users.  Apple does not officially monitor these forums and they never respond to comments posted here.  If you have a concern, the best course of action is to provide polite, constructive feedback (with details of the issue) through the Feedback website:



    Hopefully if all of us who are having trouble will do this and raise the issue to a higher position in Apple's To-Do list.

  • Loren Ryter Level 2 (495 points)

    I also find these pseudo-invites when my spouse adds to her shared calendars annoying. I've left feedback.


    But I wodner, what are the implications of NOT hitting OK to these pseudo-invitations in the iOS Calendar app?  What am I agreeing to or not agreeing to?

  • terriergal Level 1 (10 points)

    I have the same problem but I want the alerts ON -- i get the alerts from all my shared calendars on everything BUT my phone which is where I need it probably the most.  Shared alerts is turned on in settings.

  • GK_Medic Level 1 (0 points)

    I hope this helps...


    "If what bothers you is a crowded Notification Center, you can clear it by selecting the app you don't want. In the next page, find where it says "Notification Center" and simply turn it off. This will still let you receive alerts from the app, but they will no longer linger in your Notification Center after you see them."


    This was referenced from an article in the LA Times: 1011