Previous 1 2 3 4 Next 46 Replies Latest reply: Nov 13, 2015 11:37 AM by nucleon2000
connorfitz89 Level 1 Level 1

This is really confusing me.

 

This morning I used the card reader in the imac to copy files, after the update the imac wont recognise my SD cards (including the one that worked this morning), they are not coming up in disk utility either.  However when i take it out i get the error message saying that i never ejected it properly.

 

Any help would be apreciated!


iMac, OS X Mountain Lion
Solved by connorfitz89 on Aug 8, 2012 1:18 AM Solved

Hey,

 

Sorry was away on holiday for a few days.

 

Finaly got this sorted, i searched google and found someone who had a similar problem.  Turns out when i restarted the imac the SD Card was mounting but when I inserted when it had already started it did not, the guy realised that the wee switch in the card reader must of been stuck and got something to put into it and swipe the switch back.  Mycard was now recognised in finder but not appearing on my desktop.

 

i then realised why so many are having problems since update, i always had as mentioned above 'thatsfixedit' (Click on 'Finder' 'Preferences' - tick the box 'external disks')  for some reason apple have now changed SD cards into the 'CDs, DVDs & Ipod' catagorey, tick that and it will reappear.

 

Problem solved, hope this helps others!

Reply by rkaufmann87 on Jul 29, 2012 11:29 AM Helpful

Open Terminal (Applications-Utilties-Terminal) and open a Terminal window and copy and paste this command:

 

Killall Finder

 

Then insert a SD card and test again. If it still won't work restart the computer in Safe Mode and then restart normally.

All replies

  • rkaufmann87 Level 9 Level 9

    Open Terminal (Applications-Utilties-Terminal) and open a Terminal window and copy and paste this command:

     

    Killall Finder

     

    Then insert a SD card and test again. If it still won't work restart the computer in Safe Mode and then restart normally.

  • connorfitz89 Level 1 Level 1

    Thanks for the quick reply.

     

    After I done what you said I restarted, still not recognised but now when I remove the SD Card it does not give me any error message.

     

    Still stuck.

  • connorfitz89 Level 1 Level 1

    I have been looking about and went to apple>about this mac, when i click on storage it shows my memory card but it is still not listed on the desktop or finder.

  • susanfromchatham Level 1 Level 1

    i'm having the same problem on my 2010 27" imac

     

    could apple have missed something?

  • Astroleptirobot Level 1 Level 1

    I'M having a similar issue on my mid-2011 MBA. Going to About My Mac->More Info->System Report then to "Card Reader" says "This computer doesn't contain any Apple Internal Memory Card Readers." This is since my upgrade to the release build of Mountain Lion. I'm fairly certain that it still worked on the last developer preview I had.

     

    I've booked an appointment at the Apple Store this morning, I'll see what they find.

  • Philip Hoyos Level 1 Level 1

    Im having the same issue - and I know it worked prior to my upgrade. Im running a Macbook Pro 2010 edition.

  • Astroleptirobot Level 1 Level 1

    So I went to the Apple store at the Genius bar, tech guy plugged my MBA in and had a diagnostic tool running that looked like it was built on Mac OS 9 (I kid you not). The UI showed a yellow "!" warning icon over the motherboard icon, which didn't bode well. He did solve the issue however. I apparently had leftover drivers from previous versions of Mac OS (from the Mountain Lion developer previews I suppose). SD card reader now works.

  • leolodreamland Level 1 Level 1

    i'm not in the genius bar, anyone got a solution? my macbook pro 2009 does not see any card i put in after ml upgrade...

  • thatsfixedit Level 1 Level 1

    Click on 'Finder' 'Preferences' - tick the box 'external disks'

  • leolodreamland Level 1 Level 1

    that's all it is... sheesh. thankyou!

  • connorfitz89 Level 1 Level 1

    Hey,

     

    Sorry was away on holiday for a few days.

     

    Finaly got this sorted, i searched google and found someone who had a similar problem.  Turns out when i restarted the imac the SD Card was mounting but when I inserted when it had already started it did not, the guy realised that the wee switch in the card reader must of been stuck and got something to put into it and swipe the switch back.  Mycard was now recognised in finder but not appearing on my desktop.

     

    i then realised why so many are having problems since update, i always had as mentioned above 'thatsfixedit' (Click on 'Finder' 'Preferences' - tick the box 'external disks')  for some reason apple have now changed SD cards into the 'CDs, DVDs & Ipod' catagorey, tick that and it will reappear.

     

    Problem solved, hope this helps others!

  • Philip Hoyos Level 1 Level 1

    This does not solve my problem. My card reader will still not show anything. I have checked Disk Utility, the system information, tried to open iPhoto to see if that would tricker anything - but alas. I even opened up VMware to see if that would make a difference. It is as if the card reader does not read any cards at all - and it used to work prior to the upgrade.

     

    This is what I get from the System Information:

    Built in SD Card Reader:

     

      Vendor ID:          0x14e4

      Device ID:          0x16bc

      Subsystem Vendor ID:          0x14e4

      Subsystem ID:          0x0000

      Revision:          0x0010

      Link Width:          x1

      Link Speed:          2.5 GT/s

    So it is still there and should be working.

  • yantaialec Level 1 Level 1

    thatsfixedit wrote:

     

    Click on 'Finder' 'Preferences' - tick the box 'external disks'

    Same issue for me. Finder>prefs doesn't work.

    All boxes are ticked and still nothing.

     

    About this mac>more info>card reader gives me this:

     

    Built in SD Card Reader:

     

      Vendor ID:          0x14e4

      Device ID:          0x16bc

      Subsystem Vendor ID:          0x14e4

      Subsystem ID:          0x0000

      Revision:          0x0010

      Link Width:          x1

      Link Speed:          2.5 GT/s

  • charliemoss Level 1 Level 1

    rkaufmann87's suggestion above worked for me.

     

    • Remove SD Card

    • In Terminal enter Killall Finder

     

    • Put in SD Card
Previous 1 2 3 4 Next