Previous 1 2 3 4 Next 46 Replies Latest reply: Nov 13, 2015 11:37 AM by nucleon2000 Go to original post
  • CALduenda Level 1 Level 1

    So, it's ok for someone to be rude to someone and automaticaly assume it's user error and not an OSX issue, but when we call him on it, our comments get edited but his rude comment stays?


    This SD issue has NOTHING to do with user error since cards go in only 1 way, and it has been proven to be an issue since ML upgrade.. Stop being one sided and be equally fair to everyone.

  • meika2u2 Level 1 Level 1

    The same thing is happening and I have owned my macbook pro for 6 months now.

    Any solutions for this? Has anyone received an email from Apple?

  • Big Red Barn Level 1 Level 1

    Please everyone let Apple know you are having this problem so it can get fixed in an update. Tell Apple here:


  • meika2u2 Level 1 Level 1

    Done... we need to all do it!

  • BrianForbesColgate Level 1 Level 1

    I posted this to Apple Feedback for Mac OS X ...


    Hellooooooo ... Please update you drop-down menu, below ... I am running OS X 10.8.3, but it is not on the menu. 


    Perhaps this explains a lot.  Has everyone at Apple not been made aware that Mountain Lion was released some time ago?


    Since the update to Mountain Lion the SD card no longer shows in Finder.  not in the Sidebar.  Not under DEVICES.  Not under "My" iMac.


    If it does not show up, then it cannot be Ejected, and if it cannot be ejected properly, then we have the message popping up telling us that we have done something wrong. :-(


    This is a problem that has been outstanding for some time now, but it has been exacerbated by off the cuff, smart aleck to smart *** responses by persons identified as being Apple employees. 


    They blame the User.  They tell us we have not followed the instructions to run killall -Kill Finder in Terminal, when we have, many times, with very mixed but always unsatisfactory results.  Some persons have found that to help for a short time, but never beyond a re-boot, while others have had no success in creating a change at all.


    Two things need to happen:


    1.  This nearly year-old problem, across all Mac platforms, needs to be fixed, and,


    2.  A number of Apple employees need to be jacked up, then sent back to Customer Relations school.


    Perhaps this is merely Apple's way of getting rid of all of your Mac clients so you can focus on your more financially rewarding iOS business sector?  If so, that is very short-sighted indeed. 


    Without wanting seamless integration with my Mac product, iPhone, iPod would not get a second look against the competition out there now ... or have you not noticed falling market share as it is?

  • ThinkingXL Level 1 Level 1

    I was having issues with my Macbook Pro (2012 model running 10.7.5) SD card slot. Originally it was a software issue for me, stating that my laptop didnt have a SD card slot but after doing all the OS X updates, the System Report (About this Mac > More Info > System Report > Hardware > Card Reader) had recognized that it had one.


    Tried putting a 4GB Fujifilm SD, 1GB & 4GB Sandisk SD, and none would show up under devices or on the desktop. I tried all of the solutions above and none of them worked. Then I read the posts about the compressed air and WD40. I wanted to avoid putting any liquid in my laptop so I figured the air would work. Unfortunately I didnt have any compressed air sitting around. I opted to get a flashlight and took a look inside the SD slot. TONS of dust and hair particles. I got myself a dental explorer (my mother works for a dentist) and used the hook from it to pull the dust and hair out while being mindfuland very cautious of all the metal prongs inside. Then I blew into the slot twice once I removed all the dust, and viola! It works again! Even restarted the laptop twice and it still works.

    Obviously not everyone has a dental explorer lying around so your next option could be bending a paper clip into a sort of C shape and use that! Just make sure you unplug and turn off your laptop or imac and be VERY CAREFUL WHEN POKING AROUND INSIDE. You dont want to bend any of the connectors. Let me know if this helps anyone!

  • leolodreamland Level 1 Level 1

    yeah that's a great idea, why don't jam a bent up paper clip inside your $2k laptop. **** me are you totally stupid? use some compressed air or a plastic implement. you are obv very lucky. DO NOT repeat this silly person's actions

  • Jowl2 Level 1 Level 1

    Thank you, this worked for me. Strange!


    By the way, my SD Card(s) wouldn't show up in Finder OR disk Utility - or even in the recovery utility. The terminal command has fixed it and survives a restart. I'll check on a shut-down and power up later.

  • Eltham Jones Level 1 Level 1

    I've just upgraded to ML and found that my CF card is not being recognised via USB card reader, or when accessed directly via the USB connector in my camera. System Profiler shows nothing connected but camera respnds when plugged into USB. Relaunching Finder hasn't helped. I haven't had a chance to test it with another miniUSB lead yet so I'm hoping it's just a bad lead, but this one was working before...

  • edwin307 Level 1 Level 1

    To think... that it was just dust causing my MacBook Pro to not recognize my SD Card.... >.> thanks!

  • BrianForbesColgate Level 1 Level 1

    ML does not recognize my SD card in Finder, but it does pop it up on the Desktop.

    When I insert the card into the socket on the iMac, the Nikon ViewNX2 app launches and transfers the photos to the hard drive.

    When I exit the app, the icon is still on the Desktop and I must Eject it from there.  I can set the ViewNX to automatically Eject the card, but I often am transferring to more than one folder in the hard drive and find it easier to Eject it manually.

  • Reinhard Reading Level 1 Level 1

    I have been having the same issue for some time - the SD card works in an external reader and other machines, but not in the MB Pro's own slot - and (having read the comments by ThinkingXL above) I just fixed it by gently cleaning the contacts inside the reader using one of my wife's wooden fingernail sanding files.

  • paolo17 Level 1 Level 1

    Same problem here.

    Mine is dual boot and it woreks fine under windows, so not a hardware problem.

  • bl1955 Level 1 Level 1

    I have a retina MBP with the same problem. However, I'm also using parallels 9, and it works perfectly, and configures as a drive under Windows. A bit weird that the Windows software works on MBP, but ML doesn't. At least I have a workaround. Back to Apple to sort this out, as it should not happen.


  • TwinTiger Level 1 Level 1

    Thank you for this rkaufmann87!


    I had not used by SD card reader for some time on my late 2001 MBP, only to notice that it did not recognise a previous SD card that it used to prior to the Mountain Lion upgrade or it would recognise it but not allow me to write to it.  I had a USB SD reader that was an immediate work-around until I read this 'fix'.


    All good now and I have the SD reader back doing what it should in my MBP.