Previous 1 2 3 4 Next 53 Replies Latest reply: Nov 18, 2015 12:36 PM by melissacara Go to original post
  • MihaiDeliman Level 1 (0 points)

    Changed the wifi channel to 1, and no problem what so ever, no matter the resolution of the screen. Don't know if it works with the lid closed.

  • joshemory Level 1 (0 points)

    So changing channels is a solution, now if we could only figure out why the heck that was happening haha. Then we'd be doing Apples job.

  • choots79 Level 1 (0 points)

    I'm trying to use mine in a enterprise environment so changing the channel on the access point is not that easy.  I just broke down and bought the USB to ethernet since I have drops at my desk.  Obviously works like a champ now.

  • Hawkmo0n Level 1 (0 points)

    I changed my channel on my router this evening and will report back if I have any issues.

     

    I am willing to try anything at this point.

  • Hawkmo0n Level 1 (0 points)

    So far so good!

     

    Changed my router channel to 1 a few days ago and haven't had any issues since!

     

    Not the best situation for people in enterprise environments but it seems to be a solution for me at this point.

  • Hawkmo0n Level 1 (0 points)

    Channel 1 is the answer to my problems it seems.

     

    10 days in and I haven't had an issue since, lid open or closed.

     

    Thanks everyone!

  • Hawkmo0n Level 1 (0 points)

    !

  • JimmyDP Level 1 (0 points)

    Same problem.  My setup:

     

    1. MacBook Pro Retina
    2. Mountain Lion
    3. External monitor attached via Apple Thunderbolt-to-DVI adapter
    4. Network connectivity available via wi-fi only

     

    Consistently, I could not connect to wi-fi with the Thunderbolt cable attached but could with it detached.  I changed the wi-fi settings on my Linksys router to use channel 1 instead of channel 6 and the problem disappeared.

     

    Thanks to all of you who posted before me and helped me solve the problem quickly!

  • Klabauter Level 1 (0 points)

    Same here!

     

    • Macbook Air late 2010
    • new LG 27" HDMI Monitor
    • third party hdmi adapter

     

    Instant drop from 50Mbit to 2Mbit when connected, physical proximity is NOT important. Macbook can be right next to monitor (connected to Windows PC) and still achieve 50Mbit, only when it it CONNECTED the speed drop occurs.

    Tried swichting channels, doesn't work for me (best I can do on other channcels is 5-8Mbit).

     

    Solutions:

    • Swiching to 5Ghz! Works like a charm. (but not good for me since my external WiFi USB Stick on my PC does not support 5Ghz)
    • Connecting to Monitor (if possible) via VGA. Worse display quality but full 50Mbit.

     

    This gets more and more confusing! -.-

  • jasheets1 Level 1 (0 points)

    I had same issue connecting Early 2011 MBP via off-brand mini-displayport -> HDMI -> DVI on an older model Samsung LCD.

     

    It was working fine, then I was playing with Mac Settings for the Display Resolution. Changed from 'best for display' to 'scaled' and my network dropped off. Changed back to 'best for display' and still didn't come back. But then changed from 75 hertz to 60 hertz and instantly my wifi network works again!

     

    Hope this helps someone else out there...

  • timmo11 Level 1 (0 points)

    OK

     

    ready for some real Voodoo?

     

    It seems that changing the display preferences is critical

     

    I have had this set up:

     

    2012 MBA -> Generic Thunberbolt to DVI Adapter -> Apple Cinema Display 23" from 2005

     

    Wireless has been working flawlessly on Channel 11 for weeks, with the lid closed.


    A friend came over with his 2012 MBA and I said "hey, take a look at how it looks on a bigger screen"

     

    We plugged it in, had to open display preferences on HIS machine and do arrangement and the like. Didn't actually use the net.

     

    Later that day I plugged in my MBA and .... slow to no wirless.

    Wondered about new interference, put in an old Airport Express to boost the signal.

    Nothing worked.

    Have now changed the channel to 5 and am getting about 10Mbps

     

     

    Go figure!

  • CJHus Level 1 (0 points)

    I'm one more user experiencing this problem, which was largely solved by switching my router to channel 1.

     

    I've got a mid-2012 MacBook Air with great wifi speeds (50/25 Verizon service testing at those speeds or better) until I plug in my Dell 2007FP 23" monitor through a Apple Thunderbolt to DVI connector. It then drops to 10-20% of those speeds, especially the download rate. Changing the Dell monitor resolution also largely fixes the problem.

     

    BTW even after fixing the problem by using channel 1, when the MB Air lid is open the speeds are 20% higher. Turning off bluetooth also speeds things up incrementally.

     

    Thanks for everyone's posts.

     

     

    keywords: Verizon FIOS wifi slow MacBook Air Dell external monitor Thunderbolt port

  • Guza Level 1 (0 points)

    If hooking up a thunderbolt output for a display and your wifi stops working try the following.

    If your using an apple airport express go to the finder.

    1. Type in airport, then open airport utility.

    2. Click on Base Station.

    3. Click Edit.

    4. Click Wireless.

    5. Open Wireless Options tab.

    6. Where you see the 2.4GHz Channel listed change it to 4.

    7. where you see 5GHz Channel Change it to 149

    8. Click save and apply.

     

    That should do the trick.

  • Rogermr Level 1 (0 points)

    Hey.. same issue here.. as one user more

     

    Apple should take care of this..

     

    MB Retina 13 late 2012-->2 apple original minidisplay to DVI-d adapters ----> 2 hpLP2465 monitors -->lid close or open.. (for 3 screens)

     

    3 screens working perfect, Internet Access, Total Play 200/50 full access testing, screens 50 cms away from MBP

    Change one minidisplay with one DVI-d to HDMI for same display Works great (still 2 monitors, trying to work with three exterrnals.. lately)

    Working great 1 week, 1 day broke the wifi, disconnect and reboot anything..

    next week working great, 1 day broke again..

     

    i`ve tried changing channels -- works great as solution

    after....

    Using multicontact for energy for monitors on the same conection.. plus a laptop (VAIO)adapter, we disconnect the laptop adapter--- works great..

     

    So far so good..

     

    Next week I approach a cellular alcatel phone under the monitor and again.. the WIFI presents problems..

     

    Seems that the protection from radiation offered by MBP is deficient.. when many technology devices are near..

     

    Apple should fix this.. as its hardware issue.. should make a repair recall. as many users having this issue..

  • jürgen154 Level 1 (0 points)

    I had exactly the same issue with MBP Retina 13 and Dell 2408 DVI2mini-display and what helped here was to pull out the dvi-cable completely (as i tried to move away as far as possible from the monitor (aprox. 3 meters) and then moved closer to see what distance might work.) At the end I was 30-40cm away but with straight cable and now WiFi still works having the MBP and the 24" monitor side by side.