Previous 1 2 3 Next 42 Replies Latest reply: Sep 20, 2012 1:56 PM by Ed Enners
pki730 Level 1 (0 points)

I've been using my iMacs for a few years to monitor six ip Camera video feeds.  The cameras I use are both FOSCAM and AXIS brands.  I've used a few third party software solutions to do the monitoring, but I could also always use Safari to access a camera at a time by putting that camera's IP address in the address field and logging into the camera. 

 

After upgrading to Mountain Lion, my video feeds started timing out when using DComplex's IP Camera Viewer, so I thought initially it was strictly an issue with that third party app.  However, I then logged into my cameras using Safari and they timed out as well.  Similarly, when using Axis Camera viewer, my video feeds would time out.  It seems as whatever the issue, it does not affect Firefox, because I can still login and monitor 1 feed at a time using that browser without any timeout issues, and for some odd reason, the FOSCAM only program uFoscam works, but the problem for me with that app is that it only works with Foscam, and not the Axis cameras (besides it's an inferior program to IP Camera Viewer in my opinion as well).

 

Has anyone encountered this problem and come up with a solution?  I'm thinking it's some sort of plugin or video codec problem, but it's well above my paygrade to figure it out.


iMac, Mac OS X (10.4)
  • dholweb Level 1 (0 points)

    I have exactly the same problem using the same software. I bought IP Camera Viewer a few months ago, but since upgrading to Mountain Lion, this software also stalls after 5 seconds and then maybe updates a frame every minute or two afterwards. I've reported it to DComplex but other than 'we're looking into it' haven't heard anything back.

     

    Watching the stream directly via the camera's web pages in Safari also has the same issue after several seconds. It does seem to work if you watch the stream in Chrome or Firefox though.

     

    Unfortunately I haven't found a solution either to the timeouts.

  • pki730 Level 1 (0 points)

    I spent an hour on the phone with Apple Tech support. They were polite as always but couldn't resolve the problem.  What I found disconcerting was that at the conclusion of the conversation I suggested that they reach out to the developer of the IP camera software, put their heads together, and perhaps that would speed a resolution.  The response was, "we don't reach out to developers." If Apple doesn't have a willingness to work with its app developers who know the video programming issues perhaps better than they, I don't know how they expect to resolve this issue.  Very disappointing.

  • dangobot Level 1 (100 points)

    same here. i use an axis cam and it stalls after 5 seconds in safari. i was able to get it to work again by changing from motion jpeg to java, but then i can't view it on my iPhone anymore.

  • pki730 Level 1 (0 points)

    I am glad I'm not the only one with this problem. I hope enough people bring the same problem to Apple's attention so it gets the appropriate attention on the bug fix list.

  • digitalsweater Level 1 (0 points)

    Same problem here with 2 Axis 207W cameras and the Axis DNS service.Cameras stop after 4 seconds.

  • jjason000 Level 1 (0 points)

    Same problem here with an EasyN IP camera.  Worked perfectly under Lion and Safari 5 but with the upgrade to Mountain Lion and Safari 6, the video feed times out after about 2-3 seconds.

     

    I played around with the Timeline Recording feature of Safari and the issue seems to be with the way Safari now handles the cgi script that feeds the video.  I can't see any error messages being thrown either -- so this is one of those silent failures that makes it difficult to diagnose ... 

  • mayavirupa333 Level 1 (10 points)

    Same issue with Foscam 8910W, worked perfectly till 10.8. Cameras stop after few secs.

  • mayavirupa333 Level 1 (10 points)

    ...but my Foscam does work in Chrome, so it is apparently a Safari issue, and, it seems, an IP Viewer issue.

  • Mac Fanatic Level 1 (115 points)

    If you have and iDevice you can still use the Foscam thru an app.

     

    i use the CamViewer and Baby Monitor apps on the iPhone 4s.

  • malincal Level 1 (5 points)

    Same here,  Axis camera.  Hangs in Safari, but found it works on Firefox.

  • mgb99 Level 1 (0 points)

    I'm having the same problem with both my Vivotek wired network camera and Panasonic wireless network cameras. At first I thought this was an issue with the video framework in Mountain Lion, but if Firefox is working (I haven't tried it yet), it sounds like it may be an objective-c video library that has been changed. It's possible Firefox is using an objective-c interface that calls an objective-c function that isn't called by Safari or IP Camera Viewer, etc., (possibly a function that is on its way to be deprecated) or Firefox could use it's own library that directly calls the video framework.

     

    Could be the Mountain Lion objective-c framework has a buffering issue.

     

    Since this is occuring in both 3rd party software and Apple software, it sounds like it's an Apple issue. 3rd party applications typically utilize the Apple Developer objective-c frameworks to access video frameworks/libraries (for example, MJPEG). Thus, contacting 3rd party developers may not solve the situation (unless they can figure out a temporary bandaid--possibly figuring out the video framework call that Firefox uses and patching their software to do the same (not a simple task), but could still provide more feedback to Apple via their developer status.

     

    Has anyone attempted to record from their cameras via iMovie or Final Cut Pro X HD? I will try mine later tonight to see if it records the hanging. If it does, then it's looking more and more like Apple's the culprit.

     

    My suggestion is for everyone to file a bug report via http://www.apple.com/feedback/macosx.html

  • mattrixx Level 3 (940 points)

    same here... Safari stops, but Firefox fine!

  • mgb99 Level 1 (0 points)

    "Has anyone attempted to record from their cameras via iMovie or Final Cut Pro X HD? I will try mine later tonight to see if it records the hanging."

     

    My bad. Work was busy and boy was I not thinking since iMovie and Final Cut Pro X HD don't record network cameras. Disregard that comment, but the rest is accurate.

     

    Also, FireFox doesn't work with my networked Panasonic BL-C230A. However, it seems to be the browser page created by the camera, not the video streaming, as it is hanging even before the page is fully loaded (no streaming data received yet).

  • mgb99 Level 1 (0 points)

    Just tried SecuritySpy and it's buffering fine, not hanging...

Previous 1 2 3 Next