Previous 1 2 Next 24 Replies Latest reply: Nov 22, 2015 1:41 PM by Tim Farnan
Switchwa Level 1 (0 points)

Hey guys,


I upgraded to Mountain Lion on the first day and immediately i noticed an issue with my mouse.


When I single click my mouse it frequently double clicks and is ****ing frustrating!! I use my mouse for work as a graphic designer and im a very fast worker - with this issue my productivity has nearly dropped a third.


I use a Logitech Performance MX mouse, but have also tried it on my standard (new / was unopened) Apple mouse that came with my iMac.


I have also tried altering the double click speed in the system preferences but the issue keeps repeating.


if ANYONE can help me i would very grateful as if this continues i could potentially lose my job.

iMac (21.5-inch Mid 2010), OS X Mountain Lion
  • TheSmokeMonster Level 4 (3,230 points)

    You need to reset you PRAM


    Resetting PRAM and NVRAM

    1. Shut down the computer.
    2. Locate the following keys on the keyboard: Command, Option, P, and R. You will need to hold these keys down simultaneously in step 4.
    3. Turn on the computer.
    4. Press and hold the Command-Option-P-R keys. You must press this key combination before the gray screen appears.
    5. Hold the keys down until the computer restarts and you hear the startup sound for the second time.
    6. Release the keys.
  • captfred Level 7 (26,290 points)

    .  Edit: misread the issue.

  • Switchwa Level 1 (0 points)

    hey Smoke Monster - i already did that twice last week but to no avail thanks anyway.

  • captfred Level 7 (26,290 points)

    It sounds like you have the double click speed set to low.  Go to System Preferences > Accessibility > Mouse & Trackpad on list to left > move the Double-click speed slider to a faster setting.

  • Switchwa Level 1 (0 points)

    thanks Captfred but as i mentioned i've already played with the double click settings.

  • Dave Z Level 1 (60 points)

    A couple thoughts that come to mind:


    1. Check the Accessibility settings in System Preferences. Perhaps there's an option in there that is causing this. Not just track speed, but other options that are there to ease use for physically disabled or challenged users (sorry if that's not the P.C. way of saying it).


    2. Try creating a new user on the system, if the issue does not exist there, it's probably a corrupt plist file on your profile.

  • NeverFollows Level 1 (0 points)

    I would add that I have the same problem with my mouse.


    The double click is not working, which is very annoying.


    I cannot select a whole word inside a text.

    I need to move the mouse over it while clicking on it.


    I cannot launch an application such as opening a file with an editor.

    I need to Right click and select Open.


    I tried many things. I reinstalled twice ML, on a clean disk.




    I have a similar problem using the trackpad.


    To open a file, I need to select the icon, not the file name,

    and then click the icon with the bottom right corner.

    This does not work very smoothly, I have to try several time.


    Note: I have a late 2011 MacBook Pro 17"

  • NeverFollows Level 1 (0 points)

    Note: when I put back the original 10.7 Lion disk everything is normal.

    So this is not a problem with the PRAM and NVRAM.

  • kthulhu Level 1 (0 points)

    I have the same problem with single clicks occasionally regestering as double clicks.  I also use a Logitech mouse, so I thought perhaps the Logitech drivers were the culprit.  It looks like they are.  When I removed the Logitech Control Center from my computer (the uninstaller was located at /Applications/Utilities/LCC Uninstaller), the problem dissapeared.  When I reinstalled the software, the problem returned.  So now until Apple or Logitech issues an update that fixes the problem I guess it's a choice between losing our programmible mouse buttons, or dealing with random unexpected double clicks.

  • iaian7 Level 1 (0 points)

    I've never installed the Logitech Control Centre, and the constant mouse click issue is so bad, I can't edit text, I can't move files, I can't even move windows without everything going awry.


    I'm using wireless Logitech mice on a Mac Pro (at work) and an iMac (at home), both running OSX 10.8.2.


    I've tried changing my double-click settings (no change), I've killed Better Touch Tool (the only mouse utitity I had installed, no change), I've run through system wide cleaning, repair and cache clearing via Onyx (still no change), rebooting makes no difference, and my computers are barely usable.


    What in the world is going on?!

  • Raúl Campuzano Level 1 (0 points)

    I've found this page to Logitech which mentions a malfunction of mouse with "Lion Mountain" and Adobe applications.

    I've done two tests. An Apple mouse with very satisfactory result. And I downloaded this driver from Logitech. with a satisfactory result.

    I hope something works!

  • greysonr Level 1 (0 points)

    This is not a logitech only issue. I'm experiencing the same thing with my Razer DeathAdder 3.5g. Has any additional knowledge on this come to light? Thanks! Greyson

  • tommytboner Level 1 (0 points)

    I've just upgraded and i'm gettign the same issue but with the Magic mouse! Anyone found a solution yet?

  • Tom_V Level 1 (0 points)

    I have the same maddening problem with my Apple mouse. It thinks a single click is a double click, which makes it hard to even select a file in Finder without the file opening, or to check a box (the instant double click unclicks the box). I can barely use the computer - I spend more time waiting for programs to open and closing windows that I don't want open. Menus pop open but instantly close.


    I've been using Macs for 25 years, and this level of productivity brings me back to the days of my 8mHz Macintosh Plus - only this is more frustrating.


    I have my system pref setting all the way to slow. It makes no difference whatsoever.


    I'm using OS 10.6.8 (I have no idea if that is Mountain Lion, Sea Lion, Goat Lion, Snow Tiger, or what). Why does Apple refer to the OS as an animal, but then label the OS in the computer (ie "About This Mac") by number. Why do I have to look up what number Mountain Lion - or cross reference what animal my OS number is? << Sorry wrong thread.


    I'm using an Apple mouse that says it is "Mouse". It has a clear top, white guts, no ball or button, perhaps it has invisible button areas, but I have no idea how to adjust or determine what they do or where they are. I suppose I should know what model the mouse is, but why should I have to surf the web to find out? Is it a mouse, mighty mouse, apple mouse, ultra mouse, magic mouse, mouse mouse? APPLE! Please give future mice (mouses?) a unique name or number - and print it on the hardware. My mouse and keyboard are wired. I'm getting wired too trying to fix this.




    Just typing this message is a pain. The mouse selects words when all I want to do is place the cursor.

Previous 1 2 Next