Previous 1 2 3 Next 39 Replies Latest reply: Aug 19, 2015 2:21 AM by Maxvale
kelly.davies Level 1 Level 1

When I first installed Mountain Lion, the menu bar had the normal icons - BlueTooth, Time Machine, Clock, etc. Now on the day after, all of these icons are missing and any attempt to re-add them using the System Preferneces results in a spinning cursor for a few seconds and then the menu bar icon preference turning itself off.


Other system preferences seem to work fine.


I have already run a repair on disk permissions so that does not seem to be the issue.

OS X Mountain Lion
  • c warren Level 1 Level 1

    I have had the same problem; in addition, some of my favorites - Menu Meters and Application Switcher Menu behave the same way - so both Apple menu bar and 3rd party icons are not behaving.  The problem did not occur until I installed the OS 10.8.2 update.  When the problem ocurred, I:


    1.  Ensured that my system preferences in "Secutity and Privacy" were set to allow any applications. 


    2.  Ensured that the "display icons" in each item I wanted were set to do so; this often resulted in a prolonged spinning beach ball before the setting would finish.


    3.  Eliminated all old system preference panes I had been using - Growl, Microsoft Keyboard (part of anold Intellipoint installation) and others, and ensured I had the latest versions of Menu Meters and ASM.


    4. Installed the latest Microsoft Mouse preference pane because I use a Microsoft Trackball Explorer. 


    5. Removed and reinstalled all current 3rd party preferece panes (something that had worked for much earlier OS 10 updates). 


    6. Ran "Preferential Treatment" and removed two corrupted preferences (they were not preference panes).


    7.  Removed old startup items.


    8. Downloaded the OS 10.8.2 combo update, and reinstalled it.


    9.  Repaired permissions in Disc Utility.


    Now, the menu bar items load properly on about 1 of 3 startups.  The startup sequence seems to fiffer.  Sometimes, I get the arrowhead for the cursor immediately once I have entered my security code, and the desktop will appear all at once, with my walpaper, the finder open, and all menu bar icons displayed.


    Sometimes I get a spinning beach ball instead of a cursor arow, and the desktop and finder load very slowly - usually without the icons.  Often, the Spotlight icon will appear and disappear.


    Sometimes I get the cursor, then the wallpaper and menu bar, then the hard drives I always dislay - there is a delay while the HD data comes up; then the dock - and sometimes I then get the menu bar icons, but usually not.


    These different behaviors occur without my making changes from startup to startup.


    I hope someone can help.

  • LousyFool Level 4 Level 4

    IMHO, point #3 is the most crucial: Get the latest ML-compatible (!!!) software versions!


    So many people here upgrade their OS, but keep using old SW versions and are then surprised if something doesn't work as before... oh well...

  • c warren Level 1 Level 1

    While I agree that discarding old software is important, in the matter of the menu bars, I do't think it was the problem - and I may (repeat, may) have the problem solved.


    When I originally installed Mountain Lion, I ran "Repair disk permissions" in Disk Utility.  I did not have the problem in 10.8.0 or 10.8.1.  It is only when I installed the 10.8.2 update that the problem occurred.


    I ran the steps 1-8 above, and none of them fixed it.  Having run repair permissions (again) after the re-installation of the 10.8.2 combo updater, the problem seems to be solved.


    Running "Repair Disk Permissions" before and after an update is extremely basic.  I do it routinely, and hope I didn't neglect the step after installing the initial 10.8.2 update.  Since reinstalling 10.8.2 and running repair permissions,  I have had four successful startups, and the problem may be solved.  I hope.

  • LousyFool Level 4 Level 4

    It does not hurt repairing permissions, even though since a few OS X versions this is done automatically during the installation of a new system.

    But for the 3rd-party (non-Apple) apps and preference panes you are referring to it is meaningless: repairing permissions affects only Apple apps and the files written on disk by their installers. More info.


    So, while repairing permissions might help for native Apple icons in the menu bar, it would not help e.g. MenuMeters and others, whatever caused all their vanishing or "not behaving". No surprise if kelly.davies saw no improvement after permission repair, and most likely only coincidence if c warren did see improvement around the same time. Both of you must have some other - not necessarily the sam - issues with your systems. Any other, possibly outdated, "tinker programs" running when things turned strange?

  • c warren Level 1 Level 1

    Of course, it was both Apple and non-Apple menu bar items that were not showing; and since this morning, when the problem was still showing up, and this afternoon, when it is no longer, the only change I have made is repairing permissions.


    I had removed other programs (including one that generated a network scanner icon in the menu bar), but the problem continued.  I removed several startup items for programs I no longer use - but again, the problem continued. 


    Regarding "tinker" programs, I removed Onyx, which is compatible with OSX only through 10.7. Cocktail, which I use, is current, as is TinkerTool.  Flip 4 Mac, showing as a preference pane, is current (v 3.0) and is still present.  The same is true for the CNET Tech Tracker preference pane, which generates a menu bar icon.  Thise are the only "tinker" programs i use. - but the icons are loading properly despite their presence.


    The Sophos antivirus software I use used to generate a menu bar icon, and no longer does.  Hmmmm.

  • LousyFool Level 4 Level 4

    Jeeez, with the number of "helper" apps you've been using, I wonder if you're really helped...

    You've been employing a large number of 3rd-party apps, most of which dig into your system. Which becomes a more or less huge problem latest in case of a system upgrade, obviously. Sometimes less is more...


    I can only hope that "removal" was complete, and that you're learning from it. The programmers of these small or large apps are having fun and might even mean it well, but their products aren't always that "clean"... caution!

  • c warren Level 1 Level 1

    The "helper" apps do in fact provide functionaity that Apple does not.  Yes, they can cause problems in an upgrade.  But -


    ASM restores the nifty way one can quickly change applications, harking back to OS 9 - so you don't have to scroll through the dock.  I have a large monitor; ASM makes it much easier than covering a lot of screen real estate.


    Tech Tracker keeps my applications up to date, and deals with non-Apple apps as well. 


    TinkerTool provides easy access to the interface without having to make changes in the Terminal.


    Flip4Mac of course lets me view WMV files, which some news sites insist on using for their videos.


    And Sophos has done a better job of catching viruses in email attachments than anything else Apple has provided.  My friends who operate Windows machines particularly appreciate it.


    Menu Meters lets me know my processor usage and available memory - while I have 6GB of RAM, still, I can run short when working in Photoshop.  It tells me immediately if there are incoming or outgoing transmissions - helpful if I wan't making them - especially if my drives are reading or writing as they happen.  And they help me see the speed of my uploads and downloads - perhaps not vitally necessary, but I like them.


    Microsoft Mouse lets me use a trackball that is far more useful and far superior to any of Apple's "mice" or its trackpad.  I have 2 more in storage if this one ever wears out.


    I am not surprised that some applications no longer work with the upgrade to Mountain Lion, despite the fact they all worked with Lion.  They caused no conflicy problems in Mountain Lion v. 10.8.0 and 8.1 (though Onyx and Cocktail don't work with Mountain Lion and are both gone now) - and began showing problems only with10.8.2.


    And yes, I use software to get rid of all the components of an app that I discard, so it wasn't "leftover" components causing the conflict.


    In fact, I find myself wishing I had stayed with Lion.  Mountain Lion's Notification Center is OK but not necessary.  I hate the new email headers, and the unified search/URL bar in Safari is crap.  I miss the scroll arrows and the ability (via "helper apps" like Cocktail that worked with Lion but are no longer compatible) to place them together at the top & bottom of a window.  For all the touted "improvements" in Mountain Lion, it has not been worth either the money or the headaches.


    So what I have "learned" is perhaps Apple's direction in its OS is not serving my needs, and I should just stay where I am.  And I speak as someone who started with Apple back with System 5.


    OS 10 offers significant technical advances over OS 9, it is very true - I am well aware of them.  But Apple's failure to recognize some of the best user interface features when it jettisoned OS 9 was bad.  The "tinker" apps go a long way toward making up for that.  I'll keep them, thanks.


    And as far as I know, it was still the reinstalling of the OS10.8.2 combo updater downloaded from the Apple site (not the App store), and running permissions repair after, that fixed the problem.  The other steps did not, so I do not believe they were the cause of the conflict.

  • macjack Level 9 Level 9

    It could be SystemUIServer which is a background process that specifically controls the right hand side of the menu bar where those menu extras are. This process should return it to default. Then add back what you like.


    Go to your Finder "Go" menu hold the option key to choose "Library". Then go to the Preferences folder and find and delete Then go to the By Host folder also inside your Preferences folder and delete (also any with numbers). Then log out and back in, or restart.

  • c warren Level 1 Level 1

    Thank you, macjack - that is a useful approach.  Right now all of my menu bar items are loading properly, but rest assured, this is the first thing I'll try if they fail again.


    In particular I'd like to be able to go to "Mac App Store and identified developers" for security settings.  Perhaps that will help to get there.

  • LousyFool Level 4 Level 4

    Thanks for advertising those apps!

    3 of them I'm using myself, well, part of them, and only if a compatible version is out. And no problem at all.


    The MS Mouse driver could be a big problem, at least it was on my wife's MBP after switching to ML. No ML version available, but then no more trouble once removed and back to external Apple trackpad.


    I hate the new email headers, and the unified search/URL bar in Safari is crap.  I miss the scroll arrows and the ability (via "helper apps" that worked with Lion but are no longer compatible) to place them together at the top & bottom of a window.  For all the touted "improvements" in Mountain Lion, it has not been worth either the money or the headaches.

    Most UI features were already present in Lion, with Safari having been an independent update. Anyway, some like it, some don't, some have problems, some don't... one can't be everyone's darling.


    Good luck then, and maybe more here at a different opportunity.

  • c warren Level 1 Level 1

    Well, I just returned my security settings to "Mac App Store and Identified developers" and the menu bar items load properly.  All is good, in that regard.  Thanks again, macjack.


    Lousyfool, the latest Microsoft Mouse driver (ver. 8.2) isn't a problem in Mountain Lion, at least on my Mac Pro. Now, the Microsoft Keyboard driver, dated 2005 (part of the old Intellipoint software) may have been one, but I discarded it.


    Yes, I had read of the changes in Safari, and delayed updating it until installing Mountan Lion (last week; the delay was to be CERTAIN Quicken 2007 for Lion would work with ML).

  • c warren Level 1 Level 1

    As things progresed, I was getting the full suite of menu bar items only on abour 2 of three starts.  If they did not show, a restart would usually get the menu items.  Also, when they did not show, the Spotlight icon would blink on and off at slow intervals.  The Notifications icon was always present.  The Time machine, volume, Bluetooth, keyboard and clock icons would sometimes be missing, and would sometimes load, when ASM and Menu Meters did not load.


    So, I changed my security settings back to permitting apps from anywhere; same result.  Time for macjack's approach.


    The only surprise is that when I went to the "By Host" folder to delete plist files, there was not just one "" (with numbers) but three.  I trashed them all, and the same one (which had no numbers) in the "Preferences" folder.  On restart, as I expected, some of the 3d party menu items (Menu Meters and ASM) did not load.  I suspected that the "show icon in menu" box had been unchecked by trashing the plists.  They came up immediately when I re-checked the boxes in System Prefs.


    There is also a "" in the Preferences folder.  I have not touched it.


    I left the security settings for "Mac app store and identified developers" and restarted - and the ASM and Menu Meters icons did not come up.  Tech Tracker and Sophos, and some of the Apple icons did.  I went back to the System Prefs, and they stalled whenever I checked a "show icon" box for the missing icons.  So I restarted, and went to security prefs, allowed apps from anywhere, and restarted.  When I rechecked the "show icon" boxes for ASM and Menu Meters, the icons once again showed.  They have continued to show now after several restarts.


    After each restart I checked the plists in the Prefs folder and By Host folder.  The regenerated itself in the Prefs folder; none of those in the By Host folder have regenerated.


    I will keep watching and report.

  • c warren Level 1 Level 1

    Just a confirmation:  macjack's approach is the one that solved the problem.  After using it, with the security settings allowing apps from anywhere, I had about a dozen good startups in a row.


    This morning, as an experiment, I reset the security settings to allow only apps from the App store and identified developers.  The problem immediately recurred on restart - 3rd party app icons and many Apple icons missing again.  The computer would hang (spinning beach ball) when I made settings changes inn the preference panes to try to display the missing icons.  Once it completely froze wjen I simply tried to unlock the security settings - I had to shut down with the power button.


    After again removing the items described by macjack, and restarting, I was able to reset security settings to allow apps from anywhere.  Then, after restarting again, I was able to re-check the "show icon" boxes for the missing icons, and all showed.


    Problem solved.


    This morning I received notice from one developer that he had gotten a security certificate so that he would now be an "identified developer."  I suspect that more will folow suit.

  • dabeenk Level 1 Level 1

    C warren, yours and macjack's fixes for missing menu bar icons were most helpful. Thanks!

Previous 1 2 3 Next