Previous 1 2 Next 25 Replies Latest reply: Sep 27, 2013 6:06 AM by scottsandford Go to original post
  • philipc121 Level 1 (0 points)

    Hmmm, I must have a very odd problem. I don't have any third party applications on my Mac, so I don't think it's that.


    I can see the logic of these solutions, and I have tried deleting and reinstalling as you suggest, regriff, but the problem stayed. I even tried deleting the versions I had installed from the DVD (including Library files) and downloading fresh versions from the Mac App Store, but the problem remained.


    For now I have reinstalled OS X with a fresh user account and all seems well.


    I did note, however, that the problem only seemed to occur at home, and when connected to the internet. Whenever I turned Wi-Fi off, or whenever I was at work, the iWork apps opened as normal. I don't know if that sheds a light on the source of the problem at all... (NB my other half's MacBook Pro, also running Mountain Lion with iWork istalled by DVD did not have the problem, irrespective of whether it was connected to our home wi-fi netweork).



  • fruhulda Level 6 (15,120 points)

    If it works in a new user account is usually is a corrupt plist file causing the problem.

  • philipc121 Level 1 (0 points)

    Thanks fruhulda.


    I just had a look at my ~/Librarby/Preferences file, and saw only the usual .plist files for iWork. I trashed them and reloaded and the problem remained. However, when I searched my User Library for "iWork", it also found two extra "" files, neither of which showed any location in Finder, neither of which could be deleted, and neither of which could be opened. When I try to open them I get an error message: "The alias “” can’t be opened because the original item can’t be found."


    Pressing "Delete Alias" just causes the error message to reappear. I can't seem to find anything appropriate to use to "Fix Alias" either, and when I try I get another error message: "An unexpected error occurred (error code -43)."


    Does anyone know how to fix this?





  • fruhulda Level 6 (15,120 points)

    It is the plist file in  the user library I meant. You should be able to delete them, at least be able to drag them to the trash. Have you restarted you computer lately? It help sometimes.

  • philipc121 Level 1 (0 points)

    Yeah I meant the user library too. I turn my Mac off every night...

  • forMAC Level 1 (0 points)

    I had the same problem.


    This solved everything in my case:


    1. Delete all iwork applications
    2. Delete the iWork '09 folder at: Macintosh HD/Library/Application Support/iWork '09
    3. Empty the trashbin
    4. Restart
    5. Run Software Update and install iWork update BEFORE opening any apps
    6. Voila, it works…
  • drdan711 Level 1 (0 points)

    SOLUTION:  The object is to get an update FROM THE APP STORE.  I finally simply deleted Numbers, Pages, Keynote, AND the iWork 09 folder.


    I then installed iWork 09 from the DVD.  I immediately went to the App Store, clicked on "Updates", they loaded and problem solved.


    ATTEMPTS THAT DIDN'T WORK:  Most severed, the Apple Store genius bar geek told me I should reformat my hard drive, download a new copy of Mountain Lion and start over from scratch.  I had just done this a month before and I wouldn't go throught that again even though I was minutes away from trying it.  288 Gigs is a lot to fool with.


    I deleted, uninstalled and re installed iWork over a dozen times, each time updating from the Apple>Software Update menu.  I used TechTool Pro, MacKeeper and Spring Cleaning to wipe iWorks fromthe computer.  Nothing worked until I reinstalled a fres copy of iWork from the DVD and IMMEDIATELY updated from the App Store.  What a relief!

  • fruhulda Level 6 (15,120 points)

    In this forum I don't think reformatting the HD has been proposed as an solution, eps. not after snow Leopard as it can be installed on top of preexisting system. Seems very PC to me. Deleting iWork is often a good solution. You just have to know where all files are stored. That i proposed many times in this forum

  • PeterBreis0807 Level 7 (34,577 points)

    That Apple Store "Genius" should have his T-Shirt ceremoniously ripped off his back before being thrown out of the store.



  • esteban_marco Level 1 (0 points)

    Desinstaller I WORK  9 et  reinstaller puis mise a jour immediate sur Apple store mise a jour...

    Was the good solution !


  • scottsandford Level 1 (0 points)

    FWIW, I was having real problems with launching any iWork apps - Pages and Numbers in particular.  After searching around for a solution, I stumbled accross this one that did the trick for me:



    Bascially, "Ubiquity" (aka iCloud) was causing problems.  I moved the ~/Library/Application Support/Ubiquity folder to the desktop (in case there was a problem) and then launched the programme again.  Whatever was in there before was probably corrupted and once it repopulated the folder with new entries, Pages and Numbers started normally.


    Hope that helps.


    here is the part from that article that helped me from Ric:



    Fix: Delete ~/Library/Application Support/Ubiquity/



    We have this issue here and I recently read about iCloud's new (10.7.2) Ubiquity having problems when it's installed (permissions, in some cases). In my tests, Keychain Access would often hang when I tried to start it and I noted several "ubiquity" certificate entries with errors in the DB.

    This is the step-by-step fix that I gave our help desk people. It fixed the wireless authentication issue on several machines running 10.7.2. The Aruba authentication screen usually will now appear (via native Webkit) shortly after startup/wake-up:

    • In the Finder, hold down the Option key and, in the Go menu, select Library (in Lion, the folder is hidden unless you hold down Option)
    • In the Library folder, open the Application Support folder--it is probably the second in the list
    • Have the student press the "U" key (to get them in the neighborhood) and scroll down to find the Ubiquity folder
    • Drag the Ubiquity folder to either the Desktop or the Trash (if all goes well, it can be deleted)
    • Restart the computer and test the connection



    This is the Macworld article that inspired the above solution.


    FYI: found out about this forum thanks to a link in a MacRumors forum thread.

Previous 1 2 Next