Previous 1 2 3 Next 31 Replies Latest reply: Jul 17, 2013 6:41 PM by dinesy Go to original post
  • GBCYVR Level 1 (0 points)

    Thanks, that fixed the problem.

  • terriergal Level 1 (10 points)

    I already had it too, we have discs that we had since it came out... don't tell me you have to now RE purchase it from the app store??

  • ablinkin Level 1 (0 points)

    terriergal, I did NOT have to purchase the apps from the app store..I was able to correct it using the steps in my earlier post. I also manage a network of macs ~20 of them and i had to do this on several of them and it worked quite well...Did you try those steps out?

     

    "I have managed to fix this problem on my MBP. I deleted iwork 09 from /Applications deleted the plist files that started with com.apple.iWork. from /users/myusername/Library/Preferences

    Deleted the iwork09 folder from /Library/Application Support

    Reinstalled iwork 09

    Installed the hotfix from here http://support.apple.com/kb/DL1563"

  • terriergal Level 1 (10 points)

    I did everything but trash the application support Iwork09 folder, as I was reading another thread and that didn't come up as part of the solution.  I also did not think of /Library/Application Support being a different Library folder from /users/myusername/Library

     

    Since I didn't see it, I figured it had been deleted along with the other stuff by AppDelete.

  • fruhulda Level 6 (15,120 points)

    terriergal - there are three different Libraries on the computer

    1) MacHD > Library

    2) Users > your name > Library   -  To find this one you have in Lion an Mountain Lion press the option key and click on Go in the Finder menu

    3) MacHD > System > Library

  • fleurdetoile Level 1 (0 points)

    ablinkin, I too am having trouble using iWork on my new MacBook Pro. I am trying to follow your advice but don't know how to delete from users/[myusername]/library/preferences.

     

    Also, for reinstalling it, do we need to have the original disk? (I think I might have just downloaded this software - not from the App Store. In that case, how does one reinstall?

     

    Frustrated...

  • ablinkin Level 1 (0 points)

    fleurdetoile, to delete those files you need to

    1-open a new finder window

    2-Click Go (from the tool bar at the top of the screen)

    3-Click Go To Folder

    4-Type /users/replace_me_with_your_username/library/preferences in the folder

     

    If you dont have the disk you will need the image you downloaded and used to install the software. If you dont have that, you are not going to have much luck. You can try to copy the application files from /Applications/ by copying /Applications/iWork 09 to an external drive or other folder ...then copy them back later....might work..dunno since i have not tried it.

     

    hope that helps

  • ahmad saif Level 1 (0 points)

    Thank you ablinkin,

     

    this was just the right answer I was looking for!

  • gnuauhtis Level 1 (0 points)

    Dear ablinkin,

    I have trial .dmg and key. it worked on my snow leopard... but for mountain lion it didn't. I followed everything you've been told... and I did them 4 times in a row and still not working... I deleted all the files and directories which you mentioned... and reinstall iWork, put key, and update to 4.2... but unfortunately, still not working after 4th try... any other solution(s)?????

    thx..

  • fruhulda Level 6 (15,120 points)

    If you still have Apple care ask them to help.

  • traceInNY Level 1 (0 points)

    thanks Kevyboy014 you rock.

    this totally did the trick and only took 1 minute! (the other suggestions were to do a clean install of the app which would have been much more work).

  • fruhulda Level 6 (15,120 points)

    So what did you do?

  • traceInNY Level 1 (0 points)

    Sorry I messed up. I meant to say thanks to philipc121 as it was his solution!

     

    "creating a new user account, logging into it, opened Pages (no problems there) and logging out of the new account again. I then logged back into my own account and iWork applications all launched no problems"

     

    In my case, it was keynote which wasnt working, so I followed the same instructions for keynote and it worked perfectly.

  • fruhulda Level 6 (15,120 points)

    Thank you! I had missed philipc121 answer earlier in the post. It is the first time that doing this would help. If it works in a another user account it usually means that the Pages plist file in the original account has to be deleted.

  • traceInNY Level 1 (0 points)

    you're welcome I hope it works!