Previous 1 2 3 Next 40 Replies Latest reply: Nov 13, 2013 4:06 AM by John Cogdell Go to original post
  • Sam667766 Level 1 Level 1 (0 points)

    The problem goes back some time. The only version that works fine is 8.0.6

    All other versions have the time and date issue. If the time is out it will change the date.

     

    In the Event Library the time is correct and when a Project is created the time is changed.

     

    It would be great if this was fixed ASAP.

  • Sam667766 Level 1 Level 1 (0 points)

    If you need to import AVCHD on version 8.0.6

     

    First have both 8.0.6 and the latest version on your computer.

    Open the latest version and import the video into Events Library.

    Close that version.

    Open 8.0.6 and it will open all the Events Library

    Now create your Project.

  • K2cool Level 1 Level 1 (0 points)

    Hey all,

     

    Found a way to fix it. Please go to the "Open Date & Time Preferences," open the "Date & Time" tab, make sure that the box "Set date & time automatically: Apple America/U.S. (time.apple.com)" is checked.

     

    Then go to the "Time Zone" tab, unchecked the box "Set time zone automatically using current location," then set it manuallyby dragging the blue bullet to area near US, San Francisco, however, you will need to pick any area that the time is +1 hour from San Francisco time. For instance, if SF time is 12:00, then you will need to pick an area near SF that the time is 13:00. I picked Salt Lake City in this example.

     

    Once you have done this, your iMovie time stamp should be correct. It seems that the time in the iMovie is linked to the Apple Time.

     

    Hope that help guys.

     

    K2

  • K2cool Level 1 Level 1 (0 points)

    Some additional info. iMovie somehow regarded the time in your original clip, as the same time as "Apple's time", which is in Cupertino, California. Hence, if you lived in a city which has a time of +3 from Apple's time, Cupertino, then iMovie will automatically adjust the time stamp in your iMovie project to +3 from the original time in your clip.

     

    K2

  • jsa_ny Level 1 Level 1 (0 points)

    Am I the only one who finds this to be ridiculous?  For two years, we've had to jump through hoops installing earlier versions or workaround like is mentioned above. We've seen multiple revisions of the product with no fix.  I think we're being ignored, with no explanation why.  I'm about to abandon iMovie entirely.

     

    Clips have TIME CODE.  That time is the time that should be represented in any time/date function of the software.  I don't want to trick my software into getting it right.

  • paulapp Level 1 Level 1 (0 points)

    Nope, you are not alone jsa_ny. It is sad, ridiculous, infuriating, obnoxcious.

     

    I know a little about software dev and I think when 8.8 (version after 8.6) was released, someone made a mistake and left out a few lines of code that takes care of time conversion in iMovie.

     

    For a company that boasts of having billions and billions of dollars in cash in bank, this is pretty sad. Apple should take note iEverything took off because of Mac users. And now they seem to treat everything non-iSomething as second class citizen in their resource allocation.

     

    I am hoping for a fix in next iMovie patch but somehow I have this fear that this bug will be fixed only with the next pay-for upgrade.

  • MP409 Level 1 Level 1 (0 points)

    Hi All.

     

    I have no idea why or how but I seem to have solved my Date and Time Problem.  (sort of)

     

    I have tried everything possible but always had at least 1 hour difference between my camera date (file creation date) and the display on iMovie.

     

    In "System"...."Date and Time"...."Time Zone"... I unticked "Set Time Zone Automatically" and told my computer I was living happily in London.  (I'm actually in sunny Sydney, Oz). 

     

    Now, my video date and time are spot on BUT...can anyone tell me what other problemns I might encounter?  I have checked my Diary, Reminders, Alarms, File Creation Dates, Still Photo Dates.... etc etc etc and everything is ok.  Should I leave the setting on "London" or only when using iMovie?

     

    PS.  I'm sure this will work for others but where you are and where you tell iMovie you are may vary.  Just tinker.

     

    Good Luck.

  • paulapp Level 1 Level 1 (0 points)

    Someone else earlier in the thread reported 'fixing' the time stamp issue with similar method as yours. IMO, that's not reall a fix.

     

     

    This bug is easily reproducible, hence should be easy to fix.

     

    I am puzzled by the inaction on this bug by apple.

  • MP409 Level 1 Level 1 (0 points)

    Yes, I agree with your point. I should have used the term "workaround" rather than "fix", hence the added (sort of). I am just happy to be able to get back to work. I think Apple need to realize not all people use this software for home movies, some of us need it to run our businesses and the consequences can be dire. This has been a problem for a long time and frankly, i don't think Apple are even working on a solution.

  • jsa_ny Level 1 Level 1 (0 points)

    This is absolutely maddening.  In some areas, I'm impressed with Apple support.  This is not one of those areas.  For years now we continue to report this problem, and we don't even get a "we're working on it."

  • John Cogdell Level 5 Level 5 (4,605 points)

    The Date/Time Title now works correctly in the new iMovie 10, running under Mavericks (OS X 10.9). Of course, this does not help those using iMovie '11 (version 9.0.9).

     

    John

Previous 1 2 3 Next