7 Replies Latest reply: Jul 30, 2012 8:54 AM by g_pirtle
Anonymoe Level 1 Level 1 (0 points)

I performed a Mountain Lion upgrade on a 2011 MBP running Lion this weekend. The Mac may have been set up to connect to an AD server with my user account, but I thought I had disabled that months ago... aparently not. I performed the upgrade at home not on the corporate network.

 

On first bootup after the Mountain Lion upgrade I'm stuck at the login screen unable to login with my local account or the admin account. I get the "red dot" next to the username field with the "Network accounts are unavailable" pop up. I'm plugged in to the ethernet network at work now... no luck.

 

I tried booting into the repair disk and repairing disk permissions. Still no luck.

 

Any ideas? I'd happily do a fresh install but I need to get a handful of files off the machine first.


MacBook Pro, OS X Mountain Lion
  • g_pirtle Level 1 Level 1 (40 points)

    Your local accounts should work whether you are on a network or not.

     

    I'm going to ask some basic questions (just skip over if you have already tried it).

     

    Have you tried using the shortname for your user accounts?

     

    Was your network account setup to be a mobile account? (stored offline cache on the MBP)

     

    Try:

    Boot MBP with ethernet cable plugged up and give the login screen ample time to connect before typing in network username and password. Sometimes it can be slow to show network accounts available.

     

    We use Active Directory integrated Macs so feel free to ask any questions.

  • Anonymoe Level 1 Level 1 (0 points)

    No worries with the basic questions... it's important to cover all the bases. Thanks so much for the input.

     

    - I'm trying to log in with the same username I would use to ssh in... so yes.

     

    - I don't know if the account was a mobile account. The Mac was given to me configured about a year ago, configured to be on the domain. I since have used it on and off many networks without considering it was set up to be on a domain.

     

    - Never had a problem logging into the machine before the mountain lion install, although to be honest it was very very rarely ever rebooted.

     

    - I've plugged it into ethernet and let it sit for quite some time. It's still telling me Network accounts are unavailable and I'm unable to login with my personal or admin account.

  • g_pirtle Level 1 Level 1 (40 points)

    If at any time you want to abandon troubleshooting, you can always copy the files you want to keep from /Volume/Macintosh HD/... to /Volume/USBKeyName/... using Terminal from the Recovery Partition.

     

    Copy command syntax - http://ss64.com/osx/cp.html

     

    Ex. cp -R "/Volumes/Macintosh HD/Users/username/Documents/" "/Volumes/USBKeyName/Documents"

    -R to copy entire directory contents

     

    I did not experience this issue on either of my Macs upgrade from Lion to Mountain Lion (that were bound to AD), but I am still looking into it.

  • Anonymoe Level 1 Level 1 (0 points)

    I was considering using target disk mode with a firewire cable to retrieve the files but it will be a few days until I have access to a Mac with Firewire. The terminal tip to copy documents to a USB drive is a better alternative, I will give that a shot if I'm unable to get logged.

     

    Great tip, thank you.

  • g_pirtle Level 1 Level 1 (40 points)

    Try resetting the password for your local account.

     

    Boot into Recovery Partition.

    Open Terminal.

    Type resetpassword

    Select your hard drive

    Select the user account

    Enter a new password for the user

    Reenter password

    Save

  • Anonymoe Level 1 Level 1 (0 points)

    This got me in to reset the admin account. Thanks so much for the help.

     

    The really weird thing is once I've logged in as the admin account and hit System Preferences->Users & Group... I don't see my user account at all. It's not there. The /Users/{username} directory still exists... but the account disappeared. That would explain why I couldn't log in with that account.

     

    I guess I could try recreating the account, but first I'm going to get all the data I care about off the machine in case something goes terribly wrong. I suspect I'll end up with a clean install anyway.

     

    Thanks again for the help, sir.

  • g_pirtle Level 1 Level 1 (40 points)

    No problem. Glad I could help.