Previous 1 2 3 Next 105 Replies Latest reply: Aug 8, 2015 8:08 AM by afbrooks85
midorichan Level 1 Level 1 (0 points)

I have an Epson TX420W all-in-one printer, and recently upgraded to OSX Mountain Lion, after reading that I wouldn't have any issues printing after the upgrade. Before the upgrade, I had all Epson drivers up to date (through Software update).


Now when I try to print, after 'Looking up printer', this is what I see:


Screen Shot 2012-07-30 at 4.12.37 PM.png

I can't check the supplies level either.


I checked the EPSON support & drivers page, but couldn't find an updated driver for my printer (only up to 10.7.x)


Does anyone had the same experience or a workaround to this until an driver update comes out?


Thanks in advance!

MacBook, Mac OS X (10.7.1)
  • John Blanchard1 Level 5 Level 5 (5,070 points)

    Can you look in Console and tell which filter failed? The failure should be in  /var/log/cups/error_log.

  • midorichan Level 1 Level 1 (0 points)

    Hi John,


    Thanks for your help. I checked the log file and this line was the only one that didn't exit without errors:


    (/Library/Printers/EPSON/InkjetPrinter2/Filter/ /rastertoescpII) stopped with status 206 (Interface output queue is full)


    Though this morning I try to reproduce the error, and the printer worked. I suspect that adding and deleting the printer a couple of times plus restarting did the trick.


    Thanks again!

  • cozthegrov Level 1 Level 1 (0 points)

    I have the same "Filter failed" message with my Epson Stylus Photo R1800.  The error I get in console is this:


    /Library/Printers/EPSON/InkjetPrinter2/Filter/ rastertoescpII) stopped with status 206 (Interface output queue is full)


    I've reset the printing system, removed and re-installed 5x now, and it still won't print.  Any help would be greatly appreciated and there isn't a rollback or update from Epson on this driver.  I tried the Gutenprint driver and I don't get any errors but nothing prints either.





  • frevilla Level 1 Level 1 (0 points)

    Same problem, using a MacBook Air, connecting my Epson Stylus RX680 directly via USB works well, but I cannot get it to print when the printer is connected to my Win7 workstation (as it usually is) via Wi-Fi connection. Printer is shared of course, and the green light and 'idle' status seems to be ok, but there is no response from the pprinter and then I get the error message: 'Stopped - "Filter" failed'.


    Please help!

    Installing/reinstaling the printer didn't work either  

  • Dude4 Level 1 Level 1 (15 points)

    Same error here: /Library/Printers/EPSON/InkjetPrinter2/Filter/ rastertoescpII) stopped with status 206 (Interface output queue is full)

  • Ltlmn Level 1 Level 1 (5 points)

    Had same problem this morning.

    Found your solution, and get to System Preferences->Printers, and delete the printer.


    When I wanted to add it again, I did not add it from the list of "Nearby printers", I just click Add printer...

    After this (it takes several seconds to detect the printers), I could select from a normal printer and a printer with (IP) after the name: Epson SX600FW (IP).

    My printer is a network printer, and I said to give a try to IP version now. And bam, it worked.


    So check if you don't have also another type of printer to install (in my case, in the kind field, the (IP) one was: EPSON TCPIP, and the simple one: Bonjour Multifunction)

  • cozthegrov Level 1 Level 1 (0 points)

    I removed all references to Epson in the User>Library>Printers folder  and that didn't seem to help any, but finally just switched the connection from FW to USB and everything works perferctly. 

  • bennytis Level 1 Level 1 (5 points)

    i too have this same error.  same install and uninstall a number of times etc... Recently bought an epson wf-7510.  Wifi printing works fine on a windows machine but not on mac os x mountain lion!!


    I get a variety of messages, including "stopped - 'filter' failed" cannot connect to printer etc, depending on how i set the printer up.


    if anyone can help please please please post the solution here!

  • Ltlmn Level 1 Level 1 (5 points)

    Have you tried as I wrote earlier, install the printer as network printer from the list? (the name is followed by IP)

  • cozthegrov Level 1 Level 1 (0 points)

    I need to retract my earlier solution, USB is now failing with the same errors.  Tried switching back to FW and no luck.  The solution suggested by Ltlmn may work but isn't a solution but a workaround that does apply to all descriptions here including my own.

  • Ltlmn Level 1 Level 1 (5 points)

    What do you mean is not a solution, but only a workaround? What is the difference between the 2 from your point of view?


    I am sure this is the solution, because the issue is that if you use the automaticaly settings that are setup by the OS, it chooses wrongly the way of comunicating with the printer.


    Also, if WiFi printing is an issue, check for WiFi neighbours. Too many networks in the area can disturb the normal function of the system, especially if you have other networks working on the same channel with you.

  • RickvdBerg Level 1 Level 1 (0 points)

    and i have the same problem to..


    How is it possible that since i got my mac, i felt from the one problem into the other....


    Last night i reinstalled my os, and installed the driver again for my printer. The same that i used before and then worked. At this time i get the error 'filter failed'.


    with a nothebook of 1300 euros and problem after problem after problem.... Thank you very much Apple for convincing me that Apple does not fail, or anything.


    <Edited By Host>

  • @KIRA. Level 1 Level 1 (0 points)

    I had same problem.

    First, uninstall the driver using original CD-ROM  (uninstaller).

    Then, install driver again using CD-ROM.
    I have solved by the method.

  • @KIRA. Level 1 Level 1 (0 points)

    PS. But you shouldn't update printer driver via apple software update.

Previous 1 2 3 Next