Previous 1 2 Next 18 Replies Latest reply: Aug 11, 2012 9:41 AM by ~Bee
margiebehar Level 1 Level 1 (0 points)

The font in Safari's bookmarks bar and tabs bar has suddenly changed to a lighter font.  How do I change the font back?  I'm not speaking of the font size/type in the web browser in viewing web pages, but the font in the application itself has changed. It's rather annoying and would like to be able to change it back!  I'm running Safari v5.1.7

Screen Shot 2012-07-30 at 4.22.17 PM.png


MacBook Pro, Mac OS X (10.7.4)
  • Carolyn Samit Level 10 Level 10 (98,935 points)

    Try deleting the Cache.db

     

    Quit Safari.

     

    Now open the Finder. From the Finder menu bar click Go > Go to Folder

     

    Type this exactly as you see it here:   ~/Library/Caches/com.apple.Safari/Cache.db

     

    Click Go then move the Cache.db file to the Trash.

     

    Relaunch Safari to test.

  • Hombre3000 Level 1 Level 1 (0 points)

    The same thing has just happened to me. I replaced my hard drive (with a Hitachi HGST 750GB) and when I turned on my computer, the font had changed. I cloned the hard drive with SuperDuper and had no problems with it. Everything else is normal (from what I can tell so far).

     

    If anyone has information on this, let me know! I already tried deleting the Cache.db file and it didn't help. Thanks!

  • ~Bee Level 7 Level 7 (31,160 points)

    margie --

     

    You've got a a font substitution going on there.  Open up your Font Book application in your Applications folder.

    It another Sans Serif typface, but it's not Lucida Grande.  Do you have other Lucida's on there?  Look around and let us know, OK?

    It might be Lucida Sans, but it seems more condensed that that one.

     

    I'm assuming you have not added any new free fonts lately, right?

  • Hombre3000 Level 1 Level 1 (0 points)

    I can't speak for Margie, but I did add free fonts. That said, this problem didn't start until today, and I added those fonts a month or 2 ago. I checked in Font Book and I have a lot of duplicates, and some fonts have as many as 7 (!!) copies. I tried disabling them and it hasn't solved the problem. I also tried deleting the font cache files, and then booted into Safe Mode. I think the multiple fonts are causing the problem, but I've gotten totally lost trying to read about managing fonts.

     

    Here's what I did find:

    Safari did display the correct font when the computer was booted in Safe Mode. Upon restarting, it reverted to the light font.

  • ~Bee Level 7 Level 7 (31,160 points)

    Hombre -- here's a hint.  Have a look around and if you can't find the extensions that are causing your problem, please start your onw new discussion, OK?  That way there will be a whole lot less confusion.

     

    Safe mode --

     

    disables most startup items & non-essential extensions etc - so your might have installed some software - perhaps security or antivirus or content filtering - that is causing this to occur.

  • margiebehar Level 1 Level 1 (0 points)

    hi bee, thanx for trying to help me...

    im having exactly the same problem as hombre, i did install new fonts... that i already had in my past macbook and i've never had this problem... i already try to delete duplicates but everything is the same... i already checked my sister's new macbook pro and look for the default fonts and i still have them all... the problem is that i dont know what font is causing this...

    i have many lucida's fonts... but none of them are light like the one that appear in the bookmarks bar...

    im really frustrated and i dont know what to do now... also, if i enter to the guest user in my mac the safari is fine.. the font hasnt changed, its just my user that's wrong

  • ~Bee Level 7 Level 7 (31,160 points)

    OK, Margie, here's what to do . . .

     

    First Quit Safari.

    Then Find your User's (Home) folder library. 

    It's hidden, but here's how you find the Home Library:

    Click on the desktop to get the Finder menu.  Then go up to  "Go" in the menu bar, while holding down the option key.

    You'll now see the User Library in the drop down list. Open it, then look for the Fonts folder.

     

    Take the fonts folder to the desktop.

     

    Restart Safari.

    Any better?

     

    (Warning:  This is only for the Users/Home > Library > Fonts folder.  Under no circumstances, should this be done with the SYSTEM > Library > Fonts folder.) 

  • margiebehar Level 1 Level 1 (0 points)

    i dont have fonts on my user/library/font because i once read that taking out fonts from there it would help.... but i did a mess up there because some of them i install them in system, library, fonts..

    is there a way that i can restore the fonts from the system?...

  • margiebehar Level 1 Level 1 (0 points)

    i think that's not the problem, because in my mom's user in this macbook she dont have this problem going on and there are the exact same fonts installed...

  • ~Bee Level 7 Level 7 (31,160 points)

    Margie --

     

    Can you please copy and paste the list of fonts that are in the SYSTEM folder> Library > fonts folder.  Don't do anything but copy them, and then paste the list here for us to check out, OK?

  • ~Bee Level 7 Level 7 (31,160 points)

    Margie, I just read your most recent post.

     

    On your Mom's account,copy her User's fonts and paste them here for us.

     

    When did you empty YOUR user's font library?  And you're sure it's the User's library?

    If you double click on the Hard drive icon in the upper right corner, then go down to Library, is that the one that's empty on your account?

  • margiebehar Level 1 Level 1 (0 points)

    in the macintosh hd/library/fonts ....i have all my fonts, the ones that i intalled and the ones that came along with my macbook

     

    im macintosh hd/system/library/fonts i have like 20 fonts... here are they... the ones that does not appear in the screenshot are like 5 chinesse fonts...

    Screen Shot 2012-08-10 at 11.04.26 PM.png

    and if i click "go" in finder + option and then click library/fonts there are no fonts there..

     

    i think everything is a mess here... when i installed new fonts i didnt install them via font book... i just paste them in library/fonts

  • ~Bee Level 7 Level 7 (31,160 points)

    So what's in your Library >Fonts.

    (Your System Fonts look pretty good, btw)

    So, can you look in your Library>fonts folder where you posted the new ones, sort by "Date Added?"

    Maybe that was you can locate the messed up font.  It's definitely a condensed font.

     

    If you open Font Book, click on all font, and then type in "condensed" in the search bar, you'll see all the condensed ones.  Anything ring a bell?

     

    I think we have a communications problem when talking about where exactly you put these fonts. 

         

    HD > System > Library > Fonts folder looks fine.

    HD > Users/ Home > Library >Fonts folder is empty?

    HD > Library > Fonts is where you put everything?

     

    That's confusing, because I think the System Fonts relagate the menu bar fonts, systemwide.

  • ~Bee Level 7 Level 7 (31,160 points)

    Margie --

     

    Did you download one of your favorite sites menubars?  Or an app that would "enhance" your menubar?

Previous 1 2 Next