1 Reply Latest reply: Jul 30, 2012 5:12 PM by Kappy
3vet Level 1 (0 points)

I have a MacBook with OS 10.4.11 and need OS 10.5 or newer Software for my Canon Digital camera--- any suggestions?


MacBook, Mac OS X (10.4.11)
  • Kappy Level 10 (265,914 points)

    Snow Leopard General requirements

     

    • Mac computer with an Intel processor
    • 1GB of memory
    • 5GB of available disk space
    • DVD drive for installation
    • Some features require a compatible Internet service provider; fees may apply.
    • Some features require Apple’s MobileMe service; fees and terms apply.

     

    If you need to purchase Snow Leopard you can still purchase a copy from Apple's online store's telesales agents.[1-800-MY-APPLE (1-800-692-7753) or Customer Service and Sales Support at 1-800-676-2775.] Ask for a Sales Representative.

     

    Third-party sources for Snow Leopard are:

     

    Snow Leopard from Amazon.com

    Snow Leopard from eBay